14:06:47 <farheen_att> #startmeeting Architecture Committee
14:06:47 <collabot`> Meeting started Wed Apr 15 14:06:47 2020 UTC.  The chair is farheen_att. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:06:47 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:06:47 <collabot`> The meeting name has been set to 'architecture_committee'
14:07:03 <farheen_att> #info Murali will be hosting the meeting.
14:07:29 <farheen_att> #info agenda user story review
14:07:42 <farheen_att> #topic Acumos-4083
15:04:20 <farheen_att> #info Guy: We decided that the model names should not have spaces.  We can revisit the addition of spaces.  We don't want to generate a uuid.  We will go back and revisit. Consider every model that exists today will have to be updated to have the friendly name vs. scripted
15:04:39 <farheen_att> #action Guy update Acumos-4083 with comments
15:05:10 <farheen_att> #action Murali update Acumos-4083 to a user story instead of a Bug
15:06:27 <farheen_att> #info Guy: this can not be delivered in Demeter and it is not a bug.  This was released in Athena and we can't have last minute bugs because one user decides it needs to be implemented.
15:10:29 <farheen_att> #topic Acumos-4113 Description field search
15:11:11 <farheen_att> #info Rajesh: This issue is a work in progress and being addressed.
15:12:56 <farheen_att> #topic Acumos-4107
15:13:06 <farheen_att> #info FarheenWhen I select my favorite catalogs there should be an actionable button that takes me to My Favorite Catalogs in the Marketplace.Ask: Users are don't know what to do after they select their favorite catalogs. There needs to be a button or link that takes me to My Favorite Catalogs screen.Acceptance Criteria: After I as an MLP System
15:13:07 <farheen_att> user am done selecting my favorite catalogs I want a button that takes me back to My Favorite Catalogs page.
15:13:24 <farheen_att> #info Rajesh: yes we will deliver this in Demeter
15:14:03 <farheen_att> #info  Farheen: Users do not understand why tiles are not clickable.Ask: remove the on mouseover raised catalog tiles action.Acceptance Criteria: When a user hovers over a catalog tile icon the tile stays flat and does not pop up.
15:14:38 <farheen_att> #info Rajesh: We can deliver this in Demeter.
15:15:31 <farheen_att> #info Farheen: Users don't understand why they have to scroll through pages of 10 count catalogs to select a favorite Ask: They want to see all catalogs on one select favorite catalog page. They don't want to have to have multiple selects on multiple pages.Acceptance Criteria: When a user clicks Select Favorite Catalog button from home page they
15:15:31 <farheen_att> land on a single page with all the catalogs listed on it.
15:17:55 <farheen_att> #info Rajesh: Demeter release has moved the #of catalogs drop down from the bottom of the page to the top of the page.  Moved the search catalogs to the right.  That is all we can do in Demeter.
15:19:42 <farheen_att> #info Rajesh: Capturing all the catalogs on one page will take a long time to draw if there are thousands of catalogs.
15:22:41 <farheen_att> #info Creating a list of links like the Catalog page will take time to design and needs to be converted to a user story and moved to the E release.
15:25:44 <farheen_att> #action Farheen change Acumos-4107 to an epic and break up these asks into user stories.
15:29:23 <farheen_att> Users want to see what models are contained inside the catalog.Ask: Users want to see the model names contained within that catalog.  They also want to be able to read the description of the models within the catalog.Acceptance Criteria: A user can see all the catalogs (similar to the Catalog screen for Publisher roles) and when he/she selects a
15:29:24 <farheen_att> catalog they can can click on the models names within that catalog.  Clicking on the model name will bring up the model details page description.  This way the user knows what the model does.  Based on that the user can make the decision of whether he/she wants to select that catalog as his/her favorite.
15:31:18 <farheen_att> #info Michelle: suggestion to have a list of catalogs view of the Marketplace where a user can view a list of catalogs and see what models are contained within that catalog.
15:33:37 <farheen_att> #info Farheen suggestion to leverage the mousover catalog feature in the Marketplace.  Have a similar icon in the Select favorite catalog page where instead of showing a list of catalogs display the list of models.
15:33:59 <farheen_att> #info Rajesh: If there are 100 models that list will look ugly.
15:34:40 <farheen_att> #info Farheen well that will be the same case if we have 100 models but it was done regardless.
15:35:32 <farheen_att> #info Farheen I mean 100 catalogs not 100 models.
15:47:40 <farheen_att> #Farheen: Users want to be brought back to their My Favorite Catalogs page if they navigate away from the Marketplace.Ask: Users select My Favorite Catalogs in the drop down list on the top of the Marketplace screen. They navigate away from My Favorite Catalogs such as click on a model details page. When they return to the Marketplace using the
15:47:40 <farheen_att> back button or the clicking on Marketplace they are brought back to the All Catalogs page. The user is confused because when they return to the Marketplace they do not see the models from their My Favorite Catalogs but instead see All Catalogs. The user has to select My Favorite Catalogs to re-enable their favorite catalogs.Acceptance Criteria:
15:47:41 <farheen_att> When a user navigates away from My Favorite Catalogs then they should return to My Favorite catalogs
15:49:08 <farheen_att> #info Rajesh this can not be done in Demeter and has to be moved to Elpis release.
15:50:22 <farheen_att> #action Murali make updates to Acumos-4083 according to Guy's request.
15:50:30 <farheen_att> #endmeeting