14:04:24 <farheen_att> #startmeeting Architecture Committee
14:04:24 <collabot`> Meeting started Wed Apr 22 14:04:24 2020 UTC.  The chair is farheen_att. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:04:24 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:04:24 <collabot`> The meeting name has been set to 'architecture_committee'
14:04:34 <farheen_att> #topic Agenda
14:06:08 <farheen_att> #info we will cover the architecture diagram changes.
14:06:21 <farheen_att> #info release status and defects by Murali
14:07:34 <farheen_att> #link https://wiki.acumos.org/display/AR/Demeter+Architecture
14:07:52 <farheen_att> #info Manoop sharing the power point slide
14:09:09 <farheen_att> #info added Jenkins Engine to On-boarding which will enable security verification and license checks.
14:11:03 <farheen_att> #info Ken: we found because Jenkins has file share jobs running we had to put the jenkins on the same where all the dockers are running.
14:11:59 <farheen_att> #info Ken: we found because of ms drop in certain prepped file to be run they had to be running on the same core.  I have not crossed that yet with Kubernetes but that is what we found in docker.
14:12:53 <farheen_att> #info Manoop yes, these issues have to be addressed to see how it can be commonly used vs. placing restrictions.  This slide represents a general reliance on the Jenkins engine.
14:13:36 <farheen_att> #info Nat: Suggestion: Instead of putting Jenkins in validation is it possible to put it on the rectangle 7 e1 - e7 to encompass the whole platform.
14:14:16 <farheen_att> #info Manoop: Good suggestion.  Rather than putting on the outer rim of the external api we will choose it as an internal api, internal engine used by this module.
14:15:45 <farheen_att> #info The only services using Jenkins is License check and ms.
14:16:27 <farheen_att> #action Manoop update the architecture slide to spread Jenkins across all components.
14:18:28 <farheen_att> #info Ken: is there a reason why you changed Acu-Compose to Drag and Drop canvas?
14:19:22 <farheen_att> #info Manoop yes, because the name changed.
14:19:36 <farheen_att> #info Reuben: Why is Indigo on the diagram?
14:19:59 <farheen_att> #info Manoop: It was an old project.
14:20:19 <farheen_att> #info Reuben: Indigo is not open source.
14:21:34 <farheen_att> #info Manoop: Guy should we wait to add O-RAN? B or C release?
14:23:21 <farheen_att> #info We have O-RAN SC software contributions that we will after they have been released on O-RAN.
14:25:44 <farheen_att> #info Manoop: I have reviewed the Licensing User,Proxy, LUM and have them positioned accordingly.
14:26:23 <farheen_att> #info Michelle the LUM Proxy is the gateway to LUM.
14:27:01 <farheen_att> #info Michelle: The LUM proxy should be renamed.  LMCL License Manager Client Library.
14:27:49 <farheen_att> #info Michelle: Call it LM License Library.  It should not be represented as a database.  It's a server and doesn't store information.
14:33:56 <farheen_att> #info Michelle: What is the rationale for E7 because I don't reference them.
14:34:12 <farheen_att> #info Manoop: These are for the REST APIs that Justin exposed.
14:34:58 <farheen_att> #info Manoop: The E are external interface.
14:36:17 <farheen_att> #info Reuben: If the LUM requires it's own set of APIs then we could start to add L1, L2,... specific to the LUM.
14:36:53 <farheen_att> #info Michelle: Yes, we need to work on that to update this diagram because we have started using them.
14:37:49 <farheen_att> #action Michelle work with Reuben to incorporate the L interfaces specfiic to licensing and LUM into the overall architecture diagram.
14:38:53 <farheen_att> #info Ken: asterick needs a key or removed.
14:39:14 <farheen_att> #info Manoop: Simulator and Test was something I need clarity on.
14:40:15 <farheen_att> #info Reuben: Training environment One for running and one for testing.  You need a component that deploys the model into test, kicks off the testing, collects the results and then re-onboards the predictor or trained model.
14:41:49 <farheen_att> #info Manoop: Viabhav from ML Workbench have a contribution towards predictors.  Where they want to deploy a test model and evaluate the results and show those evaluated results.
14:42:29 <farheen_att> #action Manoop follow up with Vaibhav regarding the Simulator/Tester **
14:43:07 <farheen_att> #action Nat and Murali request Viabhav to join this architecture call because he is the temporary ML workbench representative.
14:43:19 <farheen_att> #topic Release
14:44:45 <farheen_att> #info we are in the ETE sprint.
14:45:37 <farheen_att> #info Manoop: our plan was to wrap up with Acumos- 3791.
14:46:33 <farheen_att> #action Murali schedule a meeting between Manoop, Sanjay, Vaibhav.
14:56:58 <farheen_att> #info moving on to Licensing: Michelle: Shylender is working on 4084 is the new license manager screen.
14:58:17 <farheen_att> #info Murali reviewed project status https://jira.acumos.org/secure/Dashboard.jspa Choose Demeter release dashboard.
14:58:21 <farheen_att> #endmeeting