09:00:21 <szlin> #startmeeting CIP IRC weekly meeting
09:00:21 <brlogger> Meeting started Thu Mar 28 09:00:21 2019 UTC and is due to finish in 60 minutes. The chair is szlin. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:21 <brlogger> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:21 <brlogger> The meeting name has been set to 'cip_irc_weekly_meeting'
09:00:25 <szlin> #topic rollcall
09:00:31 <szlin> please say hi if you're here
09:00:36 <sangorrin> hi!
09:00:37 <patersonc> hi
09:00:42 <fujita[m]> hi
09:00:47 <szlin> ._./
09:01:12 <szlin> #topic AI review
09:01:16 <iwamatsu_> hi
09:01:19 <szlin> 1. Please send configuration file of kernel 4.19 to cip-dev before the end of March.
09:01:30 <szlin> 2. Daniel has to upload to the wiki the SW updates tool comparison document
09:01:43 <szlin> sangorrin: ^ could you please update this?
09:01:51 <sangorrin> yes
09:01:55 <mungaip[m]> hi
09:02:06 <sangorrin> sorry, I will try to do it in april
09:03:08 <szlin> 3. Add a link to the SW updates wiki page from the embedded world CIP release page
09:03:43 <szlin> sangorrin: ^ could you please update this?
09:03:53 <sangorrin> I think we can drop this one, because Mae didn't update it
09:04:04 <szlin> is it necessary?
09:04:35 <sangorrin> well, it was during the press release.. that's why I uploaded the wiki in a hurry.. but well
09:04:55 <szlin> if it's unnecessary, I'll drop this AI.
09:05:14 <sangorrin> yes, drop it
09:05:22 <szlin> noted.
09:05:29 <szlin> #topic Kernel maintenance updates
09:05:33 <szlin> Iwamatsu announced the 4.4.176-cip31 stable release
09:05:39 <szlin> #info https://lists.cip-project.org/pipermail/cip-dev/2019-March/001962.html
09:05:46 <szlin> iwamatsu_: are you around?
09:05:56 <iwamatsu_> Yes.
09:06:03 <szlin> iwamatsu_: I've question with below link
09:06:05 <szlin> https://gitlab.com/cip-project/cip-kernel/lts-commit-list/blob/master/linux-kernel-v4.4.176-commit.list#L46
09:06:20 <szlin> is it an issue?
09:07:27 <iwamatsu_> I am checking this. There are no problems. Thanks, Pavel.
09:07:46 <patersonc> o/
09:07:47 <sangorrin> wow that review was quick
09:08:12 <iwamatsu_> And I am moving from git to gitlab's wiki. https://gitlab.com/cip-project/cip-kernel/lts-commit-list/wikis/Review-linux-4.4.y.
09:08:15 <szlin> amazing task, isn't it
09:08:38 <szlin> iwamatsu_: okay, so you'll check the review result from Pavel
09:09:08 <iwamatsu_> szlin: yes.
09:09:09 <szlin> #action The review results from Pavel will be confirmed by Iwamatsu-san
09:09:12 <szlin> iwamatsu_: thanks
09:09:17 <szlin> patersonc: go ahead please
09:09:23 <patersonc> I have a question about https://git.kernel.org/pub/scm/linux/kernel/git/cip/linux-cip.git/commit/?h=v4.4.176-cip31
09:09:38 <patersonc> The date of the commit is 2018
09:10:18 <szlin> patersonc: good catch
09:11:03 <patersonc> iwamatsu_?
09:11:20 <iwamatsu_> hmm
09:12:25 <sangorrin> ntp not working?
09:12:48 <iwamatsu_> There may be a problem with my develop machine...
09:13:33 <iwamatsu_> Sorry about that.It's just time to switch to a new PC.
09:13:42 <szlin> iwamatsu_: would you like to update the time with re-uploading?
09:14:29 <iwamatsu_> yes,
09:14:29 <iwamatsu_> I will fix this, and update ASAP.
09:14:29 <iwamatsu_> I will fix this, and update.
09:14:42 <patersonc> Thanks
09:15:01 <iwamatsu_> patersonc: thanks for your check.
09:15:05 <szlin> #action Iwamatsu-san will re-upload the 4.4.176-cip31
09:15:12 <szlin> any other topics?
09:15:15 <szlin> 3
09:15:16 <szlin> 2
09:15:16 <szlin> 1
09:15:16 <patersonc> I have another question, briefly discussed yesterday.
09:15:49 <szlin> iwamatsu_: Chris proposed that we can have patch format with CIP patch
09:16:02 <szlin> I mean, in the patch topic
09:16:23 <patersonc> As we have multiple target branches/repos (4.4/4.19/cip-core), I think we should use identifiers in patch submissions
09:16:24 <patersonc> [PATCH 4.4-y] etc.
09:16:25 <patersonc> Like Biju has done in his latest series yesterday
09:16:54 <iwamatsu_> Yes, I know. I am reviewing about these.
09:17:03 <szlin> and toscalix suggests we can discuss this rule via cip-dev
09:17:52 <patersonc> Good shout. And document on the wiki
09:18:06 <sangorrin> maybe we can use a compose letter and put a subject prefix there
09:18:45 <patersonc> It's easier if it's done in the patches, as patchwork doesn't track cover letters.
09:19:18 <szlin> patersonc: could you send this proposal to cip-dev?
09:19:35 <patersonc> Sure
09:19:46 <szlin> #action The proposal of CIP identifiers in patch submissions will be sent to cip-dev by Chris
09:19:50 <szlin> any other topics?
09:20:07 <patersonc> One more (sorry)
09:20:09 <patersonc> My other question is about how to handle Patchwork. Is someone taking responsibility for assigning patches to maintainers?
09:20:49 <patersonc> s|assigning|delegating
09:20:56 <szlin> patersonc: I can take this task
09:21:28 <patersonc> Thanks
09:21:28 <patersonc> I don't know if Pavel is on the system?
09:21:31 <sangorrin> I think we would need something like redmine
09:22:12 <patersonc> sangorrin: How so?
09:22:25 <szlin> #action Ask for the permission in patchework - szlin
09:22:34 <iwamatsu_> Pavel is not on patchwork.
09:22:39 <sangorrin> oh it can be done in gitlab as well
09:22:57 <patersonc> For patch reviews etc., we have patchwork: https://patchwork.kernel.org/project/cip-dev/list/
09:23:04 <sangorrin> basically you assign an issue to someone in gitlab, and it's pending until the assignee closes it
09:23:07 <patersonc> #info For patch reviews etc., we have patchwork: https://patchwork.kernel.org/project/cip-dev/list/
09:23:25 <sangorrin> ouch
09:23:38 <sangorrin> so we need an account there, dont we?
09:24:03 <patersonc> #info people can create an account on patchwork here: https://patchwork.kernel.org/register/
09:24:12 <sangorrin> ok cool
09:24:43 <patersonc> An account is only needed if patches are to be delegated (maintainers). Developers generally don't need an account to submit patches.
09:25:08 <patersonc> Patches are picked up by Patchwork automatically when they are sent to the cip-dev mailing list.
09:25:45 <szlin> any comments?
09:25:48 <sangorrin> so SZLin will need a list of maintainer user names i guess
09:26:11 <szlin> sangorrin: Indeed, I will track on it
09:27:13 <szlin> any other topics?
09:27:16 <sangorrin> and maybe how many patches each maintainer can review per month, what subsystems he is an expert on..
09:27:34 <szlin> sangorrin: fair enough
09:27:34 <sangorrin> no more topics szlin sorry
09:27:39 <szlin> #topic Kernel testing
09:28:07 <patersonc> We've fixed the MAC address issues on the boards in lab-cip-renesas
09:28:36 <patersonc> Currently investigating a potential DHCP client issue in the CIP v4.4 Kernel
09:28:53 <patersonc> Any questions/comments?
09:29:12 <sangorrin> I added Jan to AWS
09:29:21 <sangorrin> he will prepare images for S3
09:29:45 <sangorrin> maybe with kubernetes
09:30:13 <sangorrin> I tried to create a debian rootfs for iwg20m
09:30:26 <sangorrin> i will upload it at sometime and test it
09:30:31 <patersonc> Great
09:30:38 <patersonc> Thank you
09:30:43 <szlin> any topics?
09:30:45 <sangorrin> it would be nice to have NBD in the long term
09:30:51 <sangorrin> to run some LTP tests
09:31:04 <sangorrin> no more topics from me
09:31:29 <szlin> 3
09:31:29 <szlin> 2
09:31:30 <szlin> 1
09:31:33 <szlin> #topic CIP Core
09:32:04 <sangorrin> deby: we fixed a few issues (See github)
09:32:45 <szlin> any other topics?
09:32:56 <sangorrin> we discussed about naming
09:33:10 <sangorrin> but we will talk about that in tSC
09:33:15 <sangorrin> deby v2 etc
09:33:50 <sangorrin> no more topics
09:33:57 <szlin> #action Discuss the naming of deby in TSC - Daniel Sangorrin
09:34:04 <szlin> 3
09:34:04 <szlin> 2
09:34:05 <szlin> 1
09:34:08 <szlin> #topic Software update
09:34:32 <sangorrin> Suzuki-san produced a working example
09:34:39 <szlin> I've repackaged the swupdate since it released new version.
09:34:43 <sangorrin> of a software update, thanks to Christian for the help
09:34:59 <sangorrin> thanks
09:35:24 <szlin> any other comments?
09:35:27 <szlin> 3
09:35:28 <szlin> 2
09:35:28 <szlin> 1
09:35:36 <szlin> #topic AOB
09:35:40 <szlin> any other business?
09:35:53 <sangorrin> i will be in Thailand next week
09:35:56 <sangorrin> for the Linaro Connect
09:36:03 <sangorrin> if anyone is going let me know
09:36:07 <szlin> sangorrin: stay safe
09:36:12 <mungaip[m]> sangorrin: quick question- I've never worked with NBD, is it hard to set up?
09:36:53 <sangorrin> I haven't either, but it should be something like NFS
09:37:08 <szlin> 3
09:37:09 <szlin> 2
09:37:09 <szlin> 1
09:37:13 <szlin> #endmeeting