09:00:10 <szlin> #startmeeting CIP IRC weekly meeting
09:00:10 <brlogger> Meeting started Thu Apr  4 09:00:10 2019 UTC and is due to finish in 60 minutes.  The chair is szlin. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:10 <brlogger> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:10 <brlogger> The meeting name has been set to 'cip_irc_weekly_meeting'
09:00:18 <szlin> #topic rollcall
09:00:24 <szlin> please say hi if you're here
09:00:33 <iwamatsu__> Hi
09:00:35 <patersonc> hi
09:00:37 <toyooka> hi
09:00:38 <szlin> hi
09:00:39 <mungaip[m]> hi
09:01:05 <szlin> #topic AI review
09:01:13 <szlin> Action items:
09:01:14 <szlin> 1. Iwamatsu-san will re-upload the 4.4.176-cip31
09:01:14 <szlin> -> Done
09:01:14 <szlin> 2. The proposal of CIP identifiers in patch submissions will send to cip-dev – Chris
09:01:16 <szlin> -> Done
09:01:26 <szlin> 3. Ask for the permission in patchwork - szlin
09:01:27 <szlin> -> Done (Thanks to Chris!)
09:01:37 <szlin> 4. Discuss the naming of deby in TSC - Daniel Sangorrin
09:01:46 <szlin> kazu_: ^ any comments?
09:02:33 <szlin> kazu_: are you around ?
09:02:38 <kazu_> As i mentioned in TSC meeting, I need to confirm if we can use cipv1 cipv2... naming or not
09:03:33 <kazu_> it would be better to keep discussion in cip-dev
09:03:36 <szlin> kazu_: may I ask who will make the decision?
09:04:01 <kazu_> I'm not sure
09:05:19 <toscalix> hi
09:05:26 <kazu_> It might be decided in cip-core wg, then approved in TSC meeting
09:05:34 <szlin> kazu_: okay, so you will send the email to cip-dev for further discussion
09:05:45 <kazu_> yes
09:05:54 <toscalix> TSC is to steer, not the default decision forum for group related decisions
09:06:07 <toscalix> in my view
09:07:13 <szlin> toscalix: yap, in my opinion. each group needs to make a decision itself
09:07:42 <toscalix> yes, we communicate them and then if the TSC have a problem.... we take them back to revisit them.
09:08:35 <szlin> toscalix: agree
09:08:50 <toscalix> cip-dev should be our default forum to reacj consensus, assuming the maintainer role, which has a higher responsibility
09:08:51 <kazu_> OK thanks, so this should be decided in cip-core WG
09:09:11 <toscalix> s/reahj/reach
09:09:18 <szlin> pavelm2: welcome!
09:09:47 <pavelm2> Hello.
09:09:52 <szlin> #action Send discussion of deby naming to cip-dev - Kazu
09:10:07 <szlin> 5. Daniel has to upload to the wiki the SW updates tool comparison document
09:10:29 <szlin> kazu_: since Daniel is not here, do you have any update on it?
09:10:43 <pavelm2> It looks like my irc client was connecting me to wrong server, sorry for the delay.
09:10:52 <kazu_> sorry, i don't know any status update about it
09:11:33 <szlin> pavelm2: it's no big deal. thanks for joining
09:11:42 <szlin> kazu_: got it, thanks. I will ask him for the update
09:12:25 <szlin> #action Send email to Daniel for SW update update - szlin
09:12:29 <szlin> 6. The review results from Pavel will be confirmed - Iwamatsu-san
09:12:40 <szlin> iwamatsu__: ^ do you have any comments?
09:13:49 <szlin> iwamatsu__: are you around?
09:14:12 <iwamatsu__> szlin: i dont have any comment. I am reviwing Pavel's comment.
09:14:45 <pavelm2> Ok, so let me comment...
09:15:10 <pavelm2> Reviewing -stable patches is a lot of fun. Unfortunately -stable kernel does not really follow stable kernel rules.
09:15:29 <szlin> iwamatsu__: thanks, I will keep this AI.
09:15:46 <patersonc> :)
09:16:06 <pavelm2> If you have git tree nearby, run "git show 493107105843".
09:16:13 <szlin> pavelm2: please hold on a second :p
09:16:17 <pavelm2> Ok :-).
09:16:23 <szlin> :
09:16:24 <szlin> #topic Kernel maintenance updates
09:16:32 <iwamatsu__> yes, we need to join stable patch review in stable ML.
09:16:35 <szlin> Iwamatsu announced the 4.4.176-cip31 stable release
09:16:35 <szlin> #info https://lists.cip-project.org/pipermail/cip-dev/2019-March/001976.html
09:16:35 <szlin> Daniel announced the 4.4.176-cip31-rt23 stable release
09:16:35 <szlin> #info https://lists.cip-project.org/pipermail/cip-dev/2019-March/001986.html
09:16:44 <szlin> pavelm2: ok, please go ahead :)
09:16:50 <pavelm2> Ok, so...
09:17:09 <pavelm2> Some patches follow the rules and are simple bugfixes.
09:17:16 <pavelm2> Those are marked "ACK: pavel".
09:17:40 <iwamatsu__> https://gitlab.com/cip-project/cip-kernel/lts-commit-list/wikis/Review-linux-v4.4.176
09:18:09 <pavelm2> Some may be good idea, but strictly speaking do not follow the rules.
09:18:19 <pavelm2> Example is 493107105843.
09:18:27 <bwh> Right. The large one you pointed to is part of a security fix.
09:18:36 <szlin> pavelm2: uhh, #493107105843 changed lots of data structure..
09:18:45 <pavelm2> It has more than thousand lines of diff... and basically can't be reviewed.
09:18:58 <pavelm2> It is also spread over multiple commits.
09:18:59 <bwh> And, thankfully there are test cases I could run.
09:19:20 <pavelm2> Yep, testing is good.
09:19:50 <pavelm2> Question is if we could at least get tagging "this does not follow usual rules" and hopefully explanation _why_ this is good idea.
09:20:13 <pavelm2> Because we get original changelog from mainline, but no explanation why it should go to stable.
09:20:42 <bwh> Yes, that seems like a good idea
09:21:09 <pavelm2> It is not needed for simple one-liners, but it would really help for patches as complex as this :-).
09:21:17 <bwh> The cip-kernel-sec repository can tell you which fixes relate to CVE IDs
09:21:52 <bwh> (if the commit message doesn't)
09:21:59 <szlin> #info https://gitlab.com/cip-project/cip-kernel/cip-kernel-sec
09:22:49 <pavelm2> I'll have to take a look at that.
09:22:58 <szlin> pavelm2: agree, the rule could be broken but it needs the reason
09:23:17 <szlin> any comments?
09:23:49 <szlin> 3
09:23:50 <szlin> 2
09:23:51 <szlin> 1
09:23:58 <pavelm2> szlin: Yes, and it would be good to have the reason in some central place.
09:24:27 <szlin> pavelm2: yes!
09:24:31 <szlin> #topic Kernel testing
09:24:37 <patersonc> I have a question about Kernel configs.
09:24:43 <patersonc> (sorry for delay)
09:24:46 <szlin> #undo
09:24:46 <brlogger> Removing item from minutes: #topic Kernel testing
09:25:14 <patersonc> Hopefully we'll submit a renesas_defconfig for arm64 this week.
09:25:32 <bwh> Upstream, or just for CIP?
09:25:41 <patersonc> Do you want it as a patch for the cip v4.19 Kernel? Or just a PR for the config GitLab repo?
09:25:49 <patersonc> Just CIP
09:26:05 <patersonc> Upstream only allows the 'global' defconfig for arm64
09:26:14 <bwh> If I'm going to handle it, either a PR for the config repo or a bare file
09:26:45 <patersonc> Okay. Thanks bwh
09:27:30 <patersonc> Another topic - szlin do you plan to allocate patch reviews on cip-dev patchwork?
09:27:54 <szlin> yes, when I get the permission...
09:28:07 <patersonc> You should have it now?
09:28:15 <patersonc> You're listed as a moderator
09:28:36 <szlin> patersonc: ha, yes I can do it.
09:28:47 <patersonc> :)
09:28:52 <szlin> patersonc: It seems like the permission was granted today :D
09:29:13 <szlin> patersonc: please go ahead with kernel testing
09:29:14 <toscalix> meeting driven development
09:29:56 <iwamatsu__> szlin: Do you assign patch to reviewers? right?
09:30:53 <szlin> iwamatsu__: yap, I will discuss the mechanism with you and pavel after the meeting
09:31:20 <patersonc> Thank you szlin
09:31:46 <iwamatsu__> szlin: ok, thanks.
09:32:04 <szlin> patersonc: any updates on kernel testing?
09:32:24 <patersonc> Not really since the TSC.
09:32:36 <szlin> any comments?
09:32:36 <szlin> 3
09:32:37 <szlin> 2
09:32:37 <szlin> 1
09:32:38 <patersonc> Other than I'd like to encourage some more labs to be set up
09:33:11 <szlin> patersonc: thanks!
09:33:26 <szlin> #topic CIP Core
09:33:49 <szlin> kazu_: do you have any updates?
09:34:16 <szlin> any comments?
09:34:18 <kazu_> There are several miner updates, but no big one
09:34:41 <szlin> kazu_: could you list the updates here?
09:35:58 <kazu_> regarding build systems
09:36:05 <kazu_> deby: support generating minimal rootfs for RPi3 and BBB
09:36:52 <kazu_> EID: add support of building CIP kernel (and other non-Debian sources)
09:37:31 <kazu_> Regarding package lists to be supported by CIP, I need to keep discussion in the ML
09:38:28 <patersonc> kazu_: Is there a plan to support other/all CIP reference platforms?
09:39:36 <kazu_> platforms mean the board lists supported by CIP?
09:39:44 <kazu_> if so, Yes of course
09:40:25 <szlin> any comments?
09:40:28 <patersonc> Thanks
09:40:32 <szlin> 3
09:40:33 <szlin> 2
09:40:34 <szlin> 1
09:40:41 <szlin> #topic Software update
09:40:43 <kazu_> now we are only using BBB for the first PoC, but in future other platforms also should be suported
09:40:54 <szlin> kazu_: thanks!
09:41:03 <kazu_> Sorry for the interrupt, please go ahead
09:41:08 <szlin> kazu_: any updates for software update?
09:41:44 <kazu_> I don't have other updates than the reports from Suzuki-san in the last TSC meeting
09:41:53 <szlin> I will discuss with Stefano with license issue in swupdate.
09:42:28 <szlin> I plan to upload swupdate after license clarification
09:42:37 <szlin> any comments?
09:42:40 <szlin> 3
09:42:40 <szlin> 2
09:42:41 <szlin> 1
09:42:58 <szlin> #topic AOB
09:43:04 <szlin> any other business?
09:43:31 <szlin> 3
09:43:32 <szlin> 2
09:43:32 <szlin> 1
09:43:43 <szlin> #endmeeting