09:00:12 <szlin> #startmeeting CIP IRC weekly meeting
09:00:12 <brlogger> Meeting started Thu Apr 11 09:00:12 2019 UTC and is due to finish in 60 minutes.  The chair is szlin. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:12 <brlogger> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:12 <brlogger> The meeting name has been set to 'cip_irc_weekly_meeting'
09:00:18 <szlin> #topic rollcall
09:00:24 <szlin> please say hi if you're around
09:00:44 <szlin> hi
09:00:45 <iwamatsu> hi
09:00:46 <vidda> hi
09:00:50 <kazu_> hi
09:00:51 <patersonc> hi
09:00:54 <mungaip[m]> hi
09:01:05 <fujita[m]> hi
09:01:13 <szlin> #topic AI review
09:01:18 <szlin> #action Send email to Daniel for SW update update - szlin
09:01:19 <szlin> -> Done
09:01:24 <szlin> #action Daniel has to upload to the wiki the SW updates tool comparison document
09:01:24 <szlin> -> Done
09:01:25 <szlin> #action Send discussion of deby naming to cip-dev - Kazu
09:01:48 <kazu_> I've just reopened the discussion https://lists.cip-project.org/pipermail/cip-dev/2019-April/002074.html
09:02:21 <szlin> kazu_: thanks
09:02:28 <szlin> pave1: hi!
09:02:31 <szlin> #action The review results from Pavel will be confirmed - Iwamatsu-san
09:02:32 <pave1> Hi!
09:02:40 <szlin> iwamatsu: do you have any updates?
09:03:28 <iwamatsu> szlin: I updated a list of review patches.
09:04:30 <szlin> iwamatsu: thanks, have you checked the review result from Pavel?
09:04:42 <iwamatsu> Yes
09:05:32 <iwamatsu> I started from v4.4.176.
09:05:48 <szlin> iwamatsu: thanks!
09:05:55 <szlin> #topic Kernel maintenance updates
09:06:09 <szlin> pave1: do you have any updates?
09:06:44 <pave1> I started pushing patches from patchwork to kernel.org, yes.
09:07:05 <pave1> Unfortunately, series from Renesas seem to depend on each other, so it did not go exactly smoothly.
09:07:36 <iwamatsu> Yes, I think so.
09:07:51 <szlin> I thought this issue has been solved?
09:08:17 <szlin> or it's still there
09:08:28 <pave1> iwamatsu: Would it be ok if I took some of patches assigned to you, and applied them, so I could apply more of my list?
09:09:03 <pave1> szlin: The series do depend on each other. I believe we can figure out how to applie them with iwamatsu.
09:09:18 <pave1> szlin: If not, we can still ask Renesas to create one big series :-).
09:09:20 <patersonc> The guys tend to work together to submit each patch in order.
09:09:31 <szlin> pave1: thanks for your heads-up.
09:09:46 <patersonc> Problem with 1 big series is that we'd have to wait for all work to be complete before submitting everything in one go.
09:10:07 <patersonc> The preference used to be to submit in chunks to make it easier for the maintainers to process
09:10:23 <pave1> patersonc: Problem is that we split the work in patchwork according to the series between me and iwamatsu.
09:10:37 <pave1> patersonc: And that does not really work when series depend on each other.
09:11:14 <patersonc> I guess you can accept each series, but only apply them in order when the relevant series is ready?
09:11:21 <szlin> patersonc: perhaps it can add some notes and thus we can know the relationship between the patches
09:11:54 <iwamatsu> I wrote in an email, but I think it would be helpful to write dependencies on patch cover letters.
09:13:09 <szlin> patersonc: ^ would it be ok?
09:13:12 <pave1> patersonc: Let me try to figure it out... It should be possible to apply most of the patches, then ask Renesas to retransmit the rest.
09:13:35 <patersonc> We can do that for future patches
09:13:51 <patersonc> Let us know what you need resubmitting.
09:14:20 <szlin> patersonc: thanks!
09:14:27 <patersonc> But the easiest approach is to apply patches in the order they were submitted. That should work right fabrizio?
09:15:16 <pave1> patersonc: I believe I tried to do that, too, and it still did not work, but that may have been mistake on my side.
09:16:17 <pave1> patersonc: I'll try to figure it out, soon, and ask for help on the list if it does not work.
09:17:01 <iwamatsu> pavel: I think that the problem that patch can not apply is solved by reviewed commit.
09:17:20 <fabrizio> hi
09:17:39 <iwamatsu> hi
09:17:50 <fabrizio> I think we put down the dependencies in the cover letters for most of the series already
09:18:14 <fabrizio> and we tend to send out series in order of application
09:18:32 <pave1> fabrizio: I guess that is another problem; I got my patches from patchwork, thus got no cover letters :-(.
09:18:48 <pave1> fabrizio: That should not be problem in future as I'm now on the mailing list.
09:19:12 <fabrizio> ok
09:19:43 <szlin> any other topics?
09:19:48 <szlin> 3
09:19:49 <szlin> 2
09:19:49 <szlin> 1
09:19:50 <fabrizio> is there any problem series left behind_
09:20:15 <fabrizio> is there any problematic series left behind?
09:20:24 <pave1> I did not see anything I could not fix up myself during review.
09:20:31 <fabrizio> ok
09:20:42 <fabrizio> so there is no action on us, is that correct?
09:21:12 <pave1> Well, iwamatsu may have seen something, wait for his reply :-).
09:21:22 <fabrizio> ok, thanks
09:21:57 <szlin> #topic Kernel testing
09:23:17 <patersonc> Hi
09:23:18 <szlin> Daniel sent the email to share his trip in Linaro connect
09:23:21 <szlin> #info https://lists.cip-project.org/pipermail/cip-dev/2019-April/002049.html
09:23:36 <sangorrin> yeah, thanks to Renesas for having the lab ready
09:24:02 <szlin> sangorrin: nice slide
09:24:10 <mungaip[m]> sangorrin: glad it worked well :)
09:24:11 <sangorrin> thanks :)
09:24:16 <patersonc> Glad it went okay :)
09:24:39 <szlin> patersonc: do you have any updates?
09:24:39 <mungaip[m]> ls
09:24:46 <patersonc> We're still waiting on LF to resolve the link between the CIP KernelCI and LAVA servers. We cannot fix ourselves as we don't have admin access to either server.
09:25:05 <patersonc> Support for adding a RZ/G2E board to the CIP lab is ready. We just need to find a spare board...
09:25:41 <patersonc> After Veronika's email on automated-testing, I'm wondering if CIP should just report results back to KernelCI.org instead of our own instance?
09:25:56 <sangorrin> Szlin: it would be nice to know the status of Plathome's lab. I think they were going to add their board.
09:26:27 <sangorrin> patersonc: that would be great
09:26:58 <sangorrin> probably we'll know better once we are members (if we decided so during the next OSSJ)
09:27:07 <szlin> #action Ask the status of Plathome's lab - szlin
09:27:42 <patersonc> sangorrin: Let's hope. There is an action on me to investigate further though, but I'm blocked because CIP's instance isn't working..
09:28:26 <sangorrin> patersonc: there is a new version of LAVA. Maybe we should upgrade. It has interactive mode to test u-boot
09:29:06 <patersonc> I'm halfway through rebasing to the latest lava-docker from KernelCI
09:29:19 <sangorrin> patersonc: I think you can test with a local instance (docker compose i think)
09:29:35 <patersonc> sangorrin: Probably :)
09:29:58 <szlin> patersonc: thanks for the update.
09:30:03 <szlin> any other topic?
09:30:11 <szlin> 3
09:30:12 <szlin> 2
09:30:12 <szlin> 1
09:30:19 <szlin> #topic CIP Core
09:30:42 <sangorrin> I am trying to get ISAR working on my environment now
09:31:39 <sangorrin> If we can use ISAR for testing, we will have more flexibility (apt get yay!)
09:32:29 <szlin> sangorrin: thanks for the update
09:32:33 <szlin> any other topic?
09:32:36 <kazu_> I asked if CIP-core needs to decide the supported version combinations of CIP kernel + Debian (See https://lists.cip-project.org/pipermail/cip-dev/2019-April/002074.html )
09:32:38 <sangorrin> hayashi-san is writing something
09:32:44 <sangorrin> oh there you are :D
09:33:05 <szlin> #info https://lists.cip-project.org/pipermail/cip-dev/2019-April/002074.html
09:33:35 <kazu_> I asked Jan about the supported combinations in Isar https://lists.cip-project.org/pipermail/cip-dev/2019-April/002075.html
09:33:45 <szlin> #info https://lists.cip-project.org/pipermail/cip-dev/2019-April/002075.html
09:34:12 <kazu_> but currently cannot get clear answer about the combination
09:34:38 <kazu_> In Isar, all CIP kernel + Debian versions (9,10) are now supported in one branch (master)
09:35:31 <kazu_> In Deby, the supported Debian version depends on the branch
09:36:14 <kazu_> So, it's hard to share the branch name in cip-core repository at this time
09:36:35 <szlin> kazu_: I see, so the discussion will be continued
09:36:49 <kazu_> Yes, I still need to consider what kind of branch names should be used in Tiny profile
09:37:16 <szlin> kazu_: thanks.
09:37:22 <szlin> any other topic?
09:37:31 <szlin> 3
09:37:32 <szlin> 2
09:37:32 <kazu_> Also, I need to re-open the discussion about package list supported in CIP in cip-dev
09:37:32 <szlin> 1
09:38:04 <kazu_> that's all from my side
09:38:15 <szlin> #action Re-open the discussion with package list supported in CIP in cip-dev - Kazu
09:38:20 <szlin> #topic Software update
09:38:31 <sangorrin> Suzuki-san is learning how to use lua handlers in SWupdate and after that will have an online meeting with Christian
09:38:48 <sangorrin> SWUpdate is not exactly easy to use..
09:39:30 <szlin> I've discussed the license issue in swupdate with Iwamatsu-san, and I will contact Stefano in these days..
09:39:31 <sangorrin> if this continues for long, i think we should change to another method
09:39:50 <sangorrin> thanks for that
09:40:07 <szlin> sangorrin: thanks for the update
09:40:14 <szlin> any other topic?
09:40:15 <szlin> 3
09:40:16 <szlin> 2
09:40:16 <szlin> 1
09:40:26 <szlin> #topic AOB
09:40:30 <szlin> any other business?
09:40:49 <szlin> 3
09:40:50 <szlin> 2
09:40:50 <szlin> 1
09:40:55 <patersonc> I'm going to be out of the office for a couple of weeks. mungaip will cover in my absence.
09:41:14 <szlin> patersonc: thanks for the heads-up
09:41:53 <szlin> #endmeeting