09:00:28 <szlin> #startmeeting CIP IRC weekly meeting
09:00:28 <brlogger> Meeting started Thu Apr 25 09:00:28 2019 UTC and is due to finish in 60 minutes.  The chair is szlin. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:28 <brlogger> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:28 <brlogger> The meeting name has been set to 'cip_irc_weekly_meeting'
09:00:34 <szlin> #topic rollcall
09:00:39 <szlin> please say hi if you're here
09:00:42 <iwamatsu> hi
09:00:45 <_gavinlai_> hi
09:00:50 <kazu> hi
09:00:53 <mungaip[m]> hi
09:00:53 <fujita[m]> hi
09:01:08 <pave1> hi
09:01:18 <szlin> #topic AI review
09:01:24 <szlin> AI: The review results from Pavel will be confirmed - Iwamatsu-san
09:01:32 <szlin> iwamatsu: do you have any updates?
09:02:05 <iwamatsu> I am reviewing yet, I do not finish.
09:02:28 <szlin> iwamatsu: thanks.
09:02:35 <szlin> AI: send the patch to Jan for reviewing - kazu
09:02:42 <szlin> kazu: do you have any updates?
09:02:56 <kazu> no updates about this topic
09:03:12 <szlin> AI: deby: update "cip-core_buster" branch - kazu
09:03:35 <kazu> now preparing meta-debian (deby) repository
09:03:55 <kazu> then, create cip-core_buster to use the latest meta-debian repo
09:04:22 <kazu> still in progress
09:04:27 <szlin> kazu: thanks!
09:04:32 <szlin> #topic Kernel maintenance updates
09:04:48 <szlin> pave1: do you have any comments?
09:05:28 <pave1> There is series of USB patches pending on the mailing list.
09:05:46 <pave1> It looks good, so I guess I can apply it.
09:06:11 <pave1> There are DHCP patches pending... and there are two options:
09:06:43 <pave1> a) apply series of 5 (or so) patches that were rejected for -stable.
09:07:01 <pave1> b) apply oneliner to hide the problem.
09:07:23 <pave1> Renesas would prefer a)...
09:07:48 <pave1> But I believe b) may be better option.
09:07:49 <szlin> pave1: do you have any concern on it?
09:08:02 <szlin> iwamatsu: ^any comments?
09:08:45 <iwamatsu> pavel: about USB patches: please apply  and push if there's no problem. ( I can not reply your mail now)
09:08:58 <pave1> szlin: I guess the series will work ok in the end. Technically they break -stable kernel rules,
09:09:43 <pave1> szlin: and as they are in form of "main patch", "fix #1 for main patch", "fix #2 for main patch", they may cause problems for bisecting.
09:09:49 <pave1> iwamatsu: thanks, will do.
09:10:00 <iwamatsu> pavel: thanks!
09:10:23 <szlin> pave1: Fair enough.
09:11:12 <mungaip[m]> pave1: would squashing them solve the issue for bisecting?
09:11:30 <pave1> mungaip: Yes, that would solve the bisecting issue.
09:12:03 <szlin> mungaip[m]: could you contact the patch author?
09:12:33 <pave1> Its okay, its on the mailing list, I can do the contacting and they are willing to squash the patch.
09:12:40 <mungaip[m]> pave1: Okay, I can send the patch for option b to cip-dev later
09:12:56 <mungaip[m]> And then you can make a decision on the best way to go
09:13:20 <szlin> thanks!
09:13:44 <szlin> any other topics?
09:13:57 <szlin> 3
09:13:58 <szlin> 2
09:13:58 <szlin> 1
09:14:21 <szlin> #topic Kernel testing
09:15:04 <mungaip[m]> We should be able to add an RZ/G2E board to the lab in Renesas by mid May
09:15:49 <mungaip[m]> I've created a LAVA account for szlin pave1 iwamatsu , I just need to send you your credentials
09:16:00 <szlin> mungaip[m]: thanks, will you attend OSS-J?
09:16:28 <iwamatsu> mungaip: thanks!
09:16:58 <szlin> mungaip[m]: I would like to exchange keys in person
09:17:12 <szlin> I mean, PGP key
09:17:30 <pave1> mungaip: Thanks, I need to figure out what LAVA can do for me.
09:17:33 <mungaip[m]> szlin: Is that a conference? If so I won't be, but I can find out from Chris if he is
09:17:59 <mungaip[m]> iwamatsu: pave1 szlin: Alternatively, I can give you your credentials over a call?
09:17:59 <szlin> mungaip[m]: noted, thanks.
09:18:22 <pave1> mungaip: Emails I send are normally signed using "Thu 25 Apr 2019 10:19:17 AM CEST using DSA key ID 95DBFAF2" key.
09:18:54 <pave1> mungaip: I guess sending credentials using that key should be secure enough?
09:19:16 <szlin> mungaip[m]: okay, let's discuss it offline
09:19:49 <mungaip[m]> szlin: okay
09:20:12 <pave1> Yup; I think I should ask what LAVA is and how do I use it... but probably better offline, after the meeting.
09:20:30 <szlin> pave1: it's sad story that my company only allows us to use outlook for email client.
09:20:44 <szlin> any other topics?
09:20:57 <szlin> 3
09:20:58 <szlin> 2
09:20:59 <szlin> 1
09:21:00 <szlin> #topic CIP Core
09:21:24 <mungaip[m]> pave1: I'll send you an email later
09:21:29 <kazu> Discussion about supported package list is on going: https://lists.cip-project.org/pipermail/cip-dev/2019-April/002119.html
09:21:44 <kazu> Thank you for a lot of feedbacks
09:21:47 <szlin> kazu: do you have the due date for cip core package discussion? CIP security working group are still discussing the essential security packages.
09:22:12 <kazu> Currently, no clear due date
09:22:20 <szlin> kazu: got it, thanks!
09:22:33 <szlin> any other topics?
09:22:42 <szlin> 3
09:22:43 <szlin> 2
09:22:43 <szlin> 1
09:22:46 <szlin> #topic Software update
09:22:46 <kazu> regarding the package lsit
09:22:50 <kazu> oh,
09:23:04 <kazu> can I go ahead?
09:23:16 <szlin> kazu: ah, of course
09:23:32 <kazu> I attached the package list generated from debootstrap minbase
09:23:53 <kazu> the package name are "source " package name , not binary
09:24:20 <szlin> kazu: thanks!
09:24:21 <kazu> but sometimes the binary package name is also important to know why this source is listed
09:24:32 <kazu> like gcc-8
09:24:49 <kazu> I would like to summarize such information somewhere
09:25:14 <kazu> including the  packages suggested by cip-dev members
09:25:57 <kazu> I also want to consider to decide due date
09:26:26 <kazu> unfortunately, there are many holidays in the beginning of May in Japan
09:26:51 <kazu> so I would like to decide after May 7th
09:26:54 <szlin> kazu: I will notify yoshida-san to provide the estimated time for providing essential security packages
09:27:24 <kazu> OK
09:27:55 <szlin> for Software upate, I've uploaded swupdate into Debian archive few days ago
09:28:02 <szlin> s/upate/update
09:28:15 <szlin> any other topics?
09:28:24 <szlin> 3
09:28:25 <szlin> 2
09:28:26 <szlin> 1
09:28:32 <szlin> #topic AOB
09:29:46 <szlin> I suggest we can skip next week's meeting since many members are unable to join.
09:30:07 <szlin> kazu: enjoy the 10 days holiday
09:30:20 <kazu> szlin: thank you!
09:30:39 <szlin> we can use mailing list to update the status if needed
09:30:45 <szlin> any objections?
09:31:14 <pave1> No objection from me. So.. no phone call next week, no irc meeting next week?
09:31:22 <szlin> pave1: yes.
09:31:35 <szlin> okay
09:31:38 <szlin> #agreed skip next week's IRC meeting
09:31:45 <szlin> any other topics?
09:31:46 <szlin> 3
09:31:47 <szlin> 2
09:31:48 <szlin> 1
09:31:52 <szlin> #endmeeting