09:00:14 <szlin> #startmeeting CIP IRC weekly meeting
09:00:14 <brlogger> Meeting started Thu May 16 09:00:14 2019 UTC and is due to finish in 60 minutes.  The chair is szlin. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:14 <brlogger> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:14 <brlogger> The meeting name has been set to 'cip_irc_weekly_meeting'
09:00:21 <szlin> #topic rollcall
09:00:28 <szlin> please say hi if you're here
09:00:31 <iwamatsu> hi
09:00:32 <patersonc> hi
09:00:33 <vidda> hi
09:00:36 <pave1> hi
09:00:49 <mungaip[m]> hi
09:00:55 <fujita[m]> hi
09:01:05 <kazu_> hi
09:01:08 <szlin> #topic AI review
09:01:12 <szlin> AI: Send list of binary packages to cip-dev - kazu
09:01:27 <kazu_> See https://lists.cip-project.org/pipermail/cip-dev/2019-May/002225.html
09:01:41 <szlin> #info https://lists.cip-project.org/pipermail/cip-dev/2019-May/002225.html
09:01:46 <szlin> kazu_: thank you!
09:01:49 <szlin> -> Done
09:01:55 <szlin> #topic Kernel maintenance updates
09:02:23 <szlin> iwamatsu: pave1 give the floor to you
09:02:47 <pave1> I did some more reviews.
09:03:31 <pave1> More importantly, I created scripts that allow me to tell when the same patch was reviewed in 4.4 / 4.19, so it is easier to mark it as already reviewed.
09:03:48 <pave1> Results are in lts-commit-list repository.
09:03:55 <patersonc> Nice
09:03:56 <iwamatsu> pavel: thanks
09:04:14 <pave1> We should at some point decide where to put such scripts.
09:04:37 <szlin> pave1: thank you!
09:04:41 <pave1> But from the conference call... it seems that more pressing issue is that we should actually do some kernel releases :-).
09:05:01 <patersonc> Ha
09:05:36 <patersonc> pave1: iwamatsu: I had a question about the patches from Fab
09:06:17 <patersonc> iwamatsu-san has asked Fab to do a v2 on the novel patches, however I think they have already been applied by pave1
09:06:29 <patersonc> How should we continue?
09:06:37 <pave1> Yep, sorry about that. I guess I was a bit too quick there.
09:07:32 <iwamatsu> pavel: no problem. I guess we use force push.
09:07:41 <patersonc> No worries :)
09:08:00 <szlin> pave1: could you share the script? not sure if you already did.
09:08:07 <patersonc> Okay. I'll ask Fab to repost the whole series then to make it easier for you.
09:08:39 <pave1> iwamatsu: If we decide to rollback the repository, we should do it ASAP (because it will cause problems for people pulling it in the meantime).
09:09:03 <iwamatsu> patersonc: OK, thanks.
09:09:14 <patersonc> pave1: Agreed
09:09:21 <patersonc> We should work out a way to avoid this in future though.
09:09:39 <iwamatsu> pavel: Agree. I will rollback now
09:09:48 <pave1> iwamatsu: Thanks!
09:10:34 <szlin> any other topic?
09:10:36 <pave1> szlin: Yes, I can. I guess easiest option would be to put it directly into lts-commit-list repository.
09:10:45 <szlin> pave1: yes, please
09:10:51 <pave1> szlin: ok ;-).
09:10:53 <szlin> pave1: thank you for your great effort
09:11:02 <iwamatsu> pavel: and about your scirpt of reviewing, I think you can use -commit-list repository.
09:11:03 <szlin> Ben shared the news with MDS and other speculation issues
09:11:07 <szlin> #info https://lists.cip-project.org/pipermail/cip-dev/2019-May/002305.html
09:11:09 <iwamatsu> pavel: OK
09:11:31 <sangorrin> do we need to update microcode?
09:11:46 <sangorrin> the latest seems old: https://downloadcenter.intel.com/download/28087/Linux-Processor-Microcode-Data-File
09:12:20 <pave1> sangorrin: If you run Intel CPUs in production then yes, microcode update is needed AFAICT.
09:13:01 <sangorrin> ok, I will wait until it is published then
09:13:30 <szlin> #action Upload check script to lts-commit-list repository - Pavel
09:13:41 <szlin> any other topic?
09:13:54 <szlin> 3
09:13:55 <szlin> 2
09:13:56 <szlin> 1
09:14:02 <pave1> ye
09:14:04 <pave1> yes.
09:14:22 <pave1> In the emails, there was a question when to do the -cip kernel releases.
09:14:46 <pave1> I'd say it does not matter much _when_ we do it, as long as we do them relatively regulary.
09:14:57 <pave1> But it sounds like we should do one now.
09:15:20 <patersonc> Agreed.
09:15:27 <pave1> iwamatsu: Can you do the release (and perhaps document steps doing so)?
09:15:43 <pave1> Or should I attempt to do a release? Or is there good reason release should wait?
09:16:22 <iwamatsu> pavel: OK, I will release 4.4 and 4.19.
09:16:39 <pave1> iwamatsu: Thanks!
09:16:44 <szlin> iwamatsu: do you have the time table?
09:16:51 <iwamatsu> I will start working after this meeting.
09:18:00 <szlin> #action 4.4 and 4.19 kernel will be released - iwamatsu
09:18:11 <iwamatsu> szlin: for release? I can release it tomorrow morning at japan time.
09:18:30 <szlin> iwamatsu: got it, thanks.
09:18:42 <szlin> iwamatsu: can you prepare the release document for us?
09:18:59 <sangorrin> maybe it would be good to release 4.4 after the spectre test
09:19:14 <sangorrin> Ben mentioned that he didn't test it much
09:19:27 <pave1> sangorrin: I'd prefer to do the release now. I've seen the patches...
09:19:34 <iwamatsu> szlin: sure
09:19:39 <szlin> #action Prepare the CIP kernel release document - Iwamatsu
09:19:43 <szlin> iwamatsu: many thanks!
09:19:46 <pave1> ..and there's 260 of them. That will take some time.
09:19:47 <fujita[m]> iwamatsu: I have a question
09:20:04 <sangorrin> pave1: OK
09:20:07 <pave1> We'll probably want to do another release after it settles down, but I'd not slow it down now.
09:20:10 <iwamatsu> sangorrin: 4.4.180 is not release yet. We need to release this version.
09:20:33 <fujita[m]> Can we assume 4.19 is suitable for 32bit Arm arch?
09:21:18 <fujita[m]> Currently no 32bit arm boards are used for 4.19
09:21:31 <szlin> #agree Release CIP kernel 4.4 without MDS and other speculation patches
09:22:06 <iwamatsu> fujita[m]: Yes, I think so. 4.19
09:22:07 <iwamatsu> 4.19 is also used by other ARM SoCs.
09:22:22 <fujita[m]> Understood. Thanks
09:22:27 <szlin> any other topic?
09:23:18 <szlin> #topic Kernel testing
09:23:48 <iwamatsu> If renesas does not support aarch32 in 4.19, we may need to consider other ARM SoCs as real hardware.
09:24:35 <patersonc> iwamatsu: The iwg20m and iwg22m are present in the v4.19 Kernel, but Renesas doesn't have a BSP using that Kernel
09:25:06 <iwamatsu> patersonc: 4,4.y only use?
09:25:13 <patersonc> I guess there is no reason not to support iwg20m in cip-core with v4.19, so we can probably still test the CIP Kernel
09:25:38 <patersonc> iwamatsu: Our RZ/G1 BSP uses CIP v4.4. The RZ/G2 BSP uses CIP v4.19
09:25:48 <pave1> fujita: What SoC do you use? I believe best option would be to test a similar configuration.
09:26:03 <fujita[m]> Renesas can also propose another boards for 4.19 if you want.
09:26:27 <iwamatsu> patersonc: I see.
09:26:28 <pave1> fujita: 32-bit vs. 64-bit is only part of the problem... There is a lot of drivers involved.
09:26:31 <fujita[m]> Currently, we are using RZ/G1 and G2 series SOCs
09:26:42 <sangorrin> patersonc: we should use cip-core not renesas bsp (as a project)
09:26:43 <pave1> fujita: Aha, ok.
09:26:50 <patersonc> sangorrin: Agreed
09:27:11 <fujita[m]> sangorrin: I also agreed
09:27:26 <fujita[m]> pave1: correct
09:28:32 <szlin> any other topic?
09:28:53 <szlin> for kernel testing
09:29:02 <patersonc> For testing...
09:29:17 <patersonc> As mentioned in the TSC we now have an RZ/G2M board in the LAVA lab
09:29:23 <patersonc> Good for v4.19 testing
09:29:32 <patersonc> iwamatsu: I see you've already run a test - great
09:29:37 <sangorrin> patersonc: do we have spectre/meltdown tests?
09:29:59 <patersonc> sangorrin: Not at the moment
09:30:39 <szlin> patersonc: thank you for your work :D
09:30:52 <patersonc> szlin: It was all mungaip :)
09:31:02 <sangorrin> patersonc: i will try to add them when i get some time
09:31:05 <szlin> mungaip[m]: :D
09:31:11 <patersonc> sangorrin: Great
09:31:20 <szlin> any other topic?
09:31:34 <szlin> 3
09:31:34 <szlin> 2
09:31:35 <szlin> 1
09:31:38 <szlin> #topic CIP Core
09:31:44 <patersonc> sangorrin: If you get time, can you submit a PR to https://gitlab.com/cip-project/cip-testing/cip-kernel-tests?
09:32:02 <sangorrin> patersonc: yes
09:32:09 <szlin> The CIP Security WG plans to provide the essential packages (est.)two weeks later
09:32:31 <kazu_> szlin: thank you for the confirmation
09:32:32 <szlin> kazu_: give the floor to you
09:32:41 <sangorrin> cip-core will need more resources to deal with the requirements from cip security
09:32:57 <szlin> sangorrin: do you mean human resources?
09:33:11 <sangorrin> there are many things to add: microcode loading, encryption, integrity, secure boot?, apparmor..
09:33:28 <sangorrin> yeah, we need to collaborate between both groups
09:33:59 <szlin> let's loop these two groups
09:34:19 <sangorrin> szlin: sure
09:34:28 <szlin> we can have a discussion with it, I can arrange this.
09:34:50 <szlin> kazu_: sangorrin is it ok for you?
09:35:13 <kazu_> szlin: Yes
09:35:30 <szlin> #action Arrange a meeting between CIP core and CIP security WG - szlin
09:35:35 <szlin> any other topic?
09:35:38 <kazu_> In the above mail, I proposed the next steps to decide supported package list. I need to decide the due date for additional discussion, it should be before the next TSC meeting.
09:36:25 <kazu_> #info https://lists.cip-project.org/pipermail/cip-dev/2019-May/002225.html
09:36:31 <szlin> kazu_: thank you for the update
09:36:53 <szlin> any other topic?
09:36:54 <szlin> 3
09:36:55 <szlin> 2
09:36:55 <szlin> 1
09:37:06 <szlin> #topic Software update
09:37:28 <sangorrin> No updates, we will have a meeting next week.
09:37:42 <sangorrin> If someone wants to participate in the group/meetings let me know.
09:37:57 <szlin> sangorrin: is it a public or private meeting?
09:38:28 <sangorrin> it is open to any CIP member
09:38:43 <szlin> sangorrin: I see, could you send the invitation email to cip-members?
09:39:06 <sangorrin> ok, I will ask Christian
09:39:09 <szlin> sangorrin: thank you.
09:39:14 <szlin> any other topic?
09:39:25 <szlin> 3
09:39:25 <szlin> 2
09:39:26 <szlin> 1
09:39:29 <szlin> #topic AOB
09:39:34 <szlin> any other business?
09:40:00 <szlin> 3
09:40:01 <szlin> 2
09:40:02 <szlin> 1
09:40:06 <szlin> #endmeeting