09:00:38 <gavinlai> #startmeeting CIP IRC weekly meeting
09:00:38 <brlogger> Meeting started Thu Jun 27 09:00:38 2019 UTC and is due to finish in 60 minutes.  The chair is gavinlai. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:38 <brlogger> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:38 <brlogger> The meeting name has been set to 'cip_irc_weekly_meeting'
09:00:50 <gavinlai> #topic rollcall
09:00:54 <gavinlai> please say hi if you're here
09:00:57 <pave1> hi
09:00:59 <Yamamodo> hi
09:01:10 <fujita[m]> hi
09:01:11 <patersonc> hi
09:01:16 <hiraku> hi
09:01:17 <kazu> hi
09:01:32 <sangorrin> hi
09:02:00 <gavinlai> #topic AI review
09:02:13 <gavinlai> 1. Provide the script for CIP kernel config collection - bwh
09:02:29 <pave1> I don't see bwh on the rollcall.
09:02:32 <gavinlai> #link https://lists.cip-project.org/pipermail/cip-dev/2019-June/002506.html
09:02:53 <gavinlai> I guess bwh is not around. I will keep this action item
09:03:01 <gavinlai> #action Provide the script for CIP kernel config collection - bwh
09:03:10 <gavinlai> 2. List real time kernel questions to ask Daniel Wagner - szlin
09:03:32 <gavinlai> szlin is collecting the questions. He plans to send the questions next week.
09:03:48 <gavinlai> #action List real time kernel questions to ask Daniel Wagner - szlin
09:03:55 <gavinlai> 3. Try updating CIP RT kernel to 4.19.50 - Pavel
09:04:21 <gavinlai> pave1: (wave
09:04:25 <pave1> So... I have something that builds for me. 4.19 turned out to be relatively easy.
09:04:36 <pave1> I posted pointers to the list.
09:04:50 <pave1> What I really need at the moment is someone to step up and run the tests for me.
09:05:35 <pave1> I'm currently configuring test machine, because testing on development machines is unpleasant.
09:05:48 <pave1> But that will result in "does it boot" tests, not "is it realtime" tests.
09:06:33 <patersonc> If you have a Kernel that is built for RT it should be easy enough for us to test with Daniel's jittertest
09:06:50 <patersonc> Using the LAVA lab
09:07:07 <sangorrin> yeah or rt-tests
09:07:11 <pave1> Ok, that would be great. Can we coordinate it after the meeting?
09:07:15 <patersonc> Sure
09:07:20 <pave1> Thanks!
09:07:30 <gavinlai> :)
09:08:00 <sangorrin> https://github.com/Linaro/test-definitions/tree/master/automated/linux/cyclictest
09:08:35 <sangorrin> pave1: you will probably want to use Chris's CI
09:08:43 <sangorrin> for the kernel build
09:08:54 <patersonc> :)
09:09:03 <pave1> I hope someone can configure that for me ;-).
09:09:31 <patersonc> Sure
09:10:24 <gavinlai> move to next topic?
09:10:31 <pave1> Yes.
09:10:32 <gavinlai> #topic Kernel maintenance updates
09:11:12 <pave1> So... I reviewed 4.19.54 and 4.19.56 (regular size) and then tiny releases of 4.19.52 and 4.19.55
09:11:29 <pave1> I played with the realtime, as discussed before.
09:11:41 <pave1> I guess I should mention... I'll be traveling next week.
09:11:45 <pave1> ...that's all from me.
09:11:57 <gavinlai> pave1: thanks
09:12:24 <gavinlai> any comments?
09:12:46 <gavinlai> #topic Kernel testing
09:12:49 <sangorrin> Unrelated to Pavel's comments but as you may have seen I have been sending some patches for cip-kernel-sec.
09:13:03 <gavinlai> #undo
09:13:03 <brlogger> Removing item from minutes: #topic Kernel testing
09:13:31 <pave1> I guess I should relay...
09:13:41 <sangorrin> These scripts are very useful to track down CVE IDs
09:13:50 <patersonc> Good work
09:13:57 <sangorrin> I added functionality for tracking product kernels
09:14:07 <Yamamodo> sangorrin: thanks your help for cip-kernel-sec, we expect this tool very well:)
09:14:14 <gavinlai> sangorrin: the scripts are really helpful
09:14:29 <pave1> Nobuhiro says: I reviewd v4.4.163, and I released v4.4.182-cip34 and v4.19.52-cip4.
09:14:29 <pave1> And I am working
09:14:29 <pave1> I am testing to release a CIP kernel based on v4.19.56 tomorrow.
09:14:37 <sangorrin> great to know thanks
09:14:43 <pave1> (End of Nobuhiro's message)
09:15:38 <gavinlai> next topic ?
09:16:08 <gavinlai> #topic Kernel testing
09:16:33 <patersonc> Hello
09:16:38 <patersonc> #info lab-cip-mentor should be online today with a qemu machine. Mentor will then add the SIMATIC IPC227E and Cyclone V DE0-Nano-SoC boards.
09:16:48 <patersonc> #info We now have direct access to the CIP LAVA master (thank you Ryan). This should make maintenance a bit easier.
09:16:58 <patersonc> #info I've created a linux-cip-ci repository that creates build and test Docker containers that can be used to build the linux-cip Kernel using GitLab CI/CD.
09:17:02 <patersonc> Example usage of this can be found in the chris/linux-4.19.y-cip-ci-test branch in the linux-cip GitLab repo.
09:17:07 <patersonc> #link https://gitlab.com/cip-playground/linux-cip-ci
09:17:13 <patersonc> There's a lot functionality to add, but I'll get there :)
09:17:31 <patersonc> Discussion topics:
09:17:36 <patersonc> 1)
09:17:39 <patersonc> How would the Kernel maintainers like me to submit the gitlab-ci.yml files to the CIP Kernel branches? Mailing List or merge request in GitLab?
09:17:44 <patersonc> Should they be applied to the kernel.org repo? Or just the GitLab mirror?
09:18:07 <pave1> Umm.
09:18:30 <pave1> I don't think we want them in kernel repositories.
09:18:45 <pave1> Those are normally not part of kernel sources, right?
09:19:00 <patersonc> There aren't any in mainline, no
09:19:17 <patersonc> Another option is I create a separate repo for the CI files
09:19:19 <pave1> We keep other stuff needed for build in cip-kernel-config repository.
09:19:24 <pave1> Would it be ok to put those there, too?
09:19:38 <pave1> git@gitlab.com:cip-project/cip-kernel/cip-kernel-config.git
09:20:00 <patersonc> I can, but there is a special project type in GitLab that is just for CI/CD builds
09:20:14 <sangorrin> The problem is that cross-triggers are paid
09:21:20 <patersonc> I'll have an experiment
09:21:24 <sangorrin> if you use two repositories (kernel and tests), then you can not trigger the tests when you push new patches to the kernel unless you have paid support (if i remember correctly)
09:21:33 <pave1> Ok, I don't really know how gitlab makes money.
09:21:54 <sangorrin> btw, patersonc: the script has changed a lot!!
09:22:00 <patersonc> sangorrin: Okay, I'll have a look
09:22:28 <pave1> So that means both separate repository and putting it in cip-kernel-config have this "give us money" disadvantage?
09:23:12 <sangorrin> I think so, but patersonc says he will have a second look
09:23:37 <patersonc> sangorrin: You might be right: https://docs.gitlab.com/ee/ci/ci_cd_for_external_repos/
09:23:45 <gavinlai> patersonc: any other discussion topics?
09:23:45 <patersonc> Is CIP using a free account then?
09:23:51 <pave1> Aha, ok. In such case putting it into gitlab kernel sources would make some sense.
09:23:55 <sangorrin> https://docs.gitlab.com/ee/ci/multi_project_pipelines.html
09:24:31 <sangorrin> patersonc: I think so
09:24:42 <patersonc> gavinlai: yes
09:24:56 <patersonc> At the moment the backups from the LAVA master are only stored locally.
09:25:01 <patersonc> Is it okay to create a private repository on CIP's GitLab pages to store the backups?
09:25:06 <patersonc> Downside is that all of the CIP 'owners' will get access to keys etc. Does anyone have a problem with this?
09:25:32 <pave1> Or maybe... someone is running mirroring from kernel.org to gitlab. Maybe same script can trigger the CI?
09:26:28 <patersonc> pave1: let's discuss after the meeting
09:26:38 <pave1> patersonc: ok
09:27:19 <patersonc> Any objections to storing LAVA backups in CIP's GitLab account?
09:27:37 <sangorrin> do you mean logs?
09:27:41 <sangorrin> or the source code?
09:28:00 <pave1> Dunno. Storing keys in gitlab does not sound right.
09:28:11 <patersonc> sangorrin: Everything
09:28:43 <patersonc> Source is already in GitLab, but private details are just stored locally
09:29:30 <Yamamodo> patersonc: do you mean you want to upload private detail to gilab for LAVA ?
09:29:44 <pave1> That sounds like a right design to me :-). I don't think 3rd parties should be trusted with private data.
09:29:59 <patersonc> Yes. We'd make the repo private.
09:30:15 <patersonc> Open to other ideas?
09:30:20 <sangorrin> private repositories need a paid account though
09:30:32 <patersonc> Not on Gitlab
09:30:40 <sangorrin> oh
09:30:41 <patersonc> It's github you have to pay
09:31:30 <pave1> If it is just a backup, encryption could help?
09:31:50 <patersonc> True
09:32:50 <patersonc> #info lab-cip-mentor is now up and running: https://lava.ciplatform.org/scheduler/worker/lab-cip-mentor
09:33:02 <patersonc> (thank you mungaip )
09:33:07 <sangorrin> that was fast
09:33:12 <sangorrin> good work
09:33:45 <patersonc> I'll re-think where to store backups.
09:33:48 <patersonc> gavinlai: let's move on
09:33:57 <gavinlai> :)
09:34:09 <gavinlai> #topic CIP Core
09:34:11 <patersonc> #action Work out a solution for LAVA master backups - patersonc
09:34:22 <gavinlai> patersonc: thanks :)
09:34:39 <kazu> I'm still updating the "Package decision process" based on the action items in the last meeting
09:34:48 <kazu> would like to share its URL by the next Fri or Mon...
09:35:01 <kazu> That's all from me,
09:35:08 <kazu> daniel: do you have more?
09:35:35 <sangorrin> iwg20m support in ISAR is about to occur
09:35:48 <sangorrin> Jan is upgrading isar-cip-core to the latest ISAR
09:35:58 <sangorrin> because that ISAR contains my bmap patch
09:36:24 <sangorrin> once that upgrade is done, I want to deploy the isar-cip-core builds to AWS and trigger LAVA jobs
09:36:29 <sangorrin> including RT kernels
09:37:25 <gavinlai> next topic?
09:37:44 <gavinlai> #topic Software update
09:37:56 <sangorrin> #info We are working on the PoC demo for OSSJ2019
09:38:03 <sangorrin> #info Raw image updates with Hawkbit on the server side working#info TODO: finish u-boot script, use librsync, rollback example
09:38:08 <sangorrin> shit
09:38:13 <sangorrin> #info Raw image updates with Hawkbit on the server side working
09:38:18 <sangorrin> #info TODO: finish u-boot script, use librsync, rollback example
09:38:40 <sangorrin> we have two more weeks '=(
09:38:57 <patersonc> :)
09:39:20 <gavinlai> sangorrin: thanks
09:39:46 <gavinlai> #topic AOB
09:41:17 <gavinlai> #endmeeting