09:00:06 <szlin> #startmeeting CIP IRC weekly meeting
09:00:06 <brlogger> Meeting started Thu Jul 4 09:00:06 2019 UTC and is due to finish in 60 minutes. The chair is szlin. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:06 <brlogger> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:06 <brlogger> The meeting name has been set to 'cip_irc_weekly_meeting'
09:00:14 <szlin> #topic rollcall
09:00:16 <bwh> hi
09:00:20 <szlin> please say hi if you're here
09:00:25 <kazu> hi
09:00:31 <patersonc> hi
09:00:32 <iwamatsu> hi
09:00:37 <fujita[m]> hi
09:00:59 <szlin> #topic AI review
09:01:01 <szlin> 1. Provide the script for CIP kernel config collection - bwh
09:01:02 <szlin> #link https://lists.cip-project.org/pipermail/cip-dev/2019-June/002506.html
09:01:17 <szlin> please provide your comment or suggestion on it
09:01:31 <szlin> bwh: do you have any comment?
09:02:02 <Yamamodo> hi
09:02:29 <szlin> 2. List real time kernel questions to ask Daniel Wagner - szlin
09:02:40 <szlin> I will send the mail before this week
09:02:43 <bwh> szlin: I will merge those changes this week or next week
09:02:59 <szlin> bwh: thank you.
09:03:01 <szlin> 3. Try updating CIP RT kernel to 4.19.50 - Pavel
09:03:20 <szlin> Since pavel is not here today, I will send the email to him.
09:03:33 <szlin> 4. Work out a solution for LAVA master backups - patersonc
09:03:40 <szlin> patersonc: do you have any update?
09:03:49 <patersonc> Nope
09:04:02 <szlin> ok,I will keep it.
09:04:05 <szlin> #topic Kernel maintenance updates
09:04:51 <szlin> Yamamodo and I are starting to review failed patches.
09:05:11 <szlin> iwamatsu: bwh do you have any update on kernel maintenance updates topic?
09:05:33 <bwh> I don't
09:05:37 <iwamatsu> szlin: last friday, I updated cip kernel 4.19.y (4.19.56-cip5)
09:06:07 <szlin> iwamatsu: thank you!
09:06:29 <pave1> hi
09:06:45 <iwamatsu> hi, pave1
09:07:06 <szlin> pave1: hi! you're just in time
09:07:19 <szlin> pave1: do you have any update in kernel maintenance updates topic?
09:07:32 <pave1> sorry for being late. I am travelling.
09:07:53 <pave1> Yes. I did partial review of 4.19.57.
09:08:09 <szlin> pave1: no worry, thank you.
09:08:27 <szlin> any other comments?
09:08:30 <pave1> Plus I am searching for suitable target for realtime testing.
09:08:59 <pave1> Good news is that I am now able to do some testing.
09:09:02 <pave1> Thats all from me.
09:09:13 <szlin> pave1:thanks.
09:09:15 <szlin> 3
09:09:18 <szlin> 2
09:09:19 <szlin> 1
09:09:28 <szlin> #topic Kernel testing
09:09:43 <patersonc> Hello
09:09:44 <patersonc> #info Mentor are currently adding a Siemens IPC 227E X86 board to lab-cip-mentor, hence it's currently offline.
09:09:49 <patersonc> #info I've been continuing to improve the linux-cip-ci scripts. I should hopefully have it all completed by OSS-J.
09:09:59 <patersonc> Discussion points (1):
09:10:02 <patersonc> 1/1: Kernel maintainers: What do we want to do with the .gitlab-ci.yml files?
09:10:09 <patersonc> Add them to the main kernel.org repo?
09:10:11 <patersonc> +ve Builds are easily triggered on changes
09:10:14 <patersonc> +ve Each commit gets a pretty green tick
09:10:17 <patersonc> -ve The kernel.org repo ends up with irrelevant .gitlab-ci.yml files
09:10:20 <patersonc> -ve Kernel maintainers will need to merge updates to the gitlab ci files
09:10:23 <patersonc> Create a separate repo and use hooks to trigger builds? (untested, but I assume it'll work)
09:10:26 <patersonc> +ve Keeps the kernel.org repo clean
09:10:29 <patersonc> +ve Testing team can manage CI files independently
09:10:32 <patersonc> -ve No pretty green ticks in GitLab
09:10:36 <patersonc> -ve You have to go to a seperate repository to see what has been built/tested
09:10:44 <patersonc> over to you...
09:11:21 <pave1> I do not have strong opinion on that one.
09:11:22 <szlin> patersonc: I suggest you to email above items via cip-dev or cip-members
09:11:53 <szlin> After all, some people didn't attend today's meeting
09:12:06 <patersonc> szlin: Okay, but there is already a discussion on cip-dev based off a patch I submitted. No input from the maintainers though, just Danial and Jan
09:12:10 <szlin> patersonc: is that ok for you?
09:12:40 <patersonc> Does anyone in this meeting have an opinion?
09:13:26 <szlin> patersonc: I see.
09:13:28 <iwamatsu> patersonc: I want to keep kerne repo, if possible.
09:13:49 <szlin> iwamatsu: pave1 bwh ^ please provide your valuable opinion
09:14:13 <bwh> I think I prefer the first option
09:14:45 <patersonc> iwamatsu: Is that the first option?
09:14:46 <patersonc> Thanks bwh
09:14:47 <pave1> I'd say we can do whatever is easiest. We can always change things if it is problematic.
09:14:59 <szlin> pave1: agree
09:15:04 <iwamatsu> patersonc: Yes, first opinion.
09:15:10 <patersonc> Thank you all.
09:15:21 <pave1> commiting changes from testing team should not be hard.
09:15:46 <szlin> patersonc: first option is " Add them to the main kernel.org repo"
09:15:54 <patersonc> szlin: yep
09:16:00 <szlin> any objection?
09:16:11 <patersonc> pave1: Nope. I can just submit patches to cip-dev. Same process as any other patch
09:16:32 <szlin> #agree Add .gitlab-ci.yml files to the main kernel.org repo
09:16:38 <szlin> any other comments?
09:16:39 <szlin> 3
09:16:40 <szlin> 2
09:16:41 <szlin> 1
09:16:42 <patersonc> Thank you all!
09:16:58 <szlin> patersonc: thank you for your proposal
09:17:01 <szlin> #topic CIP Core
09:17:14 <kazu> no technical updates in this week,
09:17:33 <kazu> I'm still creating the document of package decision process,
09:17:42 <kazu> I have to finish before the next TSC meeting
09:17:43 <szlin> kazu: thank you
09:17:47 <szlin> any other comments?
09:17:50 <kazu> sorry for the delay
09:18:23 <szlin> 3
09:18:24 <szlin> 2
09:18:25 <szlin> 1
09:18:34 <szlin> #topic Software update
09:18:50 <szlin> == Quote from Suzuki ==
09:18:50 <szlin> We are preparing a software update demo for OSSJ.
09:18:50 <szlin> We had a meeting with Christian of Siemens and he shared a sample script
09:18:50 <szlin> that could manage the state of software update.
09:18:51 <kazu> Suzuki-san sent the updates to cip-dev
09:18:52 <szlin> Suzuki implemented the state management into the u-boot script of the demo
09:18:55 <szlin> and now BeagleBone Black can switch back to old root filesystem if the update fails.
09:18:58 <szlin> We call it "rollback".
09:19:00 <szlin> Now we can give the demo of raw image update only.
09:19:03 <szlin> If we can make it in time, we will give the demo of binary delta update using librsync.
09:19:06 <szlin> == End ==
09:19:09 <szlin> any other comments?
09:19:10 <szlin> 3
09:19:13 <szlin> 2
09:19:15 <szlin> 1
09:19:26 <szlin> #topic AOB
09:19:47 <szlin> pave1: Jan sent the email to ask a question about rt version
09:20:14 <iwamatsu> patersonc: Can you see https://lava.ciplatform.org/results/? I got 500 error.
09:20:39 <szlin> pave1: #info https://lists.cip-project.org/pipermail/cip-dev/2019-June/002548.html
09:20:42 <pave1> szlin thanks, I should be able to take a look later today.
09:20:49 <szlin> pave1: thank you
09:20:56 <patersonc> iwamatsu: Grrr. That's happened a couple of times.
09:21:14 <patersonc> iwamatsu: Individual test job results can usually still be seen.
09:21:31 <szlin> any other business?
09:21:34 <szlin> 3
09:21:35 <szlin> 2
09:21:36 <szlin> 1
09:21:43 <patersonc> mungaip worked out what caused it, I'll have to dig through the emails to refresh my memory
09:21:50 <patersonc> iwamatsu: Thank you for reporting the issue.
09:21:57 <szlin> #endmeeting