09:00:07 <szlin> #startmeeting CIP IRC weekly meeting
09:00:07 <brlogger> Meeting started Thu Jul 11 09:00:07 2019 UTC and is due to finish in 60 minutes. The chair is szlin. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:07 <brlogger> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:07 <brlogger> The meeting name has been set to 'cip_irc_weekly_meeting'
09:00:15 <szlin> #topic rollcall
09:00:17 <bwh> hi
09:00:20 <szlin> please say hi if you're around
09:00:21 <iwamatsu> hi
09:00:24 <sangorrin> hi
09:00:24 <vidda> hi
09:00:30 <toyooka_ctj> hi
09:00:43 <szlin> #topic AI review
09:00:53 <szlin> 1. Provide the script for CIP kernel config collection - bwh
09:00:54 <szlin> #link https://lists.cip-project.org/pipermail/cip-dev/2019-June/002506.html
09:01:20 <sangorrin> Note: I plan to integrate that with the CVE scripts
09:01:53 <sangorrin> i.e.: get issues that affect your kernel for this configuration
09:01:54 <szlin> sangorrin: do you mean CVE scripts & config collection script?
09:02:01 <bwh> szlin: This is mostly done; I still need to add a rule to merge the lists of source files together
09:02:04 <szlin> fair enough
09:02:29 <szlin> bwh: thanks, I will keep this AI.
09:02:51 <sangorrin> szlin: yes
09:03:07 <szlin> sangorrin: got it, thanks.
09:03:12 <yamamodo> hi
09:03:16 <pave1> ho
09:03:17 <szlin> 2. List real time kernel questions to ask Daniel Wagner - szlin
09:03:18 <pave1> hi
09:03:23 <szlin> -> Done
09:03:24 <patersonc> hi
09:03:38 <szlin> 3. Try updating CIP RT kernel to 4.19.50 - Pavel
09:03:40 <szlin> #link https://lists.cip-project.org/pipermail/cip-dev/2019-June/002548.html
09:04:16 <pave1> So.. I released update... and I got feedback that I numbered the version wrong.
09:04:19 <pave1> I'll need to fix that one.
09:04:42 <szlin> #action Fix release number in CIP RT kernel - pavel
09:04:46 <szlin> pave1: thanks
09:04:52 <pave1> But my testing shows some high latencies I'm currently debugging.
09:05:29 <szlin> pave1: we can discuss RT testing in CIP kernel & testing f2f meeting.
09:06:25 <szlin> 4. Work out a solution for LAVA master backups - patersonc
09:07:01 <patersonc> Not done
09:07:11 <szlin> patersonc: thanks, I will keep this AI
09:07:14 <szlin> #topic Kernel maintenance updates
09:07:48 <sangorrin> I sent a "few" patches to Ben (sorry if there are too many)
09:08:34 <pave1> I finished review of 4.19.57, and reviewed 4.19.58. (Plus I'm having realtime fun).
09:09:01 <iwamatsu> szlin: I reviewed 4.4.164, and I updated base of 4.4.y and 4.19.y for release.
09:09:02 <bwh> sangorrin: No, not too many
09:09:07 <szlin> thank you!
09:09:34 <iwamatsu> I am testing on LAVA updated kernel.
09:09:50 <patersonc> iwamatsu: Great
09:10:16 <szlin> iwamatsu: Please let me know if you need any assistence in relesing kernel.
09:10:23 <patersonc> iwamatsu: Sorry about the healthcheck issues on G2E. I've added a patch to fix it. I'll try and update the master today
09:10:52 <iwamatsu> szlin: OK, thanks for your help!
09:11:13 <szlin> I'm working with yamamodo in failed patches.
09:11:28 <iwamatsu> patersonc: great! thank you!
09:11:29 <yamamodo> :)
09:12:00 <szlin> any other comments?
09:12:13 <patersonc> o/
09:12:13 <szlin> #action Send invitation email to cip-members for CIP kernel and testing f2f meeting in OSS-J - szlin
09:12:57 <szlin> patersonc: please go ahead
09:12:58 <patersonc> Is there any chance my gitlab-ci.yml patches could be reviewed/merged before OSS-J?
09:13:01 <patersonc> https://patchwork.kernel.org/project/cip-dev/list/?submitter=154741
09:13:23 <pave1> patersonc: Yes, I believe I should just do that.
09:13:40 <patersonc> They could also be added to the -rt branches, as they are only doing boot tests atm
09:13:59 <pave1> Agreed.
09:14:13 <patersonc> Thanks pave1
09:14:51 <szlin> #action Review "gitlab-ci.yml" patches before OSS-J - pavel
09:15:02 <szlin> pave1: thank you.
09:15:05 <szlin> 3
09:15:06 <szlin> 2
09:15:07 <szlin> 1
09:15:16 <szlin> #topic Kernel testing
09:15:26 <szlin> patersonc: the floor is yours
09:15:34 <patersonc> Wooo
09:15:35 <patersonc> #info Mentor are still working on adding the two Siemens boards:
09:15:42 <patersonc> #link https://lava.ciplatform.org/scheduler/device/x86-SIMATIC-IPC227E
09:15:45 <patersonc> #link https://lava.ciplatform.org/scheduler/device/Altera-Terasic-Deo-Nano-01
09:15:54 <patersonc> #info At OSS-J we will have a browser open on a RZ/G2M platform that can be used to show the GitLab CI / LAVA testing websites.
09:15:59 <patersonc> #info szlin is trying to set up a Kernel maintenance/testing meeting at OSS-J.
09:16:02 <patersonc> Agenda (WIP): https://docs.google.com/document/d/1_GI-2YDm-8TL4h-L-rO6vD4-fHFK1SLrldrfsgZw0uM/edit#
09:16:05 <patersonc> Can people fill in the doodle if they want to attend? https://doodle.com/poll/473sudmu7hrvqqv8
09:16:22 <patersonc> That's it from me this week, unless there are any questions?
09:17:47 <szlin> iwamatsu: pave1 bwh ^ please fill in when you're available.
09:18:20 <szlin> any other comments?
09:18:37 <szlin> 3
09:18:42 <szlin> 2
09:18:44 <szlin> 1
09:18:57 <szlin> #topic CIP Core
09:19:01 <sangorrin> #info I am just testing the deployment of Deby from Gitlab to AWS S3 (https://gitlab.com/cip-project/cip-core/deby/-/jobs/249491414)
09:19:20 <sangorrin> that's all
09:19:20 <bwh> szlin: I'm not going to OSS-J
09:19:29 <szlin> sangorrin: thank you
09:19:54 <szlin> bwh: could you join the meeting via zoom?
09:20:05 <pave1> szlin: Ok, will do. Note that I'll not be in Japan, so it will be some kind of remote access.
09:20:44 <iwamatsu> szlin: OK, I will add to doodle.
09:20:45 <szlin> pave1: no problem, we will setup it.
09:20:51 <szlin> iwamatsu: thank you
09:20:56 <szlin> == Quote from Kazu ==
09:20:56 <szlin> * (WIP) Creating document about CIP-Core package decision process [60%]
09:20:57 <szlin> * (WIP) Implementing the script to resolve package dependencies automatically [20%]
09:20:57 <szlin> * Arrange CIP Core / testing WG F2F meeting on July 15th (11 attendees)
09:20:57 <bwh> szlin: Not sure
09:20:57 <pave1> szlin: thank you!
09:20:58 <szlin> ====
09:21:13 <yamamodo> 3q
09:21:42 <szlin> any other comments?
09:22:07 <szlin> 3
09:22:08 <szlin> 2
09:22:09 <szlin> 1
09:22:18 <szlin> #topic Software update
09:22:20 <sangorrin> #info Demo is almost ready, I created a small double-side leaflet to explain the demo and the workgroup to participants.
09:22:45 <szlin> sangorrin: nice
09:22:52 <sangorrin> #info I updated the wiki page also, we need to decide the next roadmap during the F2F meeting
09:23:09 <szlin> any other comments?
09:23:30 <szlin> 3
09:23:31 <szlin> 2
09:23:32 <szlin> 1
09:23:34 <szlin> #topic AOB
09:23:38 <szlin> any other business?
09:24:01 <bwh> I still want to know if I can remove old kernel configs for 4.19
09:24:30 <pave1> patersonc: I'd like to chat after the meeting if possible.
09:24:31 <bwh> If we don't do that, it will make more work for the kernel maintainers as they will have to review stable changes that don't affect members
09:24:44 <patersonc> pave1: Sure
09:24:57 <pave1> patersonc: Thanks!
09:25:02 <patersonc> bwh: I've updated the renesas configs, so please keep
09:25:36 <szlin> bwh: I've asked my counterpart to update the config before this week, and thus I can update the MR afterward.
09:25:47 <sangorrin> I was planning to answer soon. I think that the config I sent specifically for 4.19 is the only needed from Toshiba. I will confirm tommorrow
09:25:55 <bwh> patersonc: acknowledged
09:26:18 <patersonc> Thanks
09:26:31 <sangorrin> → tomorrow
09:27:05 <bwh> sangorrin: thanks
09:27:15 <szlin> 3
09:27:16 <szlin> 2
09:27:18 <szlin> 1
09:27:27 <szlin> #endmeeting