09:00:02 <szlin> #startmeeting CIP IRC weekly meeting
09:00:02 <brlogger> Meeting started Thu Aug 8 09:00:02 2019 UTC and is due to finish in 60 minutes. The chair is szlin. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:02 <brlogger> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:02 <brlogger> The meeting name has been set to 'cip_irc_weekly_meeting'
09:00:07 <szlin> #topic rollcall
09:00:13 <szlin> please say hi if you're around
09:00:14 <patersonc> hi
09:00:17 <iwamatsu> hi
09:00:26 <yamamodo> hi
09:00:36 <kazu> hi
09:00:39 <wagi> hi
09:00:46 <szlin> #topic AI review
09:01:02 <pave1> hi
09:01:03 <szlin> 1. Work out a solution for LAVA master backups - patersonc
09:01:50 <patersonc> No update. Probably won't be done for a little while. It's on my tasklist, I'm not sure if it's worth removing from these actions?
09:02:37 <szlin> Ok, I will remove it. Please notice me if you're ready.
09:02:47 <patersonc> Thanks
09:02:49 <szlin> 2. Provide the cases to cip-testing to build up the test environment - Iwamatsu-san
09:03:26 <iwamatsu> szlin: I am working about this.
09:03:37 <szlin> iwamatsu: thank you
09:03:42 <szlin> 3. Ask cip-dev which configurations need testing - patersonc
09:03:51 <szlin> patersonc: I will reply you after the meeting.
09:04:28 <patersonc> Action is in progress. People beginning to reply now
09:04:44 <szlin> patersonc: thank you
09:04:50 <szlin> 4. Confirm we can enable high-res timers for every board - pavel
09:05:09 <pave1> I sent an email to the list. No replies so far.
09:05:12 <szlin> pave1: It seems like there is no objection so far.
09:05:18 <patersonc> I have no objections :)
09:05:29 <iwamatsu> I have no objections too.
09:05:31 <szlin> pave1: +1
09:05:51 <pave1> :-). Ok, good. Looks like "enable it and see if anything breaks" is the way to go.
09:06:31 <szlin> Do you want to discuss with Chris in cyclictest after the meeting?
09:07:09 <szlin> IIRC, you mentioned you need some assistance
09:07:18 <pave1> We can talk, but I don't think I'm ready to do much at this moment.
09:07:26 <szlin> pave1: got it.
09:07:28 <szlin> 5. Add support for PowerPC (4.4 Toshiba config) - patersonc
09:07:57 <szlin> patersonc: this AI should be closed
09:08:01 <patersonc> This is done, or at least ready to be merged. However Toshiba have said they don't need their powerpc config anymore :)
09:08:04 <patersonc> So please close
09:08:20 <szlin> patersonc: thank you for your rapid development
09:08:25 <szlin> 6. Test LTS (pre)releases directly - patersonc
09:08:46 <patersonc> No progress. May be a few weeks away tbh, I'm a bit busy atm
09:09:08 <szlin> 7. Discuss the primary repository in CIP kernel development (kernel.org or gitlab) - kernel team
09:09:19 <szlin> I've sent email to discuss this topic.
09:09:48 <szlin> pave1: bwh ^ Please provide your feedback when you're available.
09:09:55 <szlin> 8. Review and merge "gitlab-ci.yml" - pavel
09:10:02 <patersonc> Done
09:10:12 <patersonc> Thanks pave1
09:10:13 <szlin> thanks.
09:10:19 <szlin> #topic Kernel maintenance updates
09:11:10 <szlin> iwamatsu: pave1 do you have any update on kernel maintenance
09:11:47 <pave1> I've reviewed v4.19.64 and v4.19.65. It is interesting how different can the different releases be.
09:12:04 <iwamatsu> szlin: I have no update.
09:12:19 <szlin> pave1: iwamatsu thank you
09:12:38 <szlin> any other topics?
09:12:40 <patersonc> o/
09:12:53 <szlin> patersonc: please go ahead
09:13:00 <patersonc> I hit a build issue with one of the configs: https://lists.cip-project.org/pipermail/cip-dev/2019-August/002816.html
09:13:15 <patersonc> It would be good if someone could take a look.
09:13:36 <pave1> Yup, sorry about that. Yes, I'll take a look.
09:13:41 <patersonc> Thanks
09:14:04 <szlin> pave1: thank you
09:14:12 <szlin> 3
09:14:13 <szlin> 2
09:14:13 <pave1> Actually,
09:14:14 <szlin> 1
09:14:21 <pave1> this is something we should discuss.
09:14:39 <pave1> -stable rules say "for serious bugs only".
09:15:00 <pave1> [They are not being followed by the -stable team, but that's different topic.]
09:15:49 <pave1> It even has a list of bugs it considers serious, and warnings are ... not bugs in the first place and definitely not on the list.
09:16:20 <pave1> So my tendency would be to deal with warnings in a simple way that does not risk creating new problems...
09:16:31 <patersonc> Sure
09:16:34 <szlin> pave1: Some unsuitable patches were merged by AUTOSEL mechanism
09:16:40 <pave1> ...which would be "turn off -Werror" in this particular case.
09:16:56 <pave1> I just wanted to confirm that this is okay with you?
09:17:05 <pave1> szlin: Yes, AUTOSEL is by far the worst offender.
09:17:58 <patersonc> Note that this issue is only with the -rt branch, so perhaps Werror was enabled by the RT project?
09:18:20 <iwamatsu> We need to decide on default compiler's options.
09:18:33 <pave1> patersonc: I'll need to take a detailed look, maybe it is just an config issue.
09:18:39 <patersonc> Thanks
09:19:01 <szlin> #action Discuss and make a decision on default compiler's options - kernel team
09:19:11 <pave1> patersonc: Anyway my point is that -Werror is good for development, but not good for keeping branch stable, especially in presence of different compiler versions.
09:19:24 <patersonc> pave1: Sure
09:19:28 <patersonc> Do we need a way to formalising reporting issues like this from the CI process? Or are emails to cip-dev enough?
09:19:30 <iwamatsu> indeed.
09:19:48 <pave1> patersonc: I believe cip-dev is ok.
09:19:55 <patersonc> Okay
09:20:00 <szlin> any objections?
09:20:34 <szlin> #agree The CI issues should send to cip-dev mailing list
09:20:36 <szlin> #topic Kernel testing
09:20:51 <szlin> patersonc: the floor is yours
09:20:56 <patersonc> #info linux-cip-ci has been moved to cip-project/cip-testing
09:20:59 <patersonc> #info Kanban board created to keep track of pending tasks for linux-cip-ci. Please feel free to make requests/pick up tasks.
09:21:04 <patersonc> #link https://gitlab.com/cip-project/cip-testing/linux-cip-ci/-/boards
09:21:15 <patersonc> #info The main CIP Kernel branches are now build testing all of the CIP configs (apart from the RT ones).
09:21:20 <patersonc> #info Started to add some wiki content for the LAVA & CI setups.
09:21:33 <patersonc> That's it from me this week. Any comments?
09:21:52 <szlin> 3
09:21:53 <szlin> 2
09:21:54 <szlin> 1
09:22:03 <szlin> #topic CIP Core
09:22:14 <kazu> No techical updates from the last TSC meeting
09:22:24 <kazu> I'm refining the package decision process document based on members' feedbacks
09:22:31 <kazu> then will release rev2 soon
09:22:36 <szlin> thanks
09:22:39 <szlin> any other points?
09:22:50 <szlin> 3
09:22:50 <kazu> I've just sent email to cip-members
09:22:51 <patersonc> o/
09:22:52 <kazu> about this topic
09:23:05 <szlin> patersonc: yes, please
09:23:12 <kazu> If you have any opinions about the update for rev2, please reply
09:23:23 <kazu> patersonc please go ahead
09:23:26 <patersonc> Were any decisions made with regards to compiler versions etc. in the end?
09:23:57 <kazu> not yet in cip core, but in toshiba...
09:24:15 <kazu> at least, CIP will support the following version combinations: 4.4 + stretch, 4.19 + stretch, 4.19 + buster
09:24:40 <kazu> So, the above kernel versions should be tested with gcc of each Debian version
09:25:01 <wagi> patersonc: (LAVA & CI setup): I'll cleanup my build/submit scripts for -rt soon. Most stuff I needed from test-definitions are now upstream. Last missing feature is 'background command'. Still in discussion. After that all my stuff is ready to be abused :)
09:25:22 <patersonc> wagi: Thanks
09:25:37 <patersonc> kazu: Will this testing happen as part of cip-core testing?
09:25:51 <patersonc> kazu: Or do I need to build each Kernel config with multiple GCC versions?
09:25:57 <szlin> kazu: so we can assume that the gcc version will be 8.3
09:26:21 <szlin> 6.3 (stretch( and 8.3 (buster)
09:26:33 <kazu> patersonc please give me time to decide where we do that
09:26:43 <szlin> kazu: got it, thanks.
09:26:49 <patersonc> kazu: Okay. I'll let you pick up the action :)
09:26:52 <patersonc> Thanks
09:26:53 <szlin> any other topics?
09:26:54 <szlin> 3
09:26:55 <szlin> 2
09:26:56 <szlin> 1
09:27:03 <szlin> #topic Software update
09:27:25 <szlin> kazu: do you or Daniel have any update on this topic?
09:27:32 <kazu> CIP wiki has been updated
09:27:46 <kazu> The loadmap will be released soon
09:27:52 <szlin> kazu: thanks.
09:27:59 <szlin> any other points?
09:28:00 <kazu> roadmap
09:28:05 <szlin> 3
09:28:06 <szlin> 2
09:28:07 <szlin> 1
09:28:08 <szlin> #topic AOB
09:28:14 <szlin> Any other business?
09:28:34 <szlin> 3
09:28:35 <szlin> 2
09:28:35 <szlin> 1
09:28:41 <szlin> #endmeeting