09:00:01 <szlin> #startmeeting CIP IRC weekly meeting
09:00:01 <brlogger> Meeting started Thu Sep 26 09:00:01 2019 UTC and is due to finish in 60 minutes.  The chair is szlin. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:01 <brlogger> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:01 <brlogger> The meeting name has been set to 'cip_irc_weekly_meeting'
09:00:10 <szlin> #topic rollcall
09:00:17 <szlin> please say hi if you are around
09:00:44 <pave1> hi
09:00:45 <patersonc> hi
09:00:56 <fujita[m]> hi
09:01:05 <szlin> #topic AI review
09:01:18 <szlin> 1. Provide the cases to cip-testing to build up the test environment - Iwamatsu-san
09:01:26 <szlin> iwamatsu: are you around?
09:01:29 <masashi910> hi
09:01:55 <szlin> I will keep this AI.
09:01:58 <szlin> 2. Test LTS (pre)releases directly - patersonc
09:02:21 <patersonc> I've sent an email to cip-dev with details of what i've done so far
09:02:29 <szlin> patersonc: thank you.
09:02:31 <patersonc> Essentially: https://gitlab.com/cip-playground/linux-stable-rc-ci/pipelines
09:02:46 <szlin> #info https://gitlab.com/cip-playground/linux-stable-rc-ci/pipelines
09:02:54 <szlin> #topic Kernel maintenance updates
09:03:02 <wens> hi
09:03:06 <szlin> I've started working on cip-kernel-sec, and the MR has been sent.
09:03:58 <szlin> pave1: do you have any update on kernel maintenance?
09:04:08 <pave1> I have reviewed 4.19.75 and 4.19.35.
09:04:27 <pave1> Also 4.4-rt kernel should now build.
09:05:04 <szlin> pave1: thank you for your work
09:06:11 <szlin> pave1: I am curious why you review 4.19.35 this time
09:06:21 <szlin> for rt or something else?
09:07:10 <pave1> Well, I thought that we'll eventually want whole 4.19.X reviewed, so I started going down from patches we have already reviewed.
09:07:28 <szlin> pave1: I see, thanks :)
09:07:32 <szlin> any other topics?
09:07:39 <szlin> 3
09:07:41 <szlin> 2
09:07:42 <szlin> 1
09:07:50 <szlin> #topic Kernel testing
09:08:42 <szlin> #info https://lists.cip-project.org/pipermail/cip-dev/2019-September/003334.html
09:09:24 <szlin> ^ any feedback is welcome
09:09:53 <szlin> patersonc: do you have any update on kernel testing?
09:09:55 <pave1> This looks very good, I'll take a detailed look.
09:10:04 <patersonc> Thanks pave1
09:10:09 <patersonc> #info CI Kernel jobs now store the Kernel config, even if the build fails.
09:10:10 <szlin> pave1: thank you.
09:10:15 <patersonc> #info lab-cip-mentor will move over to new hardware today, so there may be some downtime.
09:10:20 <patersonc> #info Initial prototype created to automatically build and test the stable-rc releases.
09:10:26 <patersonc> #link https://lists.cip-project.org/pipermail/cip-dev/2019-September/003334.html
09:10:41 <patersonc> That's it from me, unless there are any comments/queries?
09:11:00 <szlin> patersonc: I'm thinking to add some test slide in ELCE session, let's discuss this offline
09:11:12 <patersonc> szlin: Great
09:11:27 <szlin> any other topics?
09:11:40 <szlin> 3
09:11:41 <szlin> 2
09:11:41 <szlin> 1
09:11:46 <szlin> #topic CIP Core
09:11:56 <kazu> The project porposal (cip-pkglist) is accepted in TSC.
09:12:03 <kazu> Thank you for your voting!
09:12:14 <kazu> I will move the repo to cip-project/cip-core soon.
09:12:28 <kazu> PDP updated: Use the following script to get the number of CVEs in a Debian package
09:12:39 <kazu> https://gitlab.com/cip-playground/cip-pkglist/blob/master/count_cve.py
09:12:48 <szlin> kazu: Congradulations, and thank you for your effort!
09:13:01 <kazu> I will formally inform this in cip-members soon. After reviewed, start the review process for CIP security WG packages ASAP
09:13:15 <patersonc> kazu: Don't all member companies get a vote in TSC?
09:13:20 <kazu> szlin Thank you
09:13:32 <patersonc> You said in your email that only the platinum members get a vote
09:14:27 <kazu> I got votes from all member companies,
09:14:55 <kazu> I'm not sure if I should ask only voting from platinum members
09:15:12 <patersonc> Ah sorry, it was Yoshi-san's email
09:15:16 <patersonc> Ignore me :)
09:15:23 <szlin> any other topics?
09:15:32 <kazu> nothing from me
09:15:50 <szlin> #action Move cip-core repo to cip-project/cip-core - kazu
09:15:59 <szlin> 3
09:16:00 <szlin> 2
09:16:01 <szlin> 1
09:16:11 <szlin> #topic Software update
09:16:31 <kazu> I don't get any updates from Suzuki-san at the moment
09:16:41 <szlin> kazu: thanks.
09:16:44 <szlin> any other topics?
09:16:45 <szlin> 3
09:16:46 <kazu> He are focusing on creating demo
09:16:46 <szlin> 2
09:17:10 <szlin> kazu: does he need any assistence?
09:17:36 <kazu> I will ask him then let members know if needed :-)
09:17:45 <szlin> kazu: thanks
09:17:46 <szlin> 1
09:17:50 <szlin> #topic AOB
09:18:00 <szlin> Let's welcome wens - new kernel team member
09:18:05 <szlin> wens: \o/
09:18:08 * wens waves
09:18:12 <pave1> Welcome :-).
09:18:21 <kazu> welcome!
09:18:24 <patersonc> Hello wens
09:18:41 <wens> thanks everyone :)
09:18:50 <laurence-> hi wens !
09:19:05 <masashi910> Hello, Wens!
09:19:11 <szlin> wens is an active kernel maintainer
09:19:22 <wens> my kernel experience up to now mostly involves the Allwinner platform, with odd bits here and there
09:20:23 <szlin> wens: thank you for your introduction
09:20:46 <szlin> any other topics?
09:21:00 <szlin> is kudo-san here?
09:21:11 <patersonc> szlin: Have you had many responses for the kernel meeting at ELC-E?
09:21:12 <masashi910> Yes, I'm here.
09:21:36 <szlin> patersonc: so far I got 3 responses.
09:21:58 <masashi910> Can I propose some contribution activity?
09:22:22 <szlin> CIP kernel & Testing WG would like to have a f2f discussion during ELCE 2019, please reply your available time via "doodle" link.
09:22:59 <pave1> I'm have a talk at OSS 2019, and I'm not sure what the time will be at the moment.
09:23:26 <pave1> So I can vote but if there's collision I'll have to be at my talk.
09:23:27 <szlin> pave1: feel free to choose your prefer timeslot
09:23:34 <fujita[m]> Can we connect via zoom meeting?
09:23:59 <szlin> fujita[m]: IIRC, OSS & ELCE are in the same venue
09:24:40 <szlin> fujita[m]: and yes, zoom will be setup then
09:25:07 <fujita[m]> Good. Thank you.
09:25:17 <szlin> Once the time is confirmed
09:25:45 <szlin> masashi910: sorry for the delay, the floor is yours
09:25:58 <masashi910> Thanks, SZ-san.
09:26:06 <patersonc> pave1: This one? https://sched.co/TPHT
09:26:31 <masashi910> Now I would like to propose MPSoC code contribution to CIP tree.
09:26:56 <pave1> patersonc: Aha, yes, that one. Thanks a lot!
09:28:17 <fujita[m]> masashi910: Do you have a plan to propose another reference board using MPSoC?
09:28:34 <masashi910> Cybertrust would like to contribute the MPSoC code to CIP tree. The detail is described in the PDF I sent earlier.
09:28:52 <masashi910> I would like to get approval from the team to move it forward.
09:29:23 <masashi910> Does anyone have any comments or questions?
09:29:55 <pave1> masashi910: If you have pointer to the PDF, that would be useful.
09:30:17 <szlin> masashi910: so that means Cybertrust will take the backport task, kernel team need to take maintenance task.
09:31:02 <masashi910> Pavel: Sorry I don't know how to share the document in this IRC channel. Shall I resend the pdf to you?
09:31:39 <szlin> pave1: http://lists.cip-project.org/pipermail/cip-dev/attachments/20190926/19df8723/attachment-0001.pdf
09:31:56 <szlin> masashi910: ^ I think it's this one
09:31:58 <pave1> szlin: Thank you.
09:32:23 <szlin> masashi910: IMHO, we need more time to look on it
09:32:53 <masashi910> szlin: Thanks.
09:33:08 <szlin> #action Review the proposal from Kudo-san - Kernel team
09:33:19 <masashi910> zlin: Sure, then shall I come back next week as well?
09:33:20 <szlin> masashi910: is that ok for you?
09:33:42 <masashi910> szlin: Yes. Thanks.
09:33:46 <szlin> masashi910: yes, perhaps we can reply it beforehand
09:33:57 <szlin> masashi910: thanks
09:34:00 <szlin> any other topics?
09:34:14 <szlin> 3
09:34:15 <szlin> 2
09:34:15 <szlin> 1
09:34:24 <szlin> #endmeeting