#fdio-csit: CSIT-weekly-160803

Meeting started by mackonstan1 at 14:02:19 UTC (full logs).

Meeting summary

    1. dwallacelf (dwallacelf, 14:03:50)
    2. Dave Wallace (mackonstan1, 14:03:53)
    3. Jan Gelety (mackonstan1, 14:04:00)
    4. Peter Mikus (mackonstan1, 14:04:07)
    5. Samuel Elias (mackonstan1, 14:04:17)
    6. Vladimir Holly (mackonstan1, 14:04:25)
    7. Hung Pham (mackonstan1, 14:05:39)

  1. Inputs from FD.io projects - vpp, hc, ... (mmiklus, 14:07:53)
    1. vpp migration to 16.07 dpdk (mmiklus, 14:08:44)

  2. FD.io CSIT operational status. (mackonstan1, 14:09:09)
    1. weekly and semi-weekly jobs runing OK (mackonstan1, 14:09:36)
    2. currently functional tests taking long time - 42-to-45min, in addition to all environment setup (mackonstan1, 14:14:15)
    3. ACTION: Jan to send duration breakdown per test case, as well as environment setup times (mackonstan1, 14:19:43)
    4. ACTION: CSIT committers - review the time distribution, agree on the resolution options to reduce the overall execution time, make a proposal. (mackonstan1, 14:20:18)
    5. new nightly job for performance verification - Miro opened Jira ticket (mackonstan1, 14:23:39)
    6. https://jira.fd.io/browse/CIMANAGE-14 <- nightly build waiting for review (mmiklus, 14:24:41)

  3. Adding new test cases - TLDK (mackonstan1, 14:26:58)
    1. Anna - asking for guidance on how to add TLDK test cases to CSIT (mackonstan1, 14:29:15)
    2. ACTION: Maciek - will provide links for intro new test cases into CSIT (mackonstan1, 14:29:46)
    3. ACTION: Anna - provide description of TLDK tests to be added to CSIT, email to csit-dev (mackonstan1, 14:30:52)

  4. VPP 16.09 release readiness (mackonstan1, 14:35:26)
    1. dpdk 16.07 intro - performance issues based on this patch https://gerrit.fd.io/r/#/c/2196/ (mackonstan1, 14:35:58)
    2. observing throughput drop after moving from dpdk 16.04 to 16.07 (mackonstan1, 14:36:38)
    3. Long IPv4 baseline PDR 64B 1 core, #2196 patch: 2*3.3Mpps, nexus build(dpdk 16.04): 2*4.4Mpps (mmiklus, 14:46:09)
    4. https://git.fd.io/cgit/vpp/tree/dpdk/dpdk-16.04_patches/0013-Revert-ixgbe-fix-packet-type-from-vector-Rx.patch (mortderire, 14:54:20)
    5. https://git.fd.io/cgit/vpp/tree/dpdk/dpdk-16.04_patches/0013-Revert-ixgbe-fix-packet-type-from-vector-Rx.patch (mackonstan, 14:55:39)
    6. Ray confirmed that above patch is missing from both dpdk 16.07 and vpp 16.09, and should be added to address CSIT performance issues observed (mackonstan, 14:57:15)
    7. ACTION: Peter Mikus to send summary of performance comparison between dpdk1607 and dpdk1604, following testing of patch https://gerrit.fd.io/r/#/c/2196/ (mackonstan, 15:04:14)
    8. for baseline tests: ip4, ip6, l2xc, l2bd. (mackonstan, 15:04:31)


Meeting ended at 15:07:55 UTC (full logs).

Action items

  1. Jan to send duration breakdown per test case, as well as environment setup times
  2. CSIT committers - review the time distribution, agree on the resolution options to reduce the overall execution time, make a proposal.
  3. Maciek - will provide links for intro new test cases into CSIT
  4. Anna - provide description of TLDK tests to be added to CSIT, email to csit-dev
  5. Peter Mikus to send summary of performance comparison between dpdk1607 and dpdk1604, following testing of patch https://gerrit.fd.io/r/#/c/2196/


People present (lines said)

  1. mackonstan1 (21)
  2. mmiklus (5)
  3. collabot (5)
  4. mackonstan (4)
  5. mortderire (1)
  6. dwallacelf (1)


Generated by MeetBot 0.1.4.