14:04:21 <mackonstan> #startmeeting CSIT-weekly-160907
14:04:21 <collabot> Meeting started Wed Sep  7 14:04:21 2016 UTC.  The chair is mackonstan. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:04:21 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:04:21 <collabot> The meeting name has been set to 'csit_weekly_160907'
14:04:31 <mackonstan> #chair mackonstan
14:04:31 <collabot> Current chairs: mackonstan
14:04:40 <mackonstan> #chair mmiklus
14:04:40 <collabot> Current chairs: mackonstan mmiklus
14:04:49 <mackonstan> #topic agenda bashing
14:06:05 <mackonstan> #topic Inputs from FD.io projects
14:07:02 <mackonstan> #info VPP update from yday call - next vpp release - Keith Burns proposal for Damjan Marion to drive the release
14:08:00 <mackonstan> #topic DPDK+VPP focused pre-integration testing - Waterman Cao.
14:08:21 <mackonstan> #info open action pending - Waterman proposal: start with opt-1 as step1 for Intel team to get familiar with CSIT code and VPP environment.
14:08:32 <mackonstan> #action Waterman to review this high-level plan with Ray Kinsella, and come back with the strawman plan
14:08:55 <mackonstan> #topic TLDK test cases - Anna (Qun Wan).
14:09:49 <mackonstan> #info review done by mmiklus, Anna posted patches based on feedback
14:10:06 <mackonstan> #info updated patch in review
14:11:23 <mmiklus> #info TBD: agreee on jenkins job creation/triggers for tldk test cases
14:13:18 <mackonstan> #topic FD.io CSIT operational status
14:13:47 <mackonstan> #info jenkins slaves capacity issues are gone for now
14:14:39 <mackonstan> #info some issues starting vpp1206 images in perf testbed
14:15:38 <mackonstan> #info this issue reported by Peter Mikus
14:15:41 <mackonstan> #link https://jira.fd.io/browse/CSIT-400
14:16:50 <mackonstan> #info link to monitor fd.io jenkins slaves status
14:16:54 <mackonstan> #link https://jenkins.fd.io/computer/
14:17:46 <mackonstan> #info Build Queue should be empty or small
14:19:11 <mackonstan> #topic CSIT exec time reduction
14:19:32 <mackonstan> #info from jgelety - no progress on splitting the TCs into separate jobs, will work on it in coming week
14:19:52 <mackonstan> #topic csit1609 release readiness
14:19:52 <mackonstan> •
14:22:02 <mackonstan> #topic 	•	CSIT 16.09 jenkins jobs
14:23:34 <mackonstan> #info perf numbers into report from csit-vpp-perf-1609-all
14:25:52 <mackonstan> #info to generate the graphs, run csit-vpp-perf-1609-all manually multiple times
14:26:51 <mackonstan> #action Peter to run csit-vpp-perf-1609-all manually, report issues, auto-produce very nice graphs :)
14:31:03 <mackonstan> #topic Status - https://jira.fd.io/issues/?filter=10667.
14:31:25 <mackonstan> #topic Status - CSIT Jira 1609-p0.
14:32:07 <mackonstan> #link https://jira.fd.io/issues/?filter=10667
14:33:41 <mackonstan> #info candidates for cherry-picking for csit1609: csit-384, 383, 27
14:34:56 <mackonstan> #topic Status - performance tests
14:36:39 <mackonstan> #info comparing NDR, PDR results of vpp1609 vs. vpp1606
14:38:30 <mackonstan> #action Maciek, Miro - comparing NDR, PDR results of vpp1609 vs. vpp1606, aim to identify code changes responsible
14:40:16 <mackonstan> #topic VM-virtio, VPP-vhost-user numbers.
14:40:51 <mackonstan> #info current NDR, PDR results much lower than expected, and observed in non-CSIT testbeds
14:41:35 <mackonstan> #action Peter, Maciek working on resolution to identify root cause and fix perf issues in csit testbeds for vpp vhost-user with guest-VM running test-pmd
14:42:01 <mackonstan> #topic Latency measurements.
14:43:16 <mackonstan> #info latency results require further scrutiny and analysis, as using brand new trex functionality with separate latency measurements streams
14:44:55 <mackonstan> #action Miro, Maciek, dwallacelf - work with trex dev team (Yaroslav?) to drive conclusions on latency measurements by trex in csit
14:46:41 <mackonstan> #topic Review failing tests CSIT Jira 1609-fail
14:55:21 <mackonstan> #info csit1609 report will list failed test cases in a separate section with explanations
14:55:46 <mackonstan> #info explanation will be pulled from csit JIRA for tickets marked with 1609-fail label
14:56:03 <mackonstan> #link https://jira.fd.io/issues/?filter=10667&jql=project%20%3D%20CSIT%20AND%20resolution%20%3D%20Unresolved%20AND%20labels%20%3D%201609-fail%20ORDER%20BY%20priority%20DESC%2C%20updated%20DESC
14:57:05 <mackonstan> #topic 	•	Tickets Blocked, Stuck In Review state, Red Flag Tickets, Yellow Flag Tickets. - redundant, already discussed
14:59:08 <mackonstan> #topic Test report generation
14:59:24 <mackonstan> #info Peter updated parser, fixed text rendering
14:59:32 <mackonstan> #info need to add performance graphs
15:00:08 <mackonstan> #topic CSIT dev work plan - wiki plan, jira tracking
15:01:04 <mackonstan> #info next week fd.io TWS call will discuss vpp1612 release plan - Tue 13-Sep, 09:15
15:02:03 <mackonstan> #topic vpp1609 test gap analysis
15:02:52 <mackonstan> #topic vpp test gap analysis
15:03:06 <mackonstan> #info followup required with Erin once back from PTO
15:03:35 <mackonstan> #endmeeting