#fdio-csit: csit weekly 160928

Meeting started by mackonstan at 13:59:39 UTC (full logs).

Meeting summary

  1. : Inputs from FD.io projects (mackonstan, 14:05:06)
  2. : VPP (mackonstan, 14:05:16)
    1. : mackonstan - need to drive closer collaboration and interaction with vpp project, specifically on what vpp-dev would like to see from csit-dev on performance a.o. (mackonstan, 14:06:57)

  3. DPDK+VPP focused pre-integration testing - Waterman Cao. (mackonstan, 14:07:34)
    1. no update from Waterman (mackonstan, 14:07:56)

  4. TLDK test cases - Anna (Qun Wan) (mackonstan, 14:08:22)
    1. mmiklus - some progress on tldk patches for csit, moving forward, slowly …. (mackonstan, 14:08:45)
    2. mmiklus - tldk team are also looking at performance tests, fighting with TRex at the moment … (mackonstan, 14:09:15)

  5. FD.io CSIT operational status (mackonstan, 14:10:42)
  6. jenkins jobs - csit-vpp, vpp-csit. (mackonstan, 14:11:17)
    1. performance scale ip4 and ip6 tests failing due to fib2.0 vpp patch (mackonstan, 14:11:47)
    2. vpp vhost multiqueue patch failing - Jan, Peter assisting (mackonstan, 14:12:48)

  7. jenkins slaves, capacity issues, job queue length. (mackonstan, 14:13:06)
    1. no connectivity issues, after tcp timeout correction by LF IT team (mackonstan, 14:13:57)

  8. CSIT exec time reduction update - use experience (mackonstan, 14:15:22)
    1. now it's merged and operational in csit branch oper-160925 and used by all vpp-csit-verify jobs (mackonstan, 14:16:16)
    2. JVPP random build failure was fixed by the following link (dwallacelf, 14:16:45)
    3. https://gerrit.fd.io/r/#/c/3131/ (dwallacelf, 14:16:49)

  9. CSIT/VPP-16.09_Test_Report (mackonstan, 14:23:37)
  10. Performance tests - going forward (mackonstan, 14:24:49)
  11. upgrade to ubuntu 16.04 (mackonstan, 14:26:03)
    1. dwallacelf - working on documentation for upgrading the perf testbeds based on past Carsten TOIs (mackonstan, 14:26:38)
    2. need another volunteer to help (mackonstan, 14:29:55)
    3. Peter, Dave, Maciek - itemized work proposal to move csit virl and perf testbeds to ubuntu 16.04 - share on csit-dev. coordinate the timeline. (mackonstan, 14:38:17)

  12. Latency (mackonstan, 14:38:39)
    1. mmiklus - should analyse the latency measurement results across TCs, pick up the slow ones, and propose to vpp-dev for optimization (mackonstan, 14:40:56)
    2. mackonstan, mmiklus - ask TRex to add 1588 PTP based latency mesurement to TRex sw (mackonstan, 14:43:03)
    3. mmiklus - to look at the X170 loopback connection in LF and create tests to measure latency on a stream going from TG directly to TG (mmiklus, 14:44:34)

  13. vhost-user (mackonstan, 14:46:06)
  14. Multi-thread (mackonstan, 14:47:07)
    1. xl710 multi-thread results look low and weird (mackonstan, 14:47:25)
    2. mmiklus investigating (mackonstan, 14:48:06)

  15. dpdk rls baseline (mackonstan, 14:48:31)
    1. mackonstan dpdk performance trending is a MUST for csit1701 (mackonstan, 14:49:26)
    2. AGREED: integrating dpdk performance trending in csit is the highest priority (mackonstan, 14:50:49)
    3. ACTION: mackonstan - reach out to dpdk guys (waterman, ray kinsella) and ask for direct assistance (mackonstan, 14:51:14)

  16. Functional tests - going forward (mackonstan, 14:57:24)
    1. new vpp-dev make test framework - status, initial code (mackonstan, 15:05:26)
    2. https://github.com/vpp-dev/vpp/tree/test-infra (mackonstan, 15:05:26)
    3. csit virl functional test framework - status - need upgrade to ubuntu 16.04 (mackonstan, 15:05:26)
    4. functional test cases - splitting proposal - all pure functional tc's into vpp-dev make test, fallout tc's (eg vhost) into csit virl functional (mackonstan, 15:05:26)
    5. performance test case continue as per today in csit perf (mackonstan, 15:05:26)

  17. CSIT dev work plan - review, discuss (mackonstan, 15:05:43)
    1. jira csit-func-1701 (mackonstan, 15:06:59)
    2. https://jira.fd.io/issues/?filter=10718 (mackonstan, 15:06:59)
    3. jira csit-perf-1701 (mackonstan, 15:06:59)
    4. https://jira.fd.io/issues/?filter=10719 (mackonstan, 15:06:59)
    5. jira csit-infra-1701 (mackonstan, 15:06:59)
    6. https://jira.fd.io/issues/?filter=10720 (mackonstan, 15:07:00)


Meeting ended at 15:07:08 UTC (full logs).

Action items

  1. mackonstan - reach out to dpdk guys (waterman, ray kinsella) and ask for direct assistance


Action items, by person

  1. mackonstan
    1. mackonstan - reach out to dpdk guys (waterman, ray kinsella) and ask for direct assistance


People present (lines said)

  1. mackonstan (50)
  2. collabot (4)
  3. dwallacelf (2)
  4. mmiklus (1)


Generated by MeetBot 0.1.4.