#fdio-csit: csit weekly 161012

Meeting started by mackonstan at 14:04:49 UTC (full logs).

Meeting summary

    1. Dave Wallace (dwallacelf, 14:05:24)

  1. Agenda bashing (mackonstan, 14:05:38)
  2. Inputs from FD.io projects (mackonstan, 14:05:53)
  3. TLDK (mackonstan, 14:06:54)
    1. Peter - re csit patch for TLDK functional - updates sent over by Ana, addressing review comments (mackonstan, 14:07:41)
    2. dwallacelf - update from TLDK meeting last week - TLDK folks are using google test framework for unit tests, detail to be posted on TLDK project wiki (mackonstan, 14:08:45)
    3. keith burns talking about csit in the context of nsh - but no further details is forthcoming (mackonstan, 14:10:26)

  4. VPP (mackonstan, 14:12:26)
    1. need to summarize to VPP the csit1701 plan (mackonstan, 14:12:47)
    2. ACTION: Maciek - summarize what's done in csit1609, and then summarize proposal for csit1701 across - i) virl-functional, ii) phy-performance, iii) vpp-test. (mackonstan, 14:13:36)
    3. send it to csit-dev, review by ALL csit folks; and then fwd to vpp-dev. (mackonstan, 14:14:18)

  5. FD.io CSIT operational status (mackonstan, 14:14:51)
    1. jobs for 1609 stopped (mackonstan, 14:15:15)
    2. : https://gerrit.fd.io/r/#/c/3350/ (jgelety, 14:16:56)
    3. virl machines outage yesterday due to garbage accumulated over the LF infra outages - see email thread on csit-dev (mackonstan, 14:19:25)
    4. ACTION: Peter Mikus to summarize work required to prevent this happening in the future (mackonstan, 14:21:37)

  6. Testbeds upgrade to Ubuntu 16.04 (mackonstan, 14:21:58)
    1. Peter Mikus status update - VIRL Image 1.4 (Ubuntu Xenial) is now produced and operational. Simulation is working and nodes are brought up. (mackonstan, 14:22:29)
    2. irc://barjavel.freenode.net:6697/#infoeter Mikus - Physical TB3 is reinstalled and working properly. The rest of TBs are waiting for successful VIRL run so we can switch. (mackonstan, 14:23:05)
    3. Peter Mikus - Physical TB3 is reinstalled and working properly. The rest of TBs are waiting for successful VIRL run so we can switch. (mackonstan, 14:23:51)
    4. currently blocked by PIP and setuptools not compatible with TrafficScriptExecutor - wip (mackonstan, 14:27:29)
    5. https://gerrit.fd.io/r/#/c/3290/ (mackonstan, 14:27:36)
    6. Next step after fixing above issues with CSIT code - need to adjust ci-management so VPP jobs will work. (mackonstan, 14:32:10)

  7. Performance tests - csit1701 plan (mackonstan, 14:33:22)
    1. Maciek update - working with dpdk folks on addressing it, next update after dpdk userspace summit next week (mackonstan, 14:36:59)
    2. • Latency - path to further improve accuracy - work with TRex project (mackonstan, 14:37:14)
    3. Maciek update - TRex lead confirmed that improving latency measurement accuracy is possible by using PTP/ieee1588 supprt in xl710 nics. looking for volunteers to help it code in TRex. right now no plan. (mackonstan, 14:40:35)

  8. TLDK update - Anna (mackonstan, 14:41:07)
    1. TLDK functional test cases added - thanks to Peter and Miro for good reviews. (mackonstan, 14:41:34)
    2. DPDK baseline tests - started to work on the plan to integrate into CSIT - l2fwd, l3fwd, maybe testpmd. (mackonstan, 14:45:19)

  9. Functional tests - csit1701 plan (mackonstan, 14:49:07)
    1. new vpp test infra framework - status - framework changes tracked on gerrit (mackonstan, 14:49:34)
    2. https://gerrit.fd.io/r/#/c/3345/ (mackonstan, 14:49:45)
    3. https://gerrit.fd.io/r/#/c/3237/ (mackonstan, 14:50:40)

  10. CSIT dev work plan - review, discuss (mackonstan, 14:55:53)
    1. see jira tickets (mackonstan, 14:55:57)

  11. CSIT HC tests (mackonstan, 14:56:57)
    1. CSIT HC tests ready to go production (mackonstan, 14:57:23)
    2. https://gerrit.fd.io/r/3018 (mackonstan, 14:57:44)


Meeting ended at 14:58:47 UTC (full logs).

Action items

  1. Maciek - summarize what's done in csit1609, and then summarize proposal for csit1701 across - i) virl-functional, ii) phy-performance, iii) vpp-test.
  2. Peter Mikus to summarize work required to prevent this happening in the future


People present (lines said)

  1. mackonstan (41)
  2. collabot (4)
  3. jgelety (2)
  4. dwallacelf (1)


Generated by MeetBot 0.1.4.