14:03:36 <mackonstan> #startmeeting csit weekly 161019
14:03:36 <collabot> Meeting started Wed Oct 19 14:03:36 2016 UTC.  The chair is mackonstan. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:03:36 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:03:36 <collabot> The meeting name has been set to 'csit_weekly_161019'
14:03:48 <mackonstan> #chair mackonstan
14:03:48 <collabot> Current chairs: mackonstan
14:03:56 <dwallacelf> #info Dave Wallace
14:04:01 <mackonstan> #topic agenda bashing
14:04:25 <mackonstan> #topic Inputs from FD.io projects
14:05:26 <mackonstan> #topic VPP project
14:07:16 <dwallacelf> #info VPP agreed to move the "make test" into operational verify jobs as soon as practicable.
14:16:43 <dwallacelf> #action Maciek and Dave to raise issue of having VPP Release Manager attend CSIT weekly meeting to share 17.01 VPP milestone status and/or changes.
14:17:23 <mackonstan> #info VPP rep to help us drive the retrofit testing areas
14:20:06 <mackonstan> #topic DPDK+VPP focused pre-integration testing
14:21:10 <mackonstan> #info Waterman + Anna working on DPDK testpmd in host baseline tests, right now getting familiar trex
14:21:34 <mackonstan> #info putting in place a regular csit tws call on Friday's to drive progress
14:21:47 <mackonstan> #topic TLDK test cases
14:22:40 <mackonstan> #info functional tests - patch review almost complete, but bootstrap logic needs to be split up
14:30:27 <mackonstan> #topic Testbeds upgrade to Ubuntu 16.04
14:30:50 <mackonstan> #info confusion about vpp hugepage configuration at init - what, where, how - long saga - many patches
14:31:01 <mackonstan> #info relevant patches
14:31:31 <pmikus> #info vpp hugepages patch: https://gerrit.fd.io/r/#/c/3170/
14:32:00 <mackonstan> #link https://gerrit.fd.io/r/#/c/3170/
14:32:30 <mackonstan> #info here patches impacting ubuntu1604 operation
14:32:35 <mackonstan> #link https://gerrit.fd.io/r/#/c/3460/
14:32:58 <mackonstan> #link https://gerrit.fd.io/r/#/c/3481/
14:38:57 <mackonstan> #info dwallacelf will test 3481 on virl servers
14:43:29 <mackonstan> #topic Performance tests - csit1701 plan
14:43:59 <mackonstan> #info fib2.0 cvg test development in progress - tibor
14:45:37 <mackonstan> #info xl710 - ip4, l2bd - added. ip6 - in review.
14:46:14 <mackonstan> #info Complete XL710 baseline tests - see fallout from csit1609
14:46:38 <mackonstan> #info plan: other NICs: x710, vic1385, vic1227
14:47:56 <mackonstan> #info plan: Thorough review of ubuntu1604 perf results - NDR, PDR, latency, compare to ubuntu14.04
14:48:19 <mackonstan> #info plan: compare to non-LF hosted lab results - Cisco, Intel, others?
14:49:01 <mackonstan> #info: share findings on csit-dev and vpp-dev
14:50:35 <mackonstan> #info: Enhance vhost tests - per csit1609 report note
14:51:38 <mackonstan> #info: Enhance multi-threaded tests
14:53:44 <mackonstan> #topic Functional tests - csit1701 plan
14:54:06 <mackonstan> #info Jan - last set of ipsec / ikev2 TCs in review
14:56:14 <mackonstan> #info lisp test cases - still a long list todo - need to reduce based on usability and applicability - all lisp2lisp to be reduced in priority
14:59:14 <mackonstan> #info: tests descriptions should be sent to csit-dev for review, and to vpp-dev owner if known
15:04:09 <mackonstan> #topic new vpp test infra framework - status
15:04:49 <mackonstan> #info work ongoing on finishing test infra updates and initial test cases https://gerrit.fd.io/r/#/c/3345/
15:04:52 <mackonstan> #link https://gerrit.fd.io/r/#/c/3345/
15:05:03 <mackonstan> #topic CSIT HC tests
15:05:38 <mackonstan> #info Sam - Honeycomb integration job patch stuck in review in ci-management - need help !!
15:06:03 <mackonstan> #info emails already sent to ci-management-dev to no avail
15:06:22 <mackonstan> #info Maciek resent them adding Ed and CJ for their direct attention
15:06:30 <mackonstan> #link https://gerrit.fd.io/r/3018
15:06:33 <mackonstan> #endmeeting