15:00:37 <mackonstan> #startmeeting csit weekly 161109
15:00:37 <collabot`> Meeting started Wed Nov  9 15:00:37 2016 UTC.  The chair is mackonstan. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:37 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:00:37 <collabot`> The meeting name has been set to 'csit_weekly_161109'
15:00:47 <mackonstan> #chair mackonstan
15:00:47 <collabot`> Current chairs: mackonstan
15:00:59 <mackonstan> #topic: agenda bashing
15:03:39 <mackonstan> #topic Inputs from FD.io projects - vpp
15:04:19 <dwallacelf> #info Dave Wallace
15:04:55 <mackonstan> #info vhost test requirements discussion in email thread: "[vpp-dev] [csit-dev] vHost user test scenarios for CSIT"
15:07:00 <mackonstan> #info vhost tests today in perf testbed are with testpmd in ubuntu1604 guest, and in virl testbed with linux-bridge in ubuntu1604 guest.
15:07:04 <tfherbert> #info Tom Herbert
15:12:06 <mackonstan> #info integrating vpp make test into verify jobs
15:12:22 <mackonstan> #link https://gerrit.fd.io/r/#/c/3736 - transitions the vpp-lite-* jobs to using 'make test' (which also builds vpp-lite)
15:12:32 <mackonstan> #link https://gerrit.fd.io/r/#/c/3737 - renames vpp-lite-* jobs to vpp-test-* jobs
15:12:53 <mackonstan> #info need to test drive this properly
15:13:35 <mackonstan> #topic HoneyComb
15:13:58 <mackonstan> #info no update
15:14:10 <mackonstan> #info waiting for CentOS  in VIRL testbed
15:15:11 <mackonstan> #topic Peter - few patches
15:15:18 <mackonstan> #link https://gerrit.fd.io/r/#/c/3620/
15:15:25 <mackonstan> #link https://gerrit.fd.io/r/#/c/3743/
15:16:01 <mackonstan> #topic DPDK+VPP focused pre-integration testing
15:16:40 <mackonstan> #info no update
15:16:52 <mackonstan> #info expecting commit from Anna, Waterman this week
15:16:57 <mackonstan> #topic TLDK
15:17:06 <mackonstan> #info two blocker issues in Jira
15:19:31 <mackonstan> #topic FD.io CSIT operational status
15:22:38 <mackonstan> #info would be good to split trend graphs and make them less crowded
15:24:49 <mackonstan> #topic Test environment infra topics
15:25:35 <mackonstan> #info Adding Centos - func VIRL, perf phy testbeds, https://wiki.fd.io/view/CSIT/CSIT_Update_Testbed
15:26:19 <mackonstan> #link https://wiki.fd.io/view/CSIT/CSIT_Update_Testbed
15:34:26 <mackonstan> #info CSIT Testbeds - Adding CentOS - version to be decided based on vpp users with CentOS - currently mainly (only?) OPNFV/FDS, hence requirement for CentOS Linux release 7.2.1511 (Core)
15:36:56 <mackonstan> #action Maciek to clarify with OPNFV/FDS situation re vhost reconnect
15:37:43 <mackonstan> #info CSIT VIRL Testbed
15:38:20 <mackonstan> #action tfherbert, dwallacelf - Create CentOS VIRL image (CSIT)
15:38:55 <mackonstan> #info dwallacelf to provide pointerst to CSIT TOI sessions
15:40:52 <mackonstan> #action tfherbert, edwarnicke - Create new set of verify jobs with CentOS executor (CI-MAN)
15:42:47 <mackonstan> #action tfherbert, pmikus - Create CentOS bootstrap script (CSIT)
15:43:56 <mackonstan> #info Verify CSIT Framework - then it's integration time …
15:46:37 <mackonstan> #topic Performance tests
15:46:37 <mackonstan> •
15:47:31 <mackonstan> #topic vhost-user - test requirements
15:47:42 <mackonstan> #info Tom - still collecting feedback from ovscon
15:50:10 <mackonstan> #info Tom - proposal to see if it makes sense to integrate OPNFV/VSPERF tests into CSIT .. or the other way round … to be followed up
15:51:27 <mackonstan> #topic Performance tests
15:53:16 <mackonstan> #info dpdk rls baseline - dpdk16.11rc1 tests started
15:53:51 <mackonstan> #topic - generating online docs - sphinx, RF
15:57:52 <mackonstan> #info - Tibor to send sphinx auto-generated sample
15:59:57 <mackonstan> #topic Functional tests - vpp make test framework
16:00:11 <mackonstan> #info user guide now available
16:00:24 <mackonstan> #link https://git.fd.io/cgit/vpp/tree/test/doc/index.rst
16:00:46 <mackonstan> #info integrating vpp make test into verify jobs
16:01:24 <mackonstan> #info ewarnicke - patches proposed to run them for ubuntu and centos
16:01:33 <mackonstan> irc://barjavel.freenode.net:6697/#link https://gerrit.fd.io/r/#/c/3736 - transitions the vpp-lite-* jobs to using 'make test' (which also builds vpp-lite)
16:01:57 <mackonstan> #link https://gerrit.fd.io/r/#/c/3736 - transitions the vpp-lite-* jobs to using 'make test' (which also builds vpp-lite)
16:02:10 <mackonstan> #link https://gerrit.fd.io/r/#/c/3737 - renames vpp-lite-* jobs to vpp-test-* jobs
16:03:44 <mackonstan> #info dwallacelf, mackonstan - create a new wiki page describing the e2e vpp test architecture, covering vpp make test, csit virl, cist perf physical testbed
16:04:05 <mackonstan> #topic Functional tests - csit virl
16:04:13 <mackonstan> #info all action in jira
16:04:37 <mackonstan> #topic CSIT HC tests
16:05:03 <mackonstan> #info no updates
16:09:42 <mackonstan> #endmeeting