#fdio-csit: csit weekly 161123

Meeting started by mackonstan at 14:59:21 UTC (full logs).

Meeting summary

    1. jgelety = Jan Gelety (jgelety, 15:01:52)
    2. Peter Mikus (pmikus, 15:02:32)

  1. Inputs from FD.io projects (mackonstan, 15:02:35)
  2. VPP (mackonstan, 15:02:46)
    1. no updates, apart from progressing with adding vpp make test into verify job (mackonstan, 15:03:39)

  3. HC (mackonstan, 15:03:46)
    1. HC split into projects: i) the generic agent part (Honeycomb), ii) vpp use case (Hc2vpp) (mackonstan, 15:04:47)

  4. DPDK perf baseline pre VPP integration (mackonstan, 15:05:36)
    1. no update. ETA is still unknown.. (mackonstan, 15:06:34)

  5. TLDK (mackonstan, 15:06:47)
    1. no update (mackonstan, 15:06:59)

  6. vppsb (mackonstan, 15:07:16)
    1. Pierre posted script to auto configure and test vhost environment (mackonstan, 15:09:02)
    2. vppsb/vhost-test$ ls conf.sh.default README.md vhost.sh (mackonstan, 15:09:10)
    3. may be relevant to csit vhost use case discussion (mackonstan, 15:09:42)
    4. +1 (tfherbert, 15:10:04)

  7. FD.io CSIT operational status (mackonstan, 15:11:14)
    1. Peter reported LF infra glitch this morning CET time, but fixed now (mackonstan, 15:12:47)
    2. Jan still observing connectivity issues to Jenkins slaves - #ticket? (mackonstan, 15:13:47)
    3. oper-161120 branch operational for vpp-csit-verify jobs (mackonstan, 15:15:42)

  8. Test environment infra topics (mackonstan, 15:16:05)
    1. connectivity issue ticket: FD.io Helpdesk #32787 (jgelety, 15:16:31)

  9. vhost NDR results still low per csit1609 report note - need to address CPU jitter (mackonstan, 15:16:37)
    1. Peter working on applying kernel CFS parameters to CSIT vhost code for perf testbeds (mackonstan, 15:17:48)
    2. currently observing issues with getting it working reliably with vpp worker threads (mackonstan, 15:18:27)

  10. Adding Centos - func VIRL (mackonstan, 15:18:46)
    1. Thomas - centos7.1 image build done (mackonstan, 15:19:34)
    2. https://gerrit.fd.io/r/#/c/3860/ (mackonstan, 15:20:29)
    3. pls add Dave Wallace, Carsten Koster, Peter Mikus, Jan Gelety as reviewers to the patch (mackonstan, 15:22:38)

  11. Performance tests (mackonstan, 15:27:08)
  12. dpdk rls baseline - with testpmd (mackonstan, 15:27:38)
    1. Anna is splitting the current giantic patch with testpmd+tldk+.., into separate ones (mackonstan, 15:28:12)

  13. trending baseline tests - one-core, multi-core (mackonstan, 15:30:28)
    1. ACTION: Tibor and Maciek - prepare an analysis report for next call (mackonstan, 15:30:53)

  14. quad-loop code on ip4-lookup (mackonstan, 15:31:31)
    1. work in progress by Tibor (mackonstan, 15:32:12)

  15. online documentation (mackonstan, 15:32:25)
    1. sphinx generates static html (mackonstan, 15:33:18)
    2. ACTION: Maciek/mackonstan to ping Ed Warnicke to find home for it (mackonstan, 15:33:36)

  16. Functional tests - vpp make test framework (mackonstan, 15:34:28)
  17. integrating vpp make test into verify jobs (mackonstan, 15:34:55)
    1. need to confirm when and how they're getting integrated (mackonstan, 15:35:15)
    2. ACTION: Maciek/mackonstan to check with Ed and Damjan (mackonstan, 15:35:30)

  18. auto-generating online docs - sphinx - in place (mackonstan, 15:36:26)
    1. posting on LF FD.io VPP project site - need to find out logistics (mackonstan, 15:36:43)
    2. ACTION: Maciek/mackonstan to check with Ed and find home for it (mackonstan, 15:37:02)

  19. vhost use cases - see thread on csit-dev (mackonstan, 15:37:17)
    1. Thomas - some comments apply to long-term and some can be done now (mackonstan, 15:40:21)
    2. ACTION: Maciek to start the compilation based on email thread inputs (mackonstan, 15:40:59)
    3. ACTION: Thomas, Maciek - let's convert it then into the documented use cases and then followed by test cases - and track it on fd.io csit wiki (mackonstan, 15:41:10)

  20. Functional tests - csit virl (mackonstan, 15:41:31)
  21. HoneyComb tests (mackonstan, 15:45:18)
    1. already testing in Ubuntu (mackonstan, 15:45:29)
    2. need to run them on Centos to align with OPNFV/FDS use cases (mackonstan, 15:45:49)
    3. would be good to get a jira link to filter showing HC test dev progress (mackonstan, 15:47:52)


Meeting ended at 15:49:41 UTC (full logs).

Action items

  1. Tibor and Maciek - prepare an analysis report for next call
  2. Maciek/mackonstan to ping Ed Warnicke to find home for it
  3. Maciek/mackonstan to check with Ed and Damjan
  4. Maciek/mackonstan to check with Ed and find home for it
  5. Maciek to start the compilation based on email thread inputs
  6. Thomas, Maciek - let's convert it then into the documented use cases and then followed by test cases - and track it on fd.io csit wiki


Action items, by person

  1. mackonstan
    1. Maciek/mackonstan to ping Ed Warnicke to find home for it
    2. Maciek/mackonstan to check with Ed and Damjan
    3. Maciek/mackonstan to check with Ed and find home for it
  2. UNASSIGNED
    1. Tibor and Maciek - prepare an analysis report for next call
    2. Maciek to start the compilation based on email thread inputs
    3. Thomas, Maciek - let's convert it then into the documented use cases and then followed by test cases - and track it on fd.io csit wiki


People present (lines said)

  1. mackonstan (55)
  2. collabot` (4)
  3. jgelety (2)
  4. tfherbert (1)
  5. pmikus (1)


Generated by MeetBot 0.1.4.