15:01:25 <mackonstan> #startmeeting csit weekly 161207
15:01:25 <collabot`> Meeting started Wed Dec  7 15:01:25 2016 UTC.  The chair is mackonstan. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:25 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:01:25 <collabot`> The meeting name has been set to 'csit_weekly_161207'
15:01:27 <jgelety1> #info Jan Gelety
15:01:32 <mackonstan> #chaiir mackonstan
15:02:02 <mklotton1> #info Matej Klotton
15:02:12 <pmikus> #info Peter Mikus
15:02:50 <BillyM> #info Billy McFall
15:02:58 <tfherbert> #info Thomas Herbert
15:03:55 <dwallacelf> #info Dave Wallace
15:04:13 <selias> #info Samuel Elias
15:04:45 <mackonstan> #topic Agenda bashing
15:06:04 <mackonstan> #topic Inputs from FD.io projects
15:06:35 <mackonstan> #topic VPP project
15:08:08 <mackonstan> #info vpp+dpdk1611 XoverIPv4 tests failing due to wrong checksum
15:08:34 <mackonstan> #info Peter will add link to related gerrit patch
15:09:03 <pmikus> #info Patch on VPP is abandoned now: https://gerrit.fd.io/r/#/c/4115/1
15:10:51 <mackonstan> #info mackonstan - discussing CSIT code freeze in relation to VPP release on 18-Jan
15:11:06 <mackonstan> #info proposal for complete CSIT code freeze on 11-Jan-2017
15:11:57 <mackonstan> #topic HoneyComb
15:12:31 <mackonstan> #info selias - not much updates, updates to verify jenkins jobs, will announce on csit-dev
15:13:42 <mackonstan> #info selias - will consult with HC project devs to see what can be included in csit1701 report
15:14:24 <mackonstan> #topic TLDK project
15:15:04 <mackonstan> #info pmikus - patches reviewed, but no activity observed on patches
15:16:10 <mackonstan> #info pmikus to followup with TLDK projectdevs
15:16:20 <mackonstan> #topic FD.io CSIT operational status
15:17:30 <mackonstan> #info edwarnicke - robots in place monitoring state of Jenkins slaves and size of the job queue
15:18:14 <mackonstan> #info edwarnicke - robots work, generate some false positive, but otherwise working incl. detecting zombie jbos
15:22:07 <mackonstan> #topic Test environment infra topics
15:22:41 <mackonstan> #topic vhost CPU jitter fixes - adding CFS settings
15:25:02 <mackonstan> #info pmikus - still working on it - issues with nested thin VM not including task-set commands
15:26:20 <mackonstan> #info pmikus - this is the last patch to make vhost tests work as expected and observed in the manual tests
15:26:52 <mackonstan> #topic Adding Centos - func VIRL
15:27:08 <mackonstan> #topic Progress to date - Thomas Herbert
15:31:27 <mackonstan> #info tfherbert - making good progress, base image created and stable, working on packages  and qemu 2.3, infra working pretty well, hopefully will get to the nested image most likely tomorrow.
15:33:46 <mackonstan> #topic Performance tests
15:34:06 <tfherbert> #info will keep in touch with dwallace and pmikus if I have some problems or questions about VIRL
15:35:30 <mackonstan> #topic adding cryptodev tests - Sergio, Radu
15:35:59 <mackonstan> #info mackonstan - no progress reported
15:36:23 <mackonstan> #action - mackonstan - to set up a TWS call to discuss the tech details about cryptodev tests onboarding onto CSIT
15:36:42 <mackonstan> #action - mackonstan - poke for status on csit-dev thread: [csit-dev] AES-GCM support for ipsec tests
15:37:01 <mackonstan> #topic DPDK perf baseline pre VPP integration
15:38:03 <mackonstan> #info pmikus - separate patch now available - DPDK-perf patches https://gerrit.fd.io/r/#/c/3961/ https://gerrit.fd.io/r/#/c/3960
15:38:12 <mackonstan> #link https://gerrit.fd.io/r/#/c/3961/ https://gerrit.fd.io/r/#/c/3960/
15:38:49 <mackonstan> #link https://gerrit.fd.io/r/#/c/3961/
15:39:19 <mackonstan> #topic trending baseline tests - one-core, multi-core
15:39:52 <mackonstan> #info tifrank - send email to csit-dev
15:40:23 <mackonstan> #info tifrank - requires further analysis as performance is not completely linear
15:42:46 <mackonstan> #topic online documentation
15:43:52 <mackonstan> #info edwarnicke - follow the example of the doc auto-gen job here
15:44:01 <mackonstan> #link https://git.fd.io/ci-management/tree/jjb/vpp/vpp.yaml#n507
15:44:03 <edwarnicke> #link https://git.fd.io/ci-management/tree/jjb/vpp/include-raw-vpp-docs.sh#n22 <- example of where the groupId is set.  Note, for csit, its going to need to be groupId io.fd.csit
15:44:57 <mackonstan> #action tifrank mackonstan - implement doc auto-gen for all csit tests as scripted by tifrank, edwarnicke to assist
15:45:37 <mackonstan> #info same should apply for vpp make test
15:46:06 <edwarnicke> For documenting make test, look at updating make docs to build documentation for make test:
15:46:32 <mackonstan> #topic Functional tests - csit virl
15:47:07 <mackonstan> #info no updates
15:47:13 <edwarnicke> #link https://git.fd.io/vpp/tree/Makefile#n330 <- make doxygen creates the docs for vpp
15:48:51 <mackonstan> #info mackonstan - need to update jira
15:50:06 <mackonstan> #action mackonstan Vladimir Holly - work on cleaning jira to reflect the targets for csit1701 and status
15:50:53 <mackonstan> #topic Functional tests - vpp make test framework
15:51:22 <mackonstan> #info mackonstan - vpp make test are not verifying
15:51:51 <edwarnicke> #link https://gerrit.fd.io/r/#/c/4109/ <- patch to turn on make test
15:51:52 <mackonstan> #info edwarnicke - make test got broken by python api updates by Ole
15:52:05 <mackonstan> #info edwarnicke - now Ole fixed APIs
15:52:34 <mackonstan> #info edwarnicke - make test verify passed once, but need to do more tests
15:56:06 <mackonstan> #topic Use case tests
15:56:06 <mackonstan> •
15:56:26 <mackonstan> #topic vhost use cases - see thread on csit-dev
15:59:56 <mackonstan> #info next FD.io TWS call today at 9am PST
16:00:03 <mackonstan> #info details on TWS page
16:00:12 <mackonstan> #link https://wiki.fd.io/view/TWS
16:00:48 <mackonstan> #info vhost user cases and test cases tracked on fd.io wiki here
16:00:57 <mackonstan> #link https://wiki.fd.io/view/CSIT/vhostuser_test_scenarios
16:01:16 <mackonstan> #topic vpp-csit-verify job failures
16:01:35 <mackonstan> #info dbarach reported issue with CSIT functional test failure, not likely related to the patch
16:02:05 <mackonstan> #link https://lists.fd.io/pipermail/csit-dev/2016-December/001322.html
16:02:41 <mackonstan> #info issue with Map-E TC06 test failing
16:02:54 <mackonstan> #info pmikus - confirmed that he observed this test sporadically failing before
16:03:46 <mackonstan> #info mackonstan - RF error messages seem to be bogus: return STDERR WARNING: Failed to execute tcpdump. Check it is installed and in the PATH WARNING: No route found for IPv6 destination
16:03:53 <mackonstan> #endmeeting