#fdio-csit: csit-weekly-170222

Meeting started by mackonstan1 at 15:01:53 UTC (full logs).

Meeting summary

    1. Samuel Elias (selias, 15:04:11)

  1. agenda bashing (mackonstan1, 15:04:15)
    1. Sergio Gonzalez Monroy (sgmonroy, 15:04:16)
    2. Tibor Frank (tifrank, 15:04:25)
    3. Dave Wallace (dwallacelf, 15:04:28)
    4. Tom Herbert (tfherbert, 15:04:32)

  2. Inputs from LF and FD.io projects (mackonstan1, 15:04:35)
  3. vpp (mackonstan1, 15:04:53)
    1. https://wiki.fd.io/view/Projects/vpp/Release_Plans/Release_Plan_17.04 (mackonstan1, 15:06:12)
    2. Jan Gelety (jgelety, 15:06:33)
    3. mackonstan1/Maciek - suggested to discuss the plan and test coverage on one of the next vpp calls (mackonstan1, 15:06:44)
    4. Peter Mikus (pmikus, 15:06:47)

  4. HoneyComb (mackonstan1, 15:07:04)
  5. FD.io CSIT operational status (mackonstan1, 15:08:20)
    1. Nighlty job not working. LF ticket opened [FD.io Helpdesk #37116] (pmikus, 15:10:57)

  6. csit1701 - followups (mackonstan1, 15:11:29)
    1. need to track progress on resolving the issues listed in the csit rls1701 report (mackonstan1, 15:12:50)
    2. perf issues - Peter, Maciek to follow (mackonstan1, 15:14:14)
    3. https://docs.fd.io/csit/rls1701/report/vpp_performance_tests/csit_release_notes.html#known-issues (mackonstan1, 15:14:16)
    4. func issues - Jan, Maciek to follow (mackonstan1, 15:14:40)
    5. https://docs.fd.io/csit/rls1701/report/vpp_performance_tests/csit_release_notes.html#known-issues (mackonstan1, 15:14:43)
    6. HoneyComb issues - Sam, Maciek to follow (mackonstan1, 15:15:26)
    7. https://docs.fd.io/csit/rls1701/report/vpp_performance_tests/csit_release_notes.html#known-issues (mackonstan1, 15:15:28)
    8. perf Tests to be Added - Cryptodev (mackonstan1, 15:16:18)
    9. Sergio confirmed some issues with cryptodev device binding to igb_uio - patch on the way, hopefully in couple of days (mackonstan1, 15:17:40)
    10. Tibor, Sergio continuing to work on thsi (mackonstan1, 15:19:20)
    11. perf Tests to be Added - SNAT44 (mackonstan1, 15:20:29)
    12. Peter update - currently on hold - waiting for update from vpp-dev re code update (mackonstan1, 15:20:49)
    13. perf Tests to be Added - Additional NICs (mackonstan1, 15:21:17)
    14. Peter update - weekly review calls with testpmd team in place - Anna, Waterman (mackonstan1, 15:22:09)
    15. Peter update - xl710 and x710 testpmd tests are faiiing - 2nd interface is always down - testpmd can't bring it up - reproduced with dpdk16.09, 16.11, 17.02 (mackonstan1, 15:24:15)
    16. func Tests to be Added - Centos (mackonstan1, 15:26:09)
    17. Jan update - bootstrap files updated (mackonstan1, 15:26:45)
    18. Qemu patch https://gerrit.fd.io/r/#/c/5411/ (pmikus, 15:28:36)
    19. #5411 changes to QemuUtil do not work for perf phy environment (mackonstan1, 15:31:41)
    20. can't merge #5411 as it will break all perf phy vhost tests (mackonstan1, 15:32:54)

  7. Test environment infra topics (mackonstan1, 15:34:09)
    1. need to schedule installation of additional crypto HW cards into tb1,2. tb3 has the cards installed. (mackonstan1, 15:36:37)
    2. 8 cards total have been received - 8 x Walnut Hill Singles Quick-Assist Technology (QAT) (mackonstan1, 15:37:24)
    3. "lspci -vv" to get cards revision …. (mackonstan1, 15:39:17)
    4. need to verify capacity of these cards (mackonstan1, 15:39:30)

  8. Performance tests (mackonstan1, 15:39:49)
    1. Cryptodev lspci output in "IPsec Multi-Tunnel performance test suite" on csit-dev mailer (pmikus, 15:40:48)
    2. obvious candidates: enabling hyperthreading, snat, vhost usability list (mackonstan1, 15:41:12)

  9. 1. VPP functional tests - virl (mackonstan1, 15:42:31)
  10. VPP functional tests - virl (mackonstan1, 15:42:39)
    1. obvious candidates: vhost usability list (mackonstan1, 15:43:58)
    2. need to added centos to performance tests (mackonstan1, 15:46:01)

  11. vhost use cases (mackonstan1, 15:47:29)
    1. follow up with email to contributors to reawake and finalize the list of vhost use cases for csit rls 1704 and beyond (mackonstan1, 15:47:58)
    2. ACTION: tfherbert - send email csit-dev re vhost use cases for csit  rls 1704 and beyond (mackonstan1, 15:48:48)
    3. https://docs.fd.io/vpp/17.01/vpp_make_test/html/ (tifrank, 15:50:35)

  12. CSIT online docs (mackonstan1, 15:50:49)
    1. https://docs.fd.io/vpp/17.01/vpp_make_test/html/ (mackonstan1, 15:51:07)
    2. https://docs.fd.io/vpp/17.04/vpp_make_test/html/ (mackonstan1, 15:51:49)


Meeting ended at 15:56:00 UTC (full logs).

Action items

  1. tfherbert - send email csit-dev re vhost use cases for csit  rls 1704 and beyond


Action items, by person

  1. tfherbert
    1. tfherbert - send email csit-dev re vhost use cases for csit  rls 1704 and beyond


People present (lines said)

  1. mackonstan1 (47)
  2. pmikus (4)
  3. collabot` (4)
  4. selias (2)
  5. tifrank (2)
  6. tfherbert (1)
  7. sgmonroy (1)
  8. dwallacelf (1)
  9. jgelety (1)


Generated by MeetBot 0.1.4.