#fdio-csit: 31-May FD.io CSIT Project Meeting
Meeting started by mackonstan1 at 13:58:18 UTC
(full logs).
Meeting summary
- 
  - Jan Gelety (jgelety1,
    14:00:25)
 
 
- Agenda bashing (mackonstan1, 14:01:28)
 
- Inputs from LF and FD.io projects (mackonstan1, 14:02:15)
 
- FD.io CSIT operational status (mackonstan1, 14:02:26)
  - [http://fd.io Helpdesk #41298] Jobs are not
    triggered from gerrit - jobs working now apparently (mackonstan1,
    14:04:08)
- vpp-csit-verify-virl- - jobs are continuously
    failing (mackonstan1,
    14:05:30)
- Dave Wallace (dwallacelf,
    14:05:33)
- Peter reporting - issue seems to be related
    change of dpdk vpp pkg introduced by vpp crypto patch (mackonstan1,
    14:07:02)
- Peter Mikus (pmikus1,
    14:07:24)
- Job triggered with latest dpdk version 17.05-vpp4 https://jenkins.fd.io/job/vpp-csit-verify-virl-master/5684/
    (pmikus1,
    14:07:52)
- Peter - using few patches to verify the
    fix (mackonstan1,
    14:08:03)
- Tom Herbert (tfherbert,
    14:09:02)
- Gerrit patch for updating and operational
    branch back to oper-170531 https://gerrit.fd.io/r/#/c/6953/2
    (pmikus1,
    14:09:12)
- Gerrit patch for updating dpdk version
    https://gerrit.fd.io/r/#/c/6952/ (pmikus1,
    14:10:05)
- Why did this patch verify correctly
    (https://gerrit.fd.io/r/#/c/5847/) despite using incompatible dpdk
    pkg version - DPDK_STABLE_VER=17.05-vpp2_amd64 -
    (https://jenkins.fd.io/view/vpp/job/vpp-csit-verify-virl-master/5650/consoleFull)
    (mackonstan1,
    14:13:45)
- Need to revise the way vpp-csit-verify- and
    csit-vpp-verify jobs pick up dpkd pkg (mackonstan1,
    14:15:00)
- ACTION: edwarnicke -
    start a thread to resolve the dpdk pkg ver pegging between csit-dev
    and vpp-dev (mackonstan1,
    14:18:30)
 
 
- Centos7 VIRL tests - status (mackonstan1, 14:18:52)
  - Tom updating - focusing on Centos7 make test
    python library issues (mackonstan1,
    14:19:25)
- Tom device binding issue on TG still
    open (mackonstan1,
    14:20:00)
 
 
- perf tb1 status - still healthy ? (mackonstan1, 14:21:26)
  - Peter - working fine (mackonstan1,
    14:21:51)
 
 
- Test environment updates (mackonstan1, 14:22:17)
 
- adding test equipment: Netgate (mackonstan1, 14:22:41)
  - Matt Smith reporting - was assisting with
    installation in LF labs (mackonstan1,
    14:25:06)
- details of connectivity are unclear
    (mackonstan1,
    14:25:15)
- can assist from Netgate side re onboarding
    Netgate rcc-2758 onto FD.io CSIT (mackonstan1,
    14:25:41)
- all boxes should be running Centos7.0
    (mackonstan1,
    14:25:53)
- has stock Centos + few packages to support
    built-in QAT HW (mackonstan1,
    14:27:11)
- Tom - should be upgraded to Centos 7.3.. that's
    confirmed working fine on Netgate rcc-2758 (mackonstan1,
    14:27:12)
- once boxes onboarded management wise and
    running the right Centos ver, then can proceed with physical setup
    (2-node topology - 2 of Netgate rcc-2758 connected back-to-back over
    2x 10GE) and then start testing … (mackonstan1,
    14:30:01)
- ACTION: - Maciek,
    Tom, Matt - drive progress with Netgate rcc devices - onboarding,
    cabling into 2-node topologies, then go ahead with func tests
    (mackonstan1,
    14:34:08)
 
 
- VIRL platform (mackonstan1, 14:34:28)
 
- VIRL hosts upgrade - tb4-virl1 upgrade status (mackonstan1, 14:35:29)
  - issue - spurious NS/ND pkts seen - root caused
    to running radvd on virl host that was issuing RAs. (mackonstan1,
    14:39:27)
- 2nd issue - qemu starts failing - independent
    on load … happens sporadically - so keeping t/shooting. (mackonstan1,
    14:40:08)
- VIRL hosts upgrade - upgrading remaining hosts:
    tb4-virl2, tb4-virl3 - BLOCKED (mackonstan1,
    14:41:14)
 
 
- CSIT jobs reorgs (mackonstan1, 14:42:06)
  - need to update the csit jobs page - bring the
    most relevant info the top, and review validity of the jobs listings
    … and update accordingly (mackonstan1,
    14:42:55)
- ACTION: Tibor, Jan,
    Maciek to own the csit jobs wiki update (mackonstan1,
    14:43:26)
- https://wiki.fd.io/view/CSIT/Jobs
    (mackonstan1,
    14:43:32)
 
 
- csit1704 report (mackonstan1, 14:44:09)
 
- csit1704 known issues followup (mackonstan1, 14:44:19)
  - Peter updating - recommendation from dpdk test
    team to use x16 slot and use only one 40ge port (mackonstan1,
    14:45:10)
- followup over email on csit-dev to drive
    closure of known issues with xl710 performance (mackonstan1,
    14:45:58)
 
 
- csit1707 plan (mackonstan1, 14:46:10)
  - https://jira.fd.io/secure/RapidBoard.jspa?rapidView=8
    (mackonstan1,
    14:58:35)
 
Meeting ended at 15:03:29 UTC
(full logs).
Action items
  - edwarnicke - start a thread to resolve the dpdk pkg ver pegging between csit-dev and vpp-dev
- - Maciek, Tom, Matt - drive progress with Netgate rcc devices - onboarding, cabling into 2-node topologies, then go ahead with func tests
- Tibor, Jan, Maciek to own the csit jobs wiki update
People present (lines said)
  - mackonstan1 (43)
- collabot` (4)
- pmikus1 (4)
- jgelety1 (1)
- dwallacelf (1)
- tfherbert (1)
Generated by MeetBot 0.1.4.