#fdio-csit: 14-Jun FD.io CSIT Project Meeting

Meeting started by mackonstan1 at 14:00:26 UTC (full logs).

Meeting summary

    1. Maciek K (mackonstan1, 14:00:33)
    2. Jan Gelety (jgelety, 14:00:52)
    3. Tibor Frank (Tibor_, 14:01:11)

  1. Agenda bashing (mackonstan1, 14:01:59)
  2. Inputs from LF and FD.io projects (mackonstan1, 14:04:21)
    1. Tom Herbert (tfherbert, 14:04:25)
    2. Dave Wallace (dwallacelf, 14:04:39)

  3. APIs frozen (mackonstan1, 14:05:30)
  4. vpp (mackonstan1, 14:05:35)
    1. APIs frozen (mackonstan1, 14:05:40)

  5. nsh_sfc project (mackonstan1, 14:06:13)
    1. Tibor updating - jenkins jobs running, but test code broken - in debugging - Peter assisting from csit side. (mackonstan1, 14:06:58)

  6. FD.io CSIT operational status (mackonstan1, 14:07:19)
  7. LF infra, testing jobs (mackonstan1, 14:08:04)
    1. Jan reporting - today observed - high volume of ssh timeouts to VIRL servers - affect vpp-csit-verify- and csit-vpp-verify- (mackonstan1, 14:09:12)
    2. [http://fd.io Helpdesk #41921] connection interruptiones between jenkins executor and VIRL servers (mackonstan1, 14:09:26)
    3. LF IT / Anton stating no underlying issue found yet (mackonstan1, 14:09:39)
    4. pinged abaranov (LF IT / Anton) on #fdio-infra (mackonstan1, 14:13:44)
    5. reply from anton: ok. I'll send a ticket to vexxhost (mackonstan1, 14:14:37)

  8. open - un-pegging dpdk dev package version from CSIT, track vpp master instead? (email thread) (mackonstan1, 14:15:48)
    1. ACTION: Peter, Maciek - high-level proposal in email thread - piggyback on vpp make verify - (mackonstan1, 14:17:15)
    2. ACTION: Peter - proposing a patch to ci-mgmt to be reviewed by csit team and ci-mgmt (mackonstan1, 14:18:24)
    3. vpp team should bless this approach too (mackonstan1, 14:18:36)

  9. Test environment updates (mackonstan1, 14:19:09)
  10. adding test equipment: Netgate (mackonstan1, 14:20:01)
    1. Thomas and Maciek to coordinate the progress with Netgate / Matt (mackonstan1, 14:21:15)

  11. VIRL platform (mackonstan1, 14:22:52)
    1. VIRL hosts upgrade - in production: tb4-virl1, in progress: tb4-virl2, remaining: tb4-virl3 (mackonstan1, 14:23:03)
    2. Peter updating - tb4-virl2 - upgrade done, dry run tests in progress, but some are failing due to the ssh timeout infra issue affecting the verify jobs per earlier note (mackonstan1, 14:24:17)
    3. once dry run tests pass, tb4-virl2 going back into production (mackonstan1, 14:25:39)
    4. tb4-virl3 - expected to be much smoother - 95% automated :) (mackonstan1, 14:25:58)

  12. Centos7 VIRL tests - status (mackonstan1, 14:31:49)
    1. Tom updating - setting up the internal environment to t/shoot the startup issues (mackonstan1, 14:33:24)
    2. current Centos7 issues tracking in csit jira: CSIT-602 (mackonstan1, 14:36:05)
    3. https://jira.fd.io/browse/CSIT-602 (mackonstan1, 14:36:12)

  13. CSIT jobs reorgs (mackonstan1, 14:44:15)
    1. Tibor - wiki page updated and all jobs are verified (mackonstan1, 14:44:27)
    2. https://wiki.fd.io/view/CSIT/Jobs (mackonstan1, 14:44:37)

  14. CSIT design optimizations (mackonstan1, 14:45:26)
    1. implementation steps in progress (mackonstan1, 14:49:41)
    2. Tibor and Maciek updating (mackonstan1, 14:49:46)
    3. Tibor already done: KW renaming, remove unused and not needed KWs, refactor Suite/Test Setup/Tear , performance library dividing into: setups, configuration, utilities (mackonstan1, 14:51:18)
    4. Tibor csit repo directory reshuffle, drive alignment with test naming and results reporting (mackonstan1, 14:51:31)

  15. csit1704 report (mackonstan1, 14:54:43)
    1. any updates to csit-dev pls (mackonstan1, 14:54:58)

  16. csit1707 plan (mackonstan1, 14:55:19)
    1. https://wiki.fd.io/view/CSIT/csit1707_plan (mackonstan1, 15:01:06)
    2. csit1707 plan wiki linked to csit JIRA story tickets (mackonstan1, 15:01:40)


Meeting ended at 15:01:47 UTC (full logs).

Action items

  1. Peter, Maciek - high-level proposal in email thread - piggyback on vpp make verify -
  2. Peter - proposing a patch to ci-mgmt to be reviewed by csit team and ci-mgmt


People present (lines said)

  1. mackonstan1 (47)
  2. collabot (4)
  3. dwallacelf (1)
  4. jgelety (1)
  5. Tibor_ (1)
  6. tfherbert (1)


Generated by MeetBot 0.1.4.