13:32:44 <pmikus1> #startmeeting FD.io CSIT TWS - VPP_Device design
13:32:44 <collabot> Meeting started Thu Aug 9 13:32:44 2018 UTC. The chair is pmikus1. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:32:44 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:32:44 <collabot> The meeting name has been set to 'fd_io_csit_tws___vpp_device_design'
13:33:00 <pmikus1> #chair
13:33:00 <collabot> Current chairs: pmikus1
13:33:07 <pmikus1> #info Peter Mikus
13:34:11 <vrpolak> #info Vratko Polak
13:37:21 <jgelety> #info Jan Gelety
13:39:29 <pmikus1> #info Ed update: Not easy to do SSH connection (interactive SSH)
14:07:42 <pmikus1> #into SSH connectivity possible alongside the Docker exec. We would prefer SSH connectivity between CSIT-shim and Tested topology (sidecar containers)
14:08:17 <pmikus1> #info Agreed that best would be having the scripts in CSIT repo.
14:09:30 <pmikus1> #action Ed to commit all the scripts so far to gerrit so we can see more clearly the whole mechanics and make better picture of how it work
14:13:10 <pmikus1> #info Resources wise, it is possible to run 100+ containers with blank (void) functionality. It is not clear what is CSIT footprint and how much containers will work reliably with accepted response time once CSIT will run there.
14:13:55 <pmikus1> #action Ed to start implementing and running CSIT-shim containers on 1-node SKX TB to provide playground by next week
14:15:48 <pmikus1> #info Containers templates should be also post to gerrit for reviews and comments. We can laverage the work done on jenkins slave container hosted on https://hub.docker.com/u/snergster/
14:16:44 <pmikus1> #info Single template for both TG/DUT is most probably the way to go from manageability point of view.
14:17:39 <pmikus1> #action Peter to review https://hub.docker.com/u/snergster/ jenkins containers if suitable for use for CSIT or CSIT can be based on these.
14:23:16 <pmikus1> #info TB to use: s1-t11-sut1/s2-t12-sut1 currently stock ubuntu-18.04 installed there with single user
14:25:20 <pmikus1> #info So far virtio expose was not tested in containers. (Exposing /sys/bus/pci/) need to agree on who will code the arbiter and reservation mechanics.
14:25:31 <pmikus1> #endmeeting