#fdio-csit: FD.io CSIT project meeting

Meeting started by mackonstan at 14:02:43 UTC (full logs).

Meeting summary

    1. Jan Gelety (jgelety, 14:02:46)

  1. Agenda bashing (mackonstan, 14:02:56)
  2. Inputs from LFN and FD.io projects (mackonstan, 14:03:58)
    1. VPP - Marco updating: cmake updates usage concerns, vpp support for dpdk lts 18.11 and potential impact on CSIT, hyperscan intro into VPP. For detail see notes from VPP call yesterday. (mackonstan, 14:06:23)
    2. Juraj Linkeš (jlinkes, 14:06:31)
    3. Peter Mikus (pmikus, 14:06:31)
    4. Vratko Polak (vrpolak, 14:07:03)
    5. VPP-18.10 - Marco update - 4 weeks to API freeze (mackonstan, 14:08:07)
    6. VPP-18.10 plan wiki deliverables to complete by F0 (mackonstan, 14:10:53)
    7. https://wiki.fd.io/view/Projects/vpp/Release_Plans/Release_Plan_18.10 (mackonstan, 14:10:57)
    8. HC - Michal - switching to new ODL ver, may affect some CSIT tests, should be done next week. (mackonstan, 14:11:47)

  3. CSIT operational status (mackonstan, 14:12:28)
    1. VPP make test failures - Ed updating: i) make test crashing but not stopping - still not fully resolved, some tests still failing on both x86 amd Arm, Juraj working it. (mackonstan, 14:16:04)
    2. VPP make test failures - Juraj updating: ii) jobs hanging on Arm, Juraj looking at it. (mackonstan, 14:19:19)
    3. VPP make test failures - Ed updating: iii) make test on ubuntu 18.04 - most tests pass, but some specific tests fail: MPLS , eBGP PIC, .. (mackonstan, 14:20:45)
    4. https://jenkins.fd.io/sandbox/job/vpp-beta-verify-master-ubuntu1804/ (mackonstan, 14:20:47)

  4. VPP code performance (mackonstan, 14:22:01)
    1. Peter: trending jobs taking now >20hrs, proposal to reduce the duration (mackonstan, 14:28:27)
    2. https://lists.fd.io/g/csit-dev/message/3010 (mackonstan, 14:28:38)
    3. from email: 4 options: 1. Reduce amount of VHOST, 2. Reduce amount of Oacl, Iacl combination, 3. Reduce amount of NICs: x520 only baseline, 4. Decrease cadence of daily to run only once per day. (mackonstan, 14:33:16)
    4. re 3. same for xl710 (mackonstan, 14:33:43)
    5. AGREED: (mackonstan, 14:34:14)
    6. AGREED: to go ahead with points 1,2 and 3. (mackonstan, 14:34:28)
    7. Tibor: will need to adjust PAL filters for trending pages. (mackonstan, 14:35:45)
    8. number of perf tests are failing over the last 14 runs (mackonstan, 14:39:41)
    9. https://docs.fd.io/csit/master/trending/introduction/failures.html (mackonstan, 14:39:49)
    10. quite a few new cases - need to investigate (mackonstan, 14:40:04)
    11. Alerting to csit-report mailer, Tibor to work it once Skx testbeds added to trending (mackonstan, 14:42:16)

  5. CSIT Releases (mackonstan, 14:42:27)
    1. CSIT-18.07 known issues - VPP-1361 still being investigated led by Peter (mackonstan, 14:50:17)
    2. CSIT-18.10 plan wiki page got updated (mackonstan, 14:51:46)
    3. https://wiki.fd.io/view/CSIT/csit1810_plan (mackonstan, 14:52:27)

  6. New test environments (mackonstan, 14:52:45)
    1. VPP_Device 1-Node - Peter: working on resolving issues with Container to PCI mappings (mackonstan, 14:53:50)
    2. orchestration part is working so far (mackonstan, 14:54:02)
    3. for detail, see TWS calls (mackonstan, 14:54:16)
    4. https://wiki.fd.io/view/CSIT/TWS (mackonstan, 14:54:44)
    5. vpp-csit virl jobs still running but not voting (mackonstan, 14:57:34)
    6. csit-vpp virl jobs - Vratko - reporting that often vote -1, for no clear reason (mackonstan, 14:58:12)
    7. take the resolution of this issue to csit-dev (mackonstan, 14:58:51)

  7. Performance trending and analytics (mackonstan, 15:02:59)
    1. Vratko update: waiting to merge patch(es) for moving trending jobs from 1x10sec MRR to 10x1sec MRR tests. (mackonstan, 15:05:10)

  8. TRex (mackonstan, 15:05:28)
    1. no update (mackonstan, 15:05:31)

  9. FD.io CSIT lab infrastructure (mackonstan, 15:05:40)
    1. new Atom Denverton servers - Ray will be updating CSIT lab design pages with details (mackonstan, 15:05:59)
    2. HW RMAs - Peter - no updates, apparently they have shipped, but no ETAs. (mackonstan, 15:06:23)


Meeting ended at 15:06:27 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. mackonstan (45)
  2. collabot (3)
  3. pmikus (1)
  4. vrpolak (1)
  5. jgelety (1)
  6. jlinkes (1)


Generated by MeetBot 0.1.4.