#fdio-csit: FD.io CSIT project meeting 31-Oct-2018.

Meeting started by mackonstan at 15:04:49 UTC (full logs).

Meeting summary

    1. comms problem here, recovering.. 2min.. (mackonstan, 15:05:04)
    2. pls type your presence here (mackonstan, 15:05:17)
    3. Juraj Linkeš (jlinkes, 15:05:24)
    4. Jan Gelety (jgelety, 15:05:59)
    5. Tibor Frank (tifrank, 15:09:01)

  1. Agenda bashing (mackonstan, 15:13:32)
    1. Meeting time needs to be pegged at fixed UTC time, or clearly explain the Summer and Winter time dependencies. (mackonstan, 15:16:47)

  2. Projects - VPP (mackonstan, 15:17:59)
    1. @mackonstan provided update to VPP project yday, CSIT-18.10 rls on target so far. (mackonstan, 15:18:33)

  3. CSIT operational status (mackonstan, 15:18:54)
    1. LF infra - @jgelety all good (mackonstan, 15:19:16)
    2. Jenkins jobs - all clear (mackonstan, 15:19:36)
    3. Jenkins jobs for CSIT-18.10 performance test data and functional test - @jgelety - all pretty much on target (mackonstan, 15:20:17)
    4. @jgelety skx are good, hsw are bit behind (mackonstan, 15:20:29)
    5. @jgelety skx results on target for report release on published date 07-Nov-2018. (mackonstan, 15:28:00)
    6. @jgelety hsw results later, after >10days from today per tracking sheet <link to be posted> (mackonstan, 15:28:29)
    7. all on call agreed this is a rational thing to do (mackonstan, 15:28:54)

  4. VPP code performance (mackonstan, 15:29:57)
    1. some scale tests are failing sporadically, @pmikus suspecting a VPP API related issue (mackonstan, 15:34:23)
    2. ACTION: @pmikus to open jira ticket for above line (mackonstan, 15:34:38)

  5. CSIT Releases (mackonstan, 15:34:57)
    1. CSIT-18.07 known issues updates - no update (mackonstan, 15:35:57)

  6. CSIT-18.10 rls status (mackonstan, 15:36:17)
    1. https://wiki.fd.io/view/CSIT/csit1810_plan (mackonstan, 15:36:34)
    2. new version at the same link, updated during the call (mackonstan, 15:41:07)
    3. https://wiki.fd.io/view/CSIT/csit1810_plan (mackonstan, 15:41:13)
    4. diff at below link (mackonstan, 15:41:21)
    5. https://wiki.fd.io/index.php?title=CSIT%2Fcsit1810_plan&diff=8576&oldid=8554 (mackonstan, 15:41:38)

  7. CSIT Developments - New test environments (mackonstan, 15:43:29)
    1. @pmikus need to move to VPP bionic builds, so far testing xenial builds (mackonstan, 15:43:52)
    2. only VPP_Device runs on bionic builds, all other incl. skx and hsw testbeds are on xenial (mackonstan, 15:44:38)
    3. iow xenial using gcc 4.x, bionic using gcc 7.x, so on skx actually we expect vpp source compiled with gcc-7.x to be bit faster (avx-512, few other skx machine language optimizations - not only at x85 assembler level, but also at x86 assember to Intel SKX micro-ops level too). (mackonstan, 15:46:12)

  8. Arm env updates from @sirshak (mackonstan, 15:47:43)
    1. 1. VPP Device: We are waiting on LF/VexxHost to mount the ThunderX2 required with the 3 Intel XL710, this is required for VPP Device. (mackonstan, 15:47:46)
    2. 2. VPP Path: We are stuck with 3 test case failures(only seen in Cavium ThunderX and Taishan): VPP-1476 VPP-1475 VPP-1478. (mackonstan, 15:47:57)
    3. 3. VPP performance suite: Khem will provide updates on that. (mackonstan, 15:48:09)
    4. above three lines are facsimile of email from Sirshak (mackonstan, 15:48:33)
    5. FYI Khem == Khemendra (mackonstan, 15:49:46)

  9. Performance trending and analytics (mackonstan, 15:50:02)
    1. no updates (mackonstan, 15:50:05)

  10. New graphs (mackonstan, 15:50:17)
    1. @tifrank running code updated (mackonstan, 15:50:52)
    2. draft version of report layout (note: still 18.07 data in graphs), is published here (mackonstan, 15:52:02)
    3. https://docs.fd.io/csit/master/report/ (mackonstan, 15:52:13)
    4. @tifrank expecting the actual 18.10 data to show up in master draft tomorrow (mackonstan, 15:52:47)

  11. TRex (mackonstan, 15:55:50)
    1. no update (mackonstan, 15:55:54)

  12. FD.io CSIT lab infrastructure (mackonstan, 15:56:11)
    1. no update (mackonstan, 15:56:14)

  13. DMM CSIT status (mackonstan, 15:56:24)
    1. no update (mackonstan, 15:56:32)
    2. stale CSIT-18.07 data in report… tests ok on 18.10 base (mackonstan, 15:57:24)

  14. Housekeeping (mackonstan, 15:57:59)
    1. no updates (mackonstan, 15:58:04)
    2. ACTION: @mackonstan to bring up request for dedicated #slack channel for fdio-csit (mackonstan, 16:00:08)
    3. bring it up on tomorrow TSC call. (mackonstan, 16:00:20)


Meeting ended at 15:35:30 UTC (full logs).

Action items

  1. @pmikus to open jira ticket for above line
  2. @mackonstan to bring up request for dedicated #slack channel for fdio-csit


Action items, by person

  1. mackonstan
    1. @mackonstan to bring up request for dedicated #slack channel for fdio-csit


People present (lines said)

  1. mackonstan (59)
  2. collabot` (4)
  3. tifrank (1)
  4. jlinkes (1)
  5. jgelety (1)


Generated by MeetBot 0.1.4.