14:01:51 <mackonstan> #startmeeting FD.io CSIT project meeting
14:01:51 <collabot> Meeting started Wed May 15 14:01:51 2019 UTC.  The chair is mackonstan. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:51 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:01:51 <collabot> The meeting name has been set to 'fd_io_csit_project_meeting'
14:01:53 <jgelety> #info Jan Gelety
14:01:54 <tifrank> #info Tibor Frank
14:01:55 <pmikus> #info Peter Mikus
14:02:06 <vrpolak> #info Vratko Polak
14:04:43 <mackonstan> #topic Agenda bashing
14:05:02 <dwallacelf> #info Dave Wallace
14:05:17 <mackonstan> #topic FD.io CSIT lab infrastructure
14:05:25 <mackonstan> #info skip, no Mohammed
14:06:17 <mackonstan> #topic VPP project update
14:07:39 <mackonstan> #info DaveW - plan to release vpp-19.01.2 waiting for one more outstanding vpp patch
14:08:13 <mackonstan> #info DaveW - waiting for CSIT to confirm testbed resource for 19.01.2 testing
14:08:50 <mackonstan> #info DaveW - 19.04.1 gated by IPsec verification tests, currently scheduled for 19.01.2 + 14d
14:10:59 <mackonstan> #info DaveW - 19.08 tag applied, rls plan hasn't started yet, AndrewY and DaveW leading it
14:11:16 <mackonstan> #topic HC update
14:11:37 <mackonstan> #info Michal - HC stable/1904 released, test results in the report
14:12:07 <mackonstan> #info Michal - HC doesn't need to retest for VPP maintenance releases as long as APIs are not changing
14:12:59 <mackonstan> #info Michal - have some outstanding jvpp issues.
14:13:23 <mackonstan> #info Michal - HC tests running in VIRL, some ported to VPP_Device platform
14:14:11 <mackonstan> #topic TSC
14:17:06 <mackonstan> #info Modernizing CI/CD infrastructure working team recommendations available
14:17:13 <mackonstan> #info Infrastructure Working Group Summary Report available
14:17:20 <mackonstan> #link https://wiki.lfnetworking.org/display/LN/Infrastructure+Working+Group+Summary+Report
14:18:14 <mackonstan> #topic Operational status
14:19:25 <mackonstan> #info Jenkins down yesterday - number of CSIT-1904 jobs killed - few 100s hrs of testing lost
14:24:55 <tfherbert> #info Tom Herbert
14:29:26 <mackonstan> #info Maciek - sharing screen with Jan's CSIT-1904 test job execution tracking xls
14:30:07 <mackonstan> #info need to cap max job duration to better manage the risk of Jenkins/infra outages
14:33:40 <mackonstan> #info and in the meantime seriously pursue alternative CI strategy to the existing one, even if it's quite a stretch to expect any migration is successfully completed during one release cycle
14:39:31 <mackonstan> #info Peter - recommend to consider async mode for Jenkins job, that do not require non-stop presence of jenkins over the job lifecycle
14:41:36 <mackonstan> #topic Release CSIT-1904
14:48:12 <mackonstan> #info latest version week20 of report published
14:48:23 <mackonstan> #link https://docs.fd.io/csit/rls1904/report/
14:49:14 <mackonstan> #info data missing: 3n-hsw full test runs, some nfv density tests, tcp wrk tests - will be added in next report ver(s)
14:49:52 <mackonstan> #info data missing: vpp operational data "show runtime" due to CSIT bug, will be added in the next full run for VPP-19.04.1
14:51:51 <mackonstan> #info TomFH - still working on Centos VPP_Device tests, should be ready for 19.04.1
14:59:16 <mackonstan> #action JanG, Maciek, DaveW - work out and propose test coverage for vpp-19.01.2 based on available resources
15:01:01 <mackonstan> #endmeeting