#fdio-csit: FD.io CSIT project meeting

Meeting started by mackonstan at 14:57:12 UTC (full logs).

Meeting summary

  1. Agenda bashing (mackonstan, 15:00:44)
    1. Vratko Polak. (vrpolak, 15:02:17)

  2. FD.io CSIT physical labs (mackonstan, 15:03:03)
    1. Dave Wallace (dwallacelf, 15:03:45)
    2. PM: one 2n-skx testbed is down, reporting read-only ssd error, similar to before. (mackonstan, 15:03:52)
    3. Jan Gelety (jgelety, 15:04:04)
    4. PM, VP: 2n-clx testbeds are fully in operation. one testbed is missing mlx5 nics. e.g. need to have a separate job for mlx5 tests. (mackonstan, 15:06:32)
    5. ACTION: MK: ask Trishan to order 2 mlx5 NICs, matching models in the lab. (mackonstan, 15:07:05)

  3. Inputs from LFN and FD.io projects - VPP (mackonstan, 15:07:40)
    1. DW: for 19.08 still didn't sync up with Andrew re next maintenance release. (mackonstan, 15:08:21)
    2. DW: lots of patches (100s) cherry-picked into stable/1908 since 19.08.1 tag. Proposing a weekly trending performance tests, with associated web-pages and notification emails to csit-report (summary of failures, regressions, progressions). (mackonstan, 15:12:07)
    3. ACTION: DW: to review trending test with vpp community, as well as regular cadence for LTS maintenance releases. (mackonstan, 15:13:10)
    4. DW: re v19.04.3 maintenance release - not seeing value in executing CSIT perf tests on this minor release. (mackonstan, 15:14:17)
    5. JG: showing xls summary of physical testbeds used for 1908.1 - total 14 days. (mackonstan, 15:16:59)
    6. JG: tables already incl. minor rls and trending data, need to add major rls, impact of outages and what's left is for development (testbed-type, time) (mackonstan, 15:24:11)

  4. Inputs from LFN and FD.io projects - TSC (mackonstan, 15:25:03)
    1. VP: missed the last TSC meeting, but wanted to share a pointer to CSIT patch covering all identified Scapy licensing issues (mackonstan, 15:26:11)
    2. DW: not much discussed on the last TSC call, Scapy licensing was not covered (mackonstan, 15:26:28)

  5. Releases (mackonstan, 15:26:41)
  6. CSIT-2001 plan (mackonstan, 15:28:24)
    1. JG: Python migration - proposed plan in patch (mackonstan, 15:28:49)
    2. https://gerrit.fd.io/r/c/csit/+/22638 (mackonstan, 15:29:13)
    3. Agreed to target w/c 18-Nov for a big-bang week for migration to Python 3.6.8. (mackonstan, 15:33:46)
    4. Nidhy: asked about API coverage in device tests - list to cover is available in resources/api/vpp/supported_crcs.yaml (mackonstan, 15:47:13)

  7. Operational status (mackonstan, 15:48:25)
    1. Peter: reporting ongoing issues with testbeds losing their mgmt IP addresses. (mackonstan, 15:48:50)
    2. need to have LFN ticket# (mackonstan, 15:52:36)
    3. Peter: DPDK tests down due to DPDK API bug that crept into VPP master. Reverted by Damjan, so should be back to normal tomorrow. (mackonstan, 15:54:31)
    4. Tibor: Jenkins is going down - was restarted yday, day before, see email from Vanessa on csit-dev. (mackonstan, 15:56:59)

  8. Developments (mackonstan, 15:58:57)
    1. VP: should prioritise cleanup tasks before freezing it for Python migration (mackonstan, 15:59:38)
    2. set1: VIRL cleanup and related projects that only rely on VIRL: HC, nsh_sfc, dmm. (mackonstan, 16:01:10)
    3. set2: Ligato tests. (mackonstan, 16:01:18)
    4. set3: changes that are open waiting for weeks, if not merged before the python-migration-bigbang-week, they will have to be rebased post migration. (mackonstan, 16:03:28)


Meeting ended at 16:04:23 UTC (full logs).

Action items

  1. MK: ask Trishan to order 2 mlx5 NICs, matching models in the lab.
  2. DW: to review trending test with vpp community, as well as regular cadence for LTS maintenance releases.


People present (lines said)

  1. mackonstan (34)
  2. collabot (4)
  3. vrpolak (1)
  4. dwallacelf (1)
  5. jgelety (1)


Generated by MeetBot 0.1.4.