15:00:07 <mackonstan> #startmeeting FD.io CSIT project meeting
15:00:07 <collab-meetbot> Meeting started Wed Dec  9 15:00:07 2020 UTC and is due to finish in 60 minutes.  The chair is mackonstan. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:07 <collab-meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:07 <collab-meetbot> The meeting name has been set to 'fd_io_csit_project_meeting'
15:00:11 <mackonstan> #chair
15:00:11 <collab-meetbot> Current chairs: mackonstan
15:00:13 <jgelety> #info Jan Gelety
15:00:26 <mackonstan> #topic Agenda bashing
15:00:30 <vrpolak> #info Vratko Polak.
15:01:00 <tifrank> #info Tibor Frank
15:01:48 <mackonstan> #info Maciek: would like to add two topics: i) jenkins configuration transparency; ii) physical DCs (YUL-1, YUL-2) move and consolidation into one physical DC location as proposed by Vexxhost (deadline 15-March-2021).
15:02:30 <dwallacelf> #info Dave Wallace
15:08:03 <mackonstan> #topic Inputs from projects - VPP
15:09:26 <mackonstan> #info F0 milestone classified as a no-op, will be removed from the next release
15:10:02 <mackonstan> #topic Inputs from projects - TSC
15:11:24 <mackonstan> #topic Releases - CSIT-2101
15:11:39 <mackonstan> #link https://wiki.fd.io/view/CSIT/csit2101_plan
15:14:05 <mackonstan> #info Vratko, working on improving / enhancing nat44ed astf pps throughput tests
15:14:54 <mackonstan> #info Jan, re geneve perf tests, should be able to correct uncovered issues by RC1 date
15:16:18 <mackonstan> #info Juraj, re Arm items, not expecting any delays, all phy lab infra tasks got completed
15:16:35 <mackonstan> #topic Physical Infrastructure
15:17:03 <mackonstan> #info Juraj, mgmt switch will be procured so no more issues expected
15:23:08 <mackonstan> #info Maciek, physical DCs (YUL-1, YUL-2) move and consolidation into one physical DC location as proposed by Vexxhost (deadline 15-March-2021).
15:24:06 <mackonstan> #info Andrew, if we have a visibility and influence on the move schedule, then we should aim for hitless move
15:26:33 <mackonstan> #info Dave, agrees with Andrew, collocation stuff is good, chance to complete the cleanup
15:27:57 <mackonstan> #topic Virtual Infrastructure, CI/CD
15:28:31 <mackonstan> #info Vanessa, since Monday, every morning, Jenkins UI becomes unresponsive, getting 500 errors
15:29:08 <mackonstan> #info Vanessa, keep comparing FD.io instance vs. ODAP and XXXX instances that have 4x number of jobs, and keep increasing scale params in FD.io instanc
15:29:29 <mackonstan> #info Vanessa, yesterday upgraded monitoring plugins, and everything was running good yday
15:29:47 <mackonstan> #info Vanessa, unfortunately still the issue was observed this morning
15:30:23 <mackonstan> #info Vanessa, side issue discovered was a buggy gerrit trigger plugin, upgraded to by mistake, now reverted to previous version
15:31:32 <mackonstan> #info Vanessa, one observation, RF plugin is killing the CPU util and eating lots of memory … could this be a cause of Jenkins UI issues
15:32:29 <mackonstan> #info Bug tracking Jenkins system: https://jira.linuxfoundation.org/browse/RELENG-3325
15:32:49 <mackonstan> #link https://jira.linuxfoundation.org/browse/RELENG-3325
15:37:06 <mackonstan> #info Vanessa Q: can the RF plugin be disabled temporarily?
15:37:45 <mackonstan> #info 6+1 committers/contributors answered: yes, nobody against, so let's go ahead.
15:38:21 <mackonstan> #info Vanessa, going ahead then.
15:40:59 <mackonstan> #info Vanessa, see the following error in logs, in thousands "error  javax.imageio.IIOException: I/O error writing PNG file!"
15:41:54 <mackonstan> #info Maciek's new topic: jenkins configuration transparency
15:45:28 <mackonstan> #info Vanessa, Jenkins moving to jcasc configuration, see this patch for details
15:45:31 <mackonstan> #link https://gerrit.fd.io/r/c/ci-management/+/30100
15:46:56 <mackonstan> #info Vanessa, all startup and runtime configuration is covered, minus credentials
15:47:15 <mackonstan> #info Vanessa, some global and cloud variables are also excluded
15:47:31 <mackonstan> #link https://git.fd.io/ci-management/tree/jenkins-config
15:48:55 <mackonstan> #info Dave, patch 30100 went thru initial reviews by Dave, Vratko, Peter, but more reviews pending
15:49:25 <mackonstan> #info Migration from Nexus to S3
15:49:33 <mackonstan> #info Vanessa, working on logs
15:49:41 <mackonstan> #info Vanessa, ETA in 2021
15:51:30 <mackonstan> #info Vanessa, will also be moving to different Vexxhost VM flavour for Jenkins executors
15:52:23 <mackonstan> #info Juraj, VPP device jobs, arm thunderx2 jobs are still unstable, due to intermittent AVF issue - firmware or i40e driver
15:54:05 <mackonstan> #info see email thread
15:55:07 <mackonstan> #info Juraj, in the meantime see if a w/a can be implemented
15:58:38 <dwallacelf> #topic Environment, Framework
15:58:56 <dwallacelf> #info Vratko Update on PAPI socket connection
15:59:17 <dwallacelf> #info Vratko added GPL license checker for CSIT tox job
15:59:42 <dwallacelf> #topic Performance Tests
16:00:04 <dwallacelf> #info No issues to be discussed
16:00:21 <dwallacelf> #topic Functional Tests
16:00:50 <dwallacelf> #info Already discussed in release topics
16:02:37 <dwallacelf> #topic Inactive fdio-yul VPN users
16:04:02 <dwallacelf> #action Andrew to investigate process for deactivating fdio-yul users
16:05:20 <dwallacelf> #endmeeting