#fdio-csit: FD.io CSIT project meetinh

Meeting started by mackonstan at 14:01:36 UTC (full logs).

Meeting summary

    1. Vratko Polak. (vrpolak, 14:02:06)

  1. Agenda bashing (mackonstan, 14:02:57)
    1. Dave Wallace (dwallacelf, 14:04:51)

  2. Inputs from projects (mackonstan, 14:05:31)
  3. Inputs from projects - VPP (mackonstan, 14:05:45)
  4. Inputs from projects- VSAP (mackonstan, 14:06:30)
    1. Jan Gelety (jgelety, 14:06:32)
    2. DaveW, VSAP project is continuing to onboard (mackonstan, 14:06:47)
    3. DaveW, this includes CSIT patches, under review, moving ahead smoothly (mackonstan, 14:07:09)
    4. Inputs from projects - TSC (mackonstan, 14:07:19)

  5. Inputs from projects - TSC (mackonstan, 14:07:26)
    1. Vratko, slow progress on GPL licensing (mackonstan, 14:08:05)

  6. Releases (mackonstan, 14:08:37)
  7. Releases - CSIT-2005 (mackonstan, 14:08:53)
    1. Tibor, 2 remaining 3n-skx tests are running in the background, and missing ndrpdr 2n-dnv and 3n-dnv as they are failing (Yulong, Ray should be on it) (mackonstan, 14:10:50)
    2. Tibor, Vratko's RCA patch is under review, final one. (mackonstan, 14:11:12)
    3. DaveW, vpp v20.05.1 released, need to agree CSIT coverage (mackonstan, 14:12:50)
    4. ACTION: DaveW, Maciek - recommend CSIT 2005.1 coverage (mackonstan, 14:13:25)

  8. Releases - CSIT-1908.x (mackonstan, 14:14:41)
    1. ACTION: DaveW, AndrewY, Maciek - recommend CSIT-1908.3 coverage (mackonstan, 14:15:48)

  9. Releases - CSIT-2009 (mackonstan, 14:16:07)
    1. Vratko, CSIT should be keeping up with API changes, avoiding prolonged use of deprecated APIs (mackonstan, 14:21:58)
    2. Vratko, CSIT must be keeping up with replaced terms in VPP APIs and DPDK apps (testpmd, l3fwd) (mackonstan, 14:22:58)

  10. Physical Infrastructure (mackonstan, 14:29:09)
    1. Keesang, new AMD testbed, servers are racked up but not wired, some confusion about the wiring despite the info in the vexxhost ticket. Maciek will push a patch with clear description of wiring required, will add Keesang as reviewer, and point ticket to the patch (mackonstan, 14:37:32)
    2. Govind, ThunderX2 is arriving to Vexxhost DC tomorrow. Will open the vexxhost ticket to drive installation. (mackonstan, 14:38:29)

  11. Virtual Infrastructure, CI/CD (mackonstan, 14:38:50)
    1. DaveW, maintenance window y'day, Nomad and Jenkins Nomad plugins updated (mackonstan, 14:39:29)
    2. Peter, updated Nomad cluster installation with Ansible (mackonstan, 14:39:46)
    3. DaveW, in the process 2 servers died (SSDs with old fw), ticket open (mackonstan, 14:40:14)
    4. Peter, all Nomad servers on Ubuntu 18.04 and latest Nomad v0.12 (mackonstan, 14:41:23)
    5. Vratko, Andrew, keeping vpp-csit-verify-device job, keeping it not voting due to potential for -1 due to api change (mackonstan, 14:51:35)
    6. Vratko, Andrew, but the risk is considered low (mackonstan, 14:51:46)

  12. Environment, Framework (mackonstan, 14:53:22)
  13. Performance Tests (mackonstan, 14:53:40)
    1. Tibor, trending pages require refresh due to changed test sets, both daily mrr weekly ndrpdr, presentation layer only. (mackonstan, 14:56:33)
    2. Tibor, will look in extending the time period of trending coverage from current mrr daily from 3 mths to 4 mths, ndrpdr weekly from 3 mths to 6 mths (mackonstan, 14:58:43)
    3. Jan, nat44ed tests, astf patch in review this week and then cps tests (mackonstan, 15:00:01)


Meeting ended at 15:00:19 UTC (full logs).

Action items

  1. DaveW, Maciek - recommend CSIT 2005.1 coverage
  2. DaveW, AndrewY, Maciek - recommend CSIT-1908.3 coverage


People present (lines said)

  1. mackonstan (38)
  2. collab-meetbot (4)
  3. vrpolak (1)
  4. dwallacelf (1)
  5. jgelety (1)


Generated by MeetBot 0.1.4.