14:05:37 <dwallacelf> #startmeeting FD.io CSIT Weekly Meeting
14:05:37 <collab-meetbot> Meeting started Wed Oct 21 14:05:37 2020 UTC and is due to finish in 60 minutes. The chair is dwallacelf. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:05:37 <collab-meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:05:37 <collab-meetbot> The meeting name has been set to 'fd_io_csit_weekly_meeting'
14:05:41 <vrpolak> #info Vratko Polak.
14:05:42 <jgelety> #info Jan Gelety
14:05:43 <dwallacelf> #info Dave Wallace
14:05:51 <tifrank> #info Tibor Frank
14:05:52 <dwallacelf> #chair jgelety
14:05:52 <collab-meetbot> Warning: Nick not in channel: jgelety
14:05:52 <collab-meetbot> Current chairs: dwallacelf jgelety
14:05:56 <dwallacelf> #chair pmikus
14:05:56 <collab-meetbot> Warning: Nick not in channel: pmikus
14:05:56 <collab-meetbot> Current chairs: dwallacelf jgelety pmikus
14:06:14 <pmikus> #info Peter Mikus
14:06:22 <dwallacelf> #topic Agenda bashing
14:08:25 <dwallacelf> #topic Inputs from projects
14:09:12 <dwallacelf> #info VPP: nothing new to report
14:09:29 <dwallacelf> #info VSAP: nothing to report
14:10:41 <dwallacelf> #info TSC: scapy waiting for permission to re-license from Nidhi, other code was rewritten
14:10:58 <dwallacelf> CNCF: nothing to report
14:11:14 <dwallacelf> #info CNCF: nothing to report
14:11:31 <dwallacelf> #topic Releases
14:11:43 <dwallacelf> #info CSIT-21.01 Plan TBD
14:13:10 <dwallacelf> #info CSIT-20.09: Report 20.09.43 added today, added Nat44 tests
14:13:59 <dwallacelf> #info CSIT-20.09: RCA's no regressions bigger than 5%, but looking at regression of L2patch (some regression, but also period of time test was broken)
14:14:13 <dwallacelf> #info Bi-secting under way
14:15:30 <dwallacelf> #info RCA: Nat44 deterministic investigation under way.
14:16:01 <dwallacelf> #topic Physical Infrastructure
14:16:26 <dwallacelf> #info Performance testing:
14:16:47 <dwallacelf> #info Performance testing:
14:17:11 <dwallacelf> #info Functional driver testing: nothing new to report
14:18:07 <dwallacelf> #info New ARM testbeds: thunder-x2 servers are in nomad, but working on adding CI jobs running on them.
14:19:23 <dwallacelf> #info New AMD testbeds: issues with stability and test runs (~40% test failures). Work to continue via email thread.
14:20:52 <dwallacelf> #info FD.io lab extension in 2021: New Icelake servers delayed ~3 months. Plan to be worked on in preparation for March/April delivery.
14:21:10 <dwallacelf> #topic Virtual Infrastructure, CI/CD
14:21:47 <dwallacelf> #info LFN FD.io CI/CD systems: Another Jenkins restart required this Monday. No RCA provided to date.
14:26:28 <dwallacelf> #info No RCA for jenkins memory issue provided by LFIT to date.
14:27:21 <dwallacelf> #info Gerrit ci-management change 28022 is ready for final review/merge. Docker images are being built and put into production using the scripts from 28022.
14:28:33 <dwallacelf> #info Centos-8 docker x86_64 images are being worked on next as well as aarch64 images (centos-7 & 8).
14:30:11 <dwallacelf> #info Generation of csit docker images will be worked on after 28022 is merged. Currently delayed a bit due to additional workload of developers.
14:31:39 <dwallacelf> #info It is time to create CSIT-20.09 LTS branch and start trending jobs for 20.09 LTS branch
14:33:13 <dwallacelf> #action jgelety work on patch to create trending jobs and create branch.
14:34:06 <dwallacelf> #topic Environment, Framework
14:39:02 <dwallacelf> #info Linux updates: Plan for updating CSIT to Ubuntu-20.04 is to complete docker image generation for CSIT executors in 21.01 and start conversion to Ubuntu20.04 in Feb 2021
14:42:00 <dwallacelf> #info Juraj reported vppdevice aarch64 nodes updated to latest kernel caused a VPP crash. Will work on a process for kernel updates and qualification of kernel updates.
14:42:32 <dwallacelf> #info Would like to see if the crash can be reproduced on x86_64.
14:50:31 <dwallacelf> #action DaveW to start email thread to address definition of CSIT process to test VPP with the latest linux kernel, cpu firmware, device drivers, &/or nic firmware.
14:52:15 <dwallacelf> #action Juraj to send email to vpp-dev@lists.fd.io to bring VPP community attention to the aarch64 crash and ask for help verifying if this happens on x86_64.
14:53:07 <dwallacelf> #info TRex updates: currently no plans to update trex unless a bug is encountered
14:54:31 <dwallacelf> #info Vratko proposes to addition of Trex and python library updates to the kernel (et al) discussion.
14:55:24 <dwallacelf> #info VPP API changes' tracking: 1 pending change for nat44, csit changes ready & being tested
14:58:42 <dwallacelf> #topic Performance Tests
14:58:59 <dwallacelf> #info Nothing to discuss
14:59:10 <dwallacelf> #topic Functional Tests
14:59:23 <dwallacelf> #info Nothing to discuss
15:00:18 <dwallacelf> #endmeeting