#fdio-csit: FD.io CSIT project meeting

Meeting started by mackonstan at 15:05:35 UTC (full logs).

Meeting summary

    1. Jan Gelety (jgelety, 15:05:40)
    2. Tibor Frank (tifrank, 15:05:41)
    3. Dave Wallace (dwallacelf, 15:05:43)
    4. Vratko Polak. (vrpolak, 15:05:44)
    5. Juraj Linkeš (jlinkes, 15:05:54)

  1. Agenda bashing (mackonstan, 15:06:04)
  2. DST starts (mackonstan, 15:08:32)
    1. keeping meeting time same for Europe/UK, PDT/EDT guys have it one hour later (local time). (mackonstan, 15:09:16)

  3. Physical labs, testbeds (mackonstan, 15:09:28)
    1. Peter update - all Skx machines upgraded to BIOS v3.2 per Intel recommendations to address ucode issues; SSD firmware to avoid RMAs leading to some SSDs dying and needed to be replaced and OS reinstalled. (mackonstan, 15:12:21)
    2. All skx testbeds are now in operation. (mackonstan, 15:12:34)
    3. Govind from Arm is still waiting for VPN access, ticket open. (mackonstan, 15:14:58)

  4. Inputs from projects (mackonstan, 15:15:27)
    1. Dave update: VPP - v20.05 schedule F0 06-May (mackonstan, 15:17:49)
    2. Maciek update: TSC - Ray presented Scapy/GPLv2 points, TSC voting expected this or next week. (mackonstan, 15:19:38)
    3. Maciek update: TSC - vpp dev event collocated with dpdk dev event in France in october (mackonstan, 15:20:33)

  5. Releases CSIT-2001 (mackonstan, 15:21:05)
    1. Testing - Jan update - last ndrpdr select test running for Tsh, all other performance tests are done. (mackonstan, 15:22:05)
    2. Testing - Jan - soak 2n-clx running (some vhost test failures), reconfig 2n-clx done, 2n-clx and 3n-hsw hoststack done (mackonstan, 15:24:13)
    3. Testing - Jan - only Skx tests left to close CSIT-2001. Trending cadence can be returned to normal for all but skx testbeds. (mackonstan, 15:25:08)
    4. Report - Tibor - latest maintenance version is out, all produced test data included: (mackonstan, 15:26:51)
    5. https://docs.fd.io/csit/rls2001/report/ (mackonstan, 15:27:00)
    6. additions are recorded here: (mackonstan, 15:27:32)
    7. https://docs.fd.io/csit/rls2001/report/introduction/report_history.html (mackonstan, 15:27:34)
    8. ACTION: Dave, Florin, Maciek - would be good to review the hoststack testing sections (mackonstan, 15:31:23)
    9. https://docs.fd.io/csit/rls2001/report/vpp_performance_tests/hoststack_testing/index.html (mackonstan, 15:31:36)
    10. Skx update - Maciek, Peter - BIOS upgraded to v3.2, very low NDR issue still open on all but one 2n-skx testbed. increasing NIC driver ring size elevates the issue. Under investigation with Intel, another sync tomorrow. If not line of sight to resolution, looking to go ahead with CSIT-2001 testing with increased ring sizes and compare to default setting. (mackonstan, 15:43:43)

  6. Releases CSIT-1908 (mackonstan, 15:45:54)
    1. Peter - some fixes applied, vpp-device tests are now running. (mackonstan, 15:46:16)
    2. Vratko - like more changes required for performance tests. (mackonstan, 15:46:38)
    3. Dave - will ask on the next VPP call, if any calls for v19.08.2 rls (mackonstan, 15:49:36)

  7. Operations (mackonstan, 15:49:49)
    1. Ed Kern - all quiet, all working (mackonstan, 15:50:08)
    2. Ed Kern - disabling retries - patch open in ci-mgmt (mackonstan, 15:50:43)
    3. vpp-csit-device tests - re-enable voting - Vratko - infrequent failures still happening, needs to be investigate (mackonstan, 15:51:47)
    4. Ed - while Vanessa away, stand in is eball@linuxfoundation.org (mackonstan, 15:52:20)
    5. Centos CI - no update (mackonstan, 15:52:33)

  8. VPP code performance (mackonstan, 15:55:47)
    1. number of issues in trending in master - see email summaries in csit-report mailer (mackonstan, 15:56:28)

  9. Developments (mackonstan, 15:56:44)
    1. API functional test coverage - Vijay - IPsec tests, encryption works decryption doesn't (mackonstan, 15:57:31)
    2. Performance: No new regressions. I tried to bisect for two new failures on 3n-hsw, but results were not stable, the failure is not deterministic. Finally, there is one apparent progression on 3n-hsw I tracked to one testbed having better performance. Examining it now. (vrpolak, 15:59:26)


Meeting ended at 16:01:30 UTC (full logs).

Action items

  1. Dave, Florin, Maciek - would be good to review the hoststack testing sections


People present (lines said)

  1. mackonstan (40)
  2. collabot` (4)
  3. vrpolak (2)
  4. jgelety (1)
  5. dwallacelf (1)
  6. jlinkes (1)
  7. tifrank (1)


Generated by MeetBot 0.1.4.