#fdio-csit: FD.io CSIT project meeting

Meeting started by mackonstan at 14:02:22 UTC (full logs).

Meeting summary

    1. Vratko Polak. (vrpolak, 14:02:31)
    2. Peter Mikus (pmikus, 14:02:46)
    3. Tibor Frank (tifrank, 14:03:44)

  1. Agenda bashing (mackonstan, 14:03:51)
  2. Physical labs, testbeds (mackonstan, 14:04:08)
    1. Peter - old faulty SSDs got replaced. (mackonstan, 14:04:51)
    2. Peter - 3 more SSDs failed - 3n-skx, and 2 of 2n-skx (mackonstan, 14:05:25)
    3. Jan Gelety (jgelety, 14:05:56)
    4. Peter - some progress made on getting SSD spares, purchased and shipped. (mackonstan, 14:06:19)
    5. Peter - 10 SSDs spare (mackonstan, 14:06:39)
    6. Peter - 15 SSDs shipped as RMAs, no RCAs received. (mackonstan, 14:07:06)
    7. Dave Wallace (dwallacelf, 14:07:36)
    8. Peter - thread with CSIT, Vexxhost, LFN IT, missing is Intel eng contact. (mackonstan, 14:08:40)
    9. ACTION: Maciek, Ray to pick it up from Peter and team (mackonstan, 14:08:55)

  3. Inputs from projects (mackonstan, 14:10:57)
  4. VPP (mackonstan, 14:11:26)
    1. Dave - 20.05 API freeze is May-6, next Wed (mackonstan, 14:11:32)
    2. Dave - RC0 is week after that May-13 (mackonstan, 14:11:55)
    3. Dave - no schedule for v19.08.2 yet, waiting for CSIT progress and test data analysis (mackonstan, 14:13:01)

  5. VSAP (mackonstan, 14:13:20)
    1. https://gerrit.fd.io/r/c/csit/+/26660 <-- Add test cases about VSAP project with VPP TLS to CSIT (vrpolak, 14:13:20)
    2. Dave - 3k patch pushed in (mackonstan, 14:13:34)
    3. Dave - 3 kloc patch pushed in (mackonstan, 14:14:00)
    4. Dave - asked for simplifying the patch, separating infra from test, for VSAP to send someone to VPP and CSIT calls, and spin up FD.io project resources (mackonstan, 14:16:28)
    5. Dave - it is unfeasible to expect that this patch and tests to be included in CSIT-2005. More conversation needs to happen with Ping and Ray. (mackonstan, 14:17:25)
    6. Dave - Ping is to be the PTL for VSAP project, once the project is actually spun up. (mackonstan, 14:17:48)

  6. TSC (mackonstan, 14:19:44)
    1. Dave - Scapy / GPLv2 - work still ongoing (mackonstan, 14:20:06)
    2. Discussion about Docker image registry, as "FD.io" already taking in dockerhub (mackonstan, 14:20:29)
    3. Vratko - Discussion about Docker image registry, as "FD.io" already taking in dockerhub (mackonstan, 14:21:08)
    4. https://gerrit.fd.io/r/c/csit/+/23143 <-- GPL saga part one, move files without switching license yet. (vrpolak, 14:21:52)
    5. Side comments - Dave - Nomad images and code to be stored in ci-management (mackonstan, 14:21:53)

  7. Releases (mackonstan, 14:24:42)
  8. CSIT-2001 Release - 2n-skx, 3n-skx re-test (mackonstan, 14:25:09)
    1. Jan - 2n-skx - 10 runs complete, 3n-skx - 5 runs complete (SSD failures inhibit the progress here). (mackonstan, 14:25:55)
    2. Jan - 2n-skx - full-set tests done, 3n-skx - full-set tests not not done, will do after 6th repeatability run complete (mackonstan, 14:26:53)
    3. Tibor - report data publishing is ready, just awaiting updated files with RCA details. (mackonstan, 14:27:37)
    4. Vratko - bi-secting and RCA'ing is progressing slow, most of RCAs should be filed by next Wed May-6 (mackonstan, 14:29:02)

  9. CSIT-1908 Release (mackonstan, 14:29:54)
  10. CSIT-1908 Release - Maintenance (mackonstan, 14:30:07)
    1. Jan - 2n-skx - 10 runs complete (for repeatability), all l2-patch tests are failing (checking for missing cherry-pick, as similar was observed in the vpp master post 19.08.1 rls), all other tests are passing. (mackonstan, 14:31:38)
    2. Tibor - 2n-skx - 19.08.2 vs. 19.08.1 is ready in master (mackonstan, 14:32:03)
    3. https://docs.fd.io/csit/master/report/_static/vpp/performance-changes-1908_2-2n-skx-2t1c-ndr.txt (tifrank, 14:32:47)
    4. https://docs.fd.io/csit/master/report/_static/vpp/performance-changes-1908_2-2n-skx-2t1c-pdr.txt (tifrank, 14:33:18)
    5. https://docs.fd.io/csit/master/report/_static/vpp/performance-changes-1908_2-3n-skx-2t1c-ndr.txt (tifrank, 14:33:36)
    6. https://docs.fd.io/csit/master/report/_static/vpp/performance-changes-1908_2-3n-skx-2t1c-pdr.txt (tifrank, 14:33:51)
    7. Jan - 3n-skx - 2 runs completed too. (mackonstan, 14:40:50)
    8. Consensus on the call to go ahead with v19.08.2 (mackonstan, 14:44:11)
    9. https://docs.releng.linuxfoundation.org/en/latest/meetbot.html <-- MeetBot Guide :) (vrpolak, 14:44:35)

  11. CSIT-2005 Release (mackonstan, 14:45:40)
    1. CSIT F0 may-6, RC1 may-13. (mackonstan, 14:49:19)

  12. Operations (mackonstan, 14:50:21)
    1. Vratko - LF IT maintenance went well, no issues, all smooth (mackonstan, 14:50:56)

  13. VPP code performance (mackonstan, 14:51:10)
    1. Tibor - added ndrpdr weekly comparison to the trending pages (mackonstan, 14:51:30)
    2. https://docs.fd.io/csit/master/trending/introduction/weekly.html (tifrank, 14:51:34)
    3. Vratko - some progressions and regressions are visible on MRR daily and on PDR weekly, some are not (mackonstan, 14:54:48)
    4. Vratko - it would be nice to compare the above weekly trending with current daily dashboard (mackonstan, 14:56:13)
    5. https://docs.fd.io/csit/master/trending/introduction/dashboard.html (mackonstan, 14:56:15)
    6. discussion - separate the weekly NDRPDR tests between single run (to see if tests pass/fail) and multiple runs for statistically meaningful data for week-by-week comparison (mackonstan, 14:58:36)
    7. Jan - daily trending - ipsec tests are failing, bisecting wip, offending patch to be identified shortly (mackonstan, 14:59:34)
    8. Jan - will use Vratko's auto-bisecting code to find the bad apple (mackonstan, 15:00:16)

  14. Developments (mackonstan, 15:00:44)
    1. Jan - new srv6 api tests are in review, pls review before F0 next week (mackonstan, 15:01:09)


Meeting ended at 15:01:49 UTC (full logs).

Action items

  1. Maciek, Ray to pick it up from Peter and team


People present (lines said)

  1. mackonstan (55)
  2. tifrank (10)
  3. collab-meetbot (4)
  4. vrpolak (4)
  5. pmikus (1)
  6. jgelety (1)
  7. dwallacelf (1)


Generated by MeetBot 0.1.4.