15:00:54 <mackonstan> #startmeeting FD.io CSIT Project Meeting
15:00:54 <collab-meetbot`> Meeting started Wed Mar 10 15:00:54 2021 UTC and is due to finish in 60 minutes.  The chair is mackonstan. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:54 <collab-meetbot`> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:54 <collab-meetbot`> The meeting name has been set to 'fd_io_csit_project_meeting'
15:01:32 <mackonstan> #info mackonstan
15:01:37 <vrpolak> #info Vratko Polak.
15:01:45 <jlinkes> #info Juraj Linkeš
15:02:03 <mackonstan> #topic Agenda bashing
15:03:50 <tifrank> #info Tibor Frank
15:03:56 <dwallacelf> #info Dave Wallace
15:05:35 <mackonstan> #topic Inputs from projects - VPP
15:05:41 <mackonstan> #info Dave reporting
15:06:18 <mackonstan> #info vpp-dev meeting happened yday, v21.06 schedule confirmed
15:08:18 <mackonstan> #info Vratko, vpp api change tracking, specifically address CRC'ing backward compatible APIs, CRC check job needs a new collection of CRCs to check against
15:10:34 <mackonstan> #topic Inputs from projects - VSAP
15:20:12 <mackonstan> #info Dave, 2 sets of patches 31333, 31334, by Xi Zhang, one of them changing the test environment, so considering this as higher risk item
15:24:47 <mackonstan> #info Maciek, it will be faster for the key parties to jump on the call, walk thru the vpp, ldp, nginx testing path, and then dive into the integration into CSIT framework - stakeholders: VSAP (Xi Zhang, Fan Zhang), VPP (Dave W, Florin), CSIT (Maciek, Peter)
15:25:50 <mackonstan> #topic Inputs from projects - TSC
15:27:48 <mackonstan> #info Maciek, RayK raised the point about funding server HW for TG servers, make sure that this is included by all parties in their HW donation planning.
15:28:06 <mackonstan> #topic CSIT-2106
15:29:13 <mackonstan> #topic CSIT-2101
15:34:27 <mackonstan> #info Tibor, report update posted last week, added GSO tests
15:35:35 <mackonstan> #info Tibor, async ipsec tests to be added once analysed by Vratko/Maciek/other-volunteer
15:36:08 <mackonstan> #info at that will be it
15:36:35 <mackonstan> #topic FD.io DC move in Mar 2021
15:40:59 <mackonstan> #info Maciek, Vexxhost DC move of FD.io Nomad and CSIT testbed servers/HW: MTL2 (1 rack) move to YUL1 complete, MTL1 (4 racks) move to YUL1 to be scheduled
15:41:23 <mackonstan> #info MTL2 move verified as successful, all issues sorted
15:41:32 <mackonstan> #info Big thanks to Peter Mikus, Andrew Yourtchenko and Dave Wallace for assisting with the move, and working with Vexxhost to iron out some "teething issues"
15:45:49 <mackonstan> #topic FD.io lab extension in 2021
15:49:09 <mackonstan> #info Maciek, following on the discussion at TSC about TG, need to come up with a proposal about "standardised" TG platform for all testbeds (note any variations if appropriate), the practical aspects of operating it in CSIT framework (calibration, drivers, etc)
15:50:32 <mackonstan> #action Maciek, Peter, Dave, develop a strawman proposal, present at the next CSIT call, drive consensus there, and then bring it up in TSC meeting (expect funding discussion there)
15:51:00 <mackonstan> #topic Virtual Infrastructure, CI/CD
15:52:09 <mackonstan> #info Tibor, testbed occupancy/util for trending jobs, after optimisations longest tests are 7-8 hrs (good!)
15:52:21 <mackonstan> #info Tibor, above is about daily trending
15:53:44 <mackonstan> #info Tibor, but there are some "bloating" / growing duration weekly test jobs, 30-44 hrs.
15:56:46 <mackonstan> #info Maciek, need to look closer at how to control this, Maciek/Tibor
15:59:26 <mackonstan> #topic Environment, Framework
16:00:30 <mackonstan> #info Dave, with Peter testing Ubuntu 20.04, looking good, but transition from 18.04 to 20.04 is going to take time, due to the volume of servers we have (60 +)
16:02:24 <mackonstan> #info Peter, having some issues with old Xeon Haswell servers
16:05:35 <mackonstan> #topic Performance Tests
16:08:12 <mackonstan> #info Tomas, looking at trending failures, writing a summary
16:09:57 <mackonstan> #endmeeting