#fdio-meeting: TSC Meeting 2016-03-10

Meeting started by edwarnicke at 16:00:51 UTC (full logs).

Meeting summary

  1. Roll Call (edwarnicke, 16:00:57)
    1. edwarnicke (edwarnicke, 16:00:59)
    2. joelhalpern (joelhalpern, 16:01:03)
    3. https://wiki.fd.io/view/TSC#Agenda <- Agenda (edwarnicke, 16:02:54)
    4. dbarach present (dbarach, 16:04:31)

  2. Agenda Bashing (edwarnicke, 16:06:03)
    1. Venky (Venky, 16:06:41)
    2. added CSIT readout (edwarnicke, 16:10:04)
    3. added Pre-Formation Projects agenda item (edwarnicke, 16:10:17)

  3. Events (edwarnicke, 16:10:21)
    1. fd.io Meetup at ONS - 5-5:45pm Wed 2016-03-16 - Napa Conference Room (edwarnicke, 16:11:24)
    2. Venky asks if we should plan a summer Training/Hackfest in Eu (edwarnicke, 16:11:44)
    3. suggestions that we do one Hackfest/Training a quarter, rotate locations (edwarnicke, 16:13:02)
    4. goal to see a couple this year (edwarnicke, 16:13:17)
    5. alagalah suggests ODL summit (as GBP+SFC in ODL are planning a fd.io implementation) (edwarnicke, 16:14:13)
    6. Venky suggets Linuxcon (edwarnicke, 16:14:18)
    7. alagalah suggets dockercon/containercon/any CNF initiative once we sort out our container storry (edwarnicke, 16:14:51)
    8. joelhalpern asks if we would like to do something at IETF hackfests (edwarnicke, 16:15:44)

  4. Pre-Formation Projects (edwarnicke, 16:16:59)
    1. alagalah announces pre-formation on a netlink agent project (edwarnicke, 16:17:22)
    2. http://manpages.ubuntu.com/manpages/trusty/en/man7/netlink.7.html NETLINK(7) (alagalah, 16:17:27)
    3. netlink contact email alagalah@gmail.com (alagalah, 16:18:44)
    4. joelhalpern asks about netlink... as he'd understood it to be a way for userspace to talk to the kernel, and vpp is userspace (edwarnicke, 16:19:41)
    5. alagalah explains that many userspace applications have an expectation of talking to the kernel to get network services. Could use LDPRELOAD to intercept netlink messages and hand them to VPP for the things it should handle, pass through to kernel for everything else. (edwarnicke, 16:20:31)
    6. joelhalpern 's question was answered :) (edwarnicke, 16:21:31)
    7. Venky is interested (edwarnicke, 16:21:36)
    8. Venky discusses some of his experiences around this (edwarnicke, 16:22:05)
    9. #fdio-netlink (edwarnicke, 16:26:20)
    10. https://wiki.fd.io/view/IRC <- please add (edwarnicke, 16:26:38)
    11. Ash Young suggested adding to the IRC page under proposals section (edwarnicke, 16:28:29)
    12. Ash Young notes he'd like to follow up with Venky about possible netlink collisions with filesystem stuff (edwarnicke, 16:29:24)
    13. ACTION: Venky to email discuss@lists.fd.io explaining some of the subtlties he's experienced around doing netlink agents (edwarnicke, 16:29:59)
    14. https://wiki.fd.io/view/IRC#fd.io_Channels Added section for "unofficial" channels (alagalah, 16:30:14)
    15. Netlink project IRC channel #fdio-netlink (alagalah, 16:30:31)

  5. Making infrastructure tickets visible to the community (edwarnicke, 16:30:49)
    1. cj not present to discuss (edwarnicke, 16:30:57)

  6. Security Process (edwarnicke, 16:31:06)
    1. Ash Young has not yet completed the Security Process Draft (edwarnicke, 16:31:39)
    2. ACTION: Ash Young draft of security process for next TSC call (edwarnicke, 16:32:08)

  7. CSIT Readout (edwarnicke, 16:32:39)
    1. skobza to readout on CSIT (edwarnicke, 16:32:58)
    2. three labs in process (edwarnicke, 16:33:26)
    3. performance lab on hardware (edwarnicke, 16:33:31)
    4. virl setup, single server, to run jobs for larger topologies - run every test case for functionality, working for weeks now (edwarnicke, 16:33:57)
    5. LF VMs - Any kind of a verify/merge job with multiple VM spawning with some OpenStack provider. (edwarnicke, 16:34:29)
    6. Found out last night that cannot use LF VMs because OpenStack Security makes it useless, dropping any packets not preassigned by OpenStack (edwarnicke, 16:34:56)
    7. expecting response from LF infra today or tomorrow (edwarnicke, 16:35:10)
    8. dbarach opines that for VPP protocol interop testing that for control we are likely to need something like VIRL to actually test, as OpenStack is not able to actually support network testing, and the Linux limitations in terms of RFC support (edwarnicke, 16:36:39)
    9. skobza expects to get response from LF provider and get email out to lists in the next few days (edwarnicke, 16:37:25)
    10. CSIT project proposal scheduled for next week (edwarnicke, 16:37:38)
    11. CSIT has 18 basic tests so far (edwarnicke, 16:38:03)

  8. Draw attention to Project Proposals out for public comment (edwarnicke, 16:38:37)
    1. https://lists.fd.io/pipermail/tsc/2016-March/000022.html <- CSIT (edwarnicke, 16:38:56)
    2. https://lists.fd.io/pipermail/tsc/2016-March/000029.html <- Honeycomb (edwarnicke, 16:39:09)
    3. https://lists.fd.io/pipermail/tsc/2016-March/000028.html <- NSH SFC (edwarnicke, 16:39:22)


Meeting ended at 16:40:21 UTC (full logs).

Action items

  1. Venky to email discuss@lists.fd.io explaining some of the subtlties he's experienced around doing netlink agents
  2. Ash Young draft of security process for next TSC call


Action items, by person

  1. Venky
    1. Venky to email discuss@lists.fd.io explaining some of the subtlties he's experienced around doing netlink agents


People present (lines said)

  1. edwarnicke (56)
  2. collabot` (9)
  3. alagalah (4)
  4. dbarach (1)
  5. Venky (1)
  6. joelhalpern (1)
  7. barach (0)
  8. keith_wiles (0)


Generated by MeetBot 0.1.4.