#fdio-meeting: fdio-vpp

Meeting started by DaveBarach at 15:01:39 UTC (full logs).

Meeting summary

    1. mackonstan (mackonstan, 15:02:01)

  1. CSIT (Maciek reporting) (DaveBarach, 15:02:49)
    1. Physical infrastructure updates (mackonstan, 15:03:20)
    2. New Intel Xeon ICX based testbeds - orders placed (mackonstan, 15:03:29)
    3. 3n-hsw testbeds are finally getting decommissioned (mackonstan, 15:03:49)
    4. Test breakages - daily (MRR rapid-fire tests), weekly (NDRPDR proper perf) process, sporadic unless otherwise noted: (mackonstan, 15:04:19)
    5. 1) rdma-core on one testbed, switching driver problem; (mackonstan, 15:04:33)
    6. 2) create avf interface, moving thru NIC rxq configurations; (mackonstan, 15:04:45)
    7. 3) nat44ed 16M sessions test, sessions not getting established in allotted time for some tests; (mackonstan, 15:05:41)
    8. 4) deterministic for specific (frame_size, core config): ipsec sw asyn tests, no traffic forwarded; (mackonstan, 15:06:01)
    9. 5) VSAP tests with MLX (mackonstan, 15:06:22)
    10. CSIT-2106 report to be published tomorrow (mackonstan, 15:06:47)
    11. Draft report available at the usual place (mackonstan, 15:06:54)
    12. https://docs.fd.io/csit/master/report/ (mackonstan, 15:06:59)
    13. CSIT-2106 release deliverables (mackonstan, 15:07:05)
    14. https://wiki.fd.io/view/CSIT/csit2106_plan (mackonstan, 15:07:11)

  2. Host Stack (damjan) (DaveBarach, 15:08:29)
    1. TCP half-opens allocated in main thread connection pools instead of separate connection pools. Syns for half-open connections now follow established packet path. (dmarion, 15:08:38)
    2. Optimized cut-through fifo allocations. Fifo segments are allocated per app-pair as opposed to per session. (dmarion, 15:08:45)
    3. VCL epoll optimizations for level triggered and postponed events (dmarion, 15:08:52)
    4. Pre-release bug fixing (dmarion, 15:08:57)

  3. Doc (no Ole, no Ray) skipping (DaveBarach, 15:09:25)
    1. Still working on Nexus retirement, which will affect docs. More next month. (DaveBarach, 15:09:59)

  4. Release Management (Andrew, Dave W) (DaveBarach, 15:10:11)
    1. 21.01.1 tag tomorrow AM in Europe time (DaveBarach, 15:10:33)
    2. 21.06 nothing much to add (DaveBarach, 15:10:46)
    3. 21.10 release plan up on the wiki (DaveBarach, 15:10:56)
    4. 21.10 release cadence will be the same as 21.06 (DaveBarach, 15:11:43)
    5. Coverity: report format updated, added defects by component stanzas (DaveBarach, 15:13:30)
    6. worth highlighting that we removed the API CRC generation crutches (DaveBarach, 15:14:23)
    7. also fixed crc calculation which has been wrong for a year / affects about half of the messages (DaveBarach, 15:15:01)

  5. Infra Status (Dave W) (DaveBarach, 15:15:45)
    1. went through a bunch of changes with Vexxhost which have stabilized CI. At this point, few spurious failures. (DaveBarach, 15:16:38)
    2. last step: move Jenkins master to the data center which has all of the executors (DaveBarach, 15:17:12)
    3. Fixed a couple of nagging failures in host stack tests (DaveBarach, 15:17:49)
    4. Please report any intermittent test case failures to DW (DaveBarach, 15:18:11)
    5. "It's been quiet..." (DaveBarach, 15:18:40)
    6. Centos-8 jobs removed from master; still exist in older branches (DaveBarach, 15:19:12)

  6. IPsec SPD flow cache (Govind) (DaveBarach, 15:19:47)
    1. aarch64 optimizations led to algorithmic change (DaveBarach, 15:20:58)
    2. test data from Thunderx2 (DaveBarach, 15:21:51)
    3. hash-based flow cache addresses linear SPD search (DaveBarach, 15:24:58)
    4. 2x patches, plus unit-tests (DaveBarach, 15:30:45)

  7. Next Meeting (Damjan) (DaveBarach, 15:36:20)
    1. AGREED: Skip August meeting due to projected low attendance / Damjan unlikely to make it (DaveBarach, 15:37:30)


Meeting ended at 15:38:02 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. DaveBarach (29)
  2. mackonstan (15)
  3. collab-meetbot` (5)
  4. dmarion (4)


Generated by MeetBot 0.1.4.