13:59:10 <mackonstan> #startmeeting FD.io CSIT Project Meeting
13:59:10 <collab-meetbot`> Meeting started Wed Jun 29 13:59:10 2022 UTC and is due to finish in 60 minutes.  The chair is mackonstan. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:59:10 <collab-meetbot`> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:59:10 <collab-meetbot`> The meeting name has been set to 'fd_io_csit_project_meeting'
13:59:15 <mackonstan> #info mackonstan
13:59:30 <tifrank> #info Tibor Frank
13:59:45 <vrpolak> #info Vratko Polak.
14:02:03 <jlinkes> #info Juraj Linkeš
14:02:54 <mackonstan> #topic Agenda bashing
14:03:45 <mackonstan> #topic Inputs from projects
14:03:51 <mackonstan> #topic Inputs from projects - VPP
14:04:49 <mackonstan> #info Andrew, vpp v22.06 rls artefacts in packagecloud - should be there in a matter of 3-4 hrs
14:05:04 <mackonstan> #topic Inputs from projects - TSC
14:06:24 <mackonstan> #info Maciek - getting quotations for MLX 100 GbE NICs from Vexxhost
14:07:34 <mackonstan> #topic Releases CSIT-2206
14:08:24 <mackonstan> #info Tibor, rc2 testing is done, all data published in the master report. retesting of previous rls 22.02 in the current csit environment also done.
14:08:43 <fan_zhang> #info Fan Zhang - sorry for being late.
14:08:48 <mackonstan> #info Tibor, added all new icx testbeds, they've been tested with rc2 images, quite a few issues, all fixed
14:08:59 <mackonstan> #info Welcome Fan!
14:10:41 <mackonstan> #info Tibor, added comparison tables with throughput normalized to 2 GhZ frequency
14:14:05 <mackonstan> #info Tibor, the new comparison tables are available for preview here
14:14:37 <mackonstan> #link https://s3-docs.fd.io/csit/master/report/_static/vpp/norm-compare-testbeds-3n-skx-3n-icx-1c-pdr.txt
14:15:21 <mackonstan> #info the original comparison tables are still there
14:15:43 <mackonstan> #link https://s3-docs.fd.io/csit/master/report/_static/vpp/performance-compare-testbeds-3n-skx-3n-icx-1c-pdr.txt
14:23:28 <mackonstan> #info Vratko proposed improvement, add new column to existing tables, call it normalized diff and be done with it
14:23:50 <mackonstan> #info no need to calling out any normalizaation freq as it cancels out
14:24:15 <mackonstan> #agreed go ahead with Vratko's proposal, Tibor will push a new patch
14:24:32 <dwallacelf> #info Dave Wallace
14:25:15 <mackonstan> #info Tibor, rls artefacts testing starting tomorrow
14:25:47 <mackonstan> #info Maciek, Viliam, working on the documenting the known issues into the report
14:26:41 <mackonstan> #info Vratko, looking at regressions, one at 2% but noisy so unclear if a real one
14:27:44 <mackonstan> #info Vratko, some 3n-dnv fluctuations due to wrong links speed negotiations
14:28:13 <mackonstan> #info Vratko, 100 GbE multi-core speedup results are looking good, close to linear :)
14:30:46 <mackonstan> #info Vratko, Peter, 2n-zn2 multi-core speedup graphs are not looking too good
14:30:57 <mackonstan> #link https://s3-docs.fd.io/csit/master/report/vpp_performance_tests/throughput_speedup_multi_core/ip4-2n-zn2-cx556a.html
14:33:22 <mackonstan> #info Peter, will double-check the setup and the environment and report back in next couple of days
14:34:17 <mackonstan> #info Peter, vpp telemetry collection, fixed now, and showing the correct as expected values for all telemetry, show run, show int, show perfmon
14:36:52 <mackonstan> #info Maciek, now that we are collecting correct telemetry, would like us to consider, after the release, to add them to the CSTI UTI model and provide User Interface to see and compare them
14:37:56 <mackonstan> #info Maciek, Peter, SNR SUTs re still down, due to inability to use IPMI for console access.
14:38:48 <mackonstan> #info Peter, working on adding SNR testbeds to ansible playbooks, to bring them up and verify them, possibly may be able to executed dry runs, and possibly have data for the rls
14:39:54 <mackonstan> #info Peter, as we don't have access to BIOS, the test results may not be reliable
14:41:54 <mackonstan> #info Tibor, re CVL 100 GbE flow-based tests, got added to job - the patch is still not merged
14:41:58 <mackonstan> #link 36491: job_specs: add IPsec perf tests and GTPU perf tests to regression | https://gerrit.fd.io/r/c/csit/+/36491
14:42:06 <mackonstan> #info one outstanding comment
14:42:18 <mackonstan> #info Fan, will take care of this comment
14:42:35 <mackonstan> #info Tibor, another patch for job_specs affecting rls testing
14:43:01 <mackonstan> #link 36544: job-spec: Reduce number of iterative tests for 2n-clx | https://gerrit.fd.io/r/c/csit/+/36544
14:43:11 <mackonstan> #info Maciek, will review it after this call
14:46:45 <mackonstan> #info Maciek, Tibor, re report, main work is adding 3n-alt testbed (Juraj, Maciek), normalized comparisons (Tibor), rls_notes, methodology (astf, autogen)
14:47:34 <mackonstan> #topic Physical Infrastructure
14:47:53 <mackonstan> #topic Virtual Infrastructure, CI/CD
14:49:52 <mackonstan> #info Dave, re 1.5 weeks ago Jenkins in Shutdown Mode, it was put into this state by a human operator pre/during upgrade; LF-IT / Vanessa confirmed that the SRE / NOC team got re-confirmed to never do this
14:50:04 <mackonstan> #info without prior notice warning
14:50:51 <mackonstan> #info Dave, hoststack and quick tests, got all fixed by VPP patches - Dave and Florin - got merged into the stable branch yesterday
14:52:39 <mackonstan> #info Dave, Maciek, action to add those tests to trending
14:55:58 <mackonstan> #info Dave, note to Peter, need a single landing page for docs.fd.io, currently the index does not exist for top-level directories, for both docs.fd.io and s3-docs.fd.io
14:57:26 <mackonstan> #topic Trending
14:57:46 <mackonstan> #info Maciek, see latest email from Viliam in csit-report mailer - no new failures
14:58:02 <mackonstan> #info Vratko, some issues listed in meeting agenda have been fixed.
14:59:19 <mackonstan> #endmeeting