16:00:38 <edwarnicke> #startmeeting FD.io TSC
16:00:38 <collab-meetbot> Meeting started Thu Jan 13 16:00:38 2022 UTC and is due to finish in 60 minutes.  The chair is edwarnicke. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:38 <collab-meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:38 <collab-meetbot> The meeting name has been set to 'fd_io_tsc'
16:00:41 <edwarnicke> #topic rollcall
16:00:43 <edwarnicke> #info edwarnicke
16:00:46 <JoelHalpern> #info Joel Halpern
16:01:02 <edwarnicke> #chair JoelHalpern mackonstan
16:01:02 <collab-meetbot> Warning: Nick not in channel: JoelHalpern
16:01:02 <collab-meetbot> Warning: Nick not in channel: mackonstan
16:01:02 <collab-meetbot> Current chairs: JoelHalpern edwarnicke mackonstan
16:02:34 <mackonstan> #info mackonstan
16:04:29 <valderrv> #info valderrv
16:05:08 <edwarnicke> #chair valderrv
16:05:08 <collab-meetbot> Warning: Nick not in channel: valderrv
16:05:08 <collab-meetbot> Current chairs: JoelHalpern edwarnicke mackonstan valderrv
16:05:13 <edwarnicke> #chair vrpolak
16:05:13 <collab-meetbot> Warning: Nick not in channel: vrpolak
16:05:13 <collab-meetbot> Current chairs: JoelHalpern edwarnicke mackonstan valderrv vrpolak
16:06:38 <mortderire> #info Ray Kinsella
16:06:49 <edwarnicke> #chair mortderire
16:06:49 <collab-meetbot> Warning: Nick not in channel: mortderire
16:06:49 <collab-meetbot> Current chairs: JoelHalpern edwarnicke mackonstan mortderire valderrv vrpolak
16:07:47 <edwarnicke> #chair dwallacelf
16:07:47 <collab-meetbot> Warning: Nick not in channel: dwallacelf
16:07:47 <collab-meetbot> Current chairs: JoelHalpern dwallacelf edwarnicke mackonstan mortderire valderrv vrpolak
16:07:48 <dwallacelf> #info Dave Wallace
16:13:05 <edwarnicke> #agreed ask for four week nomination and then four week election procedure to be initiated by Trishan
15:02:45 <collab-meetbot`> mackonstan: Error: Can't start another meeting, one is in progress.  Use #endmeeting first.
15:02:49 <mackonstan> #info mackonstan
15:04:13 <fan_zhang> #info Fan Zhang
15:04:38 <jlinkes> #info Juraj Linkeš
15:04:53 <dwallacelf> #info Dave Wallace
15:05:15 <tifrank> #info Tibor Frank
15:06:38 <mackonstan> #topic Agenda bashing
15:06:55 <mackonstan> #info Maciek: added "VPP RC1 hot patch(es) items" topic
15:07:41 <mackonstan> #info Maciek: TRex and 100GbE NICs for performance testing, ICE/CVL, MLX
15:08:27 <pim> mackonstan: interested in ice/mlx 100G testing - where can I contribute ?
15:09:22 <mackonstan> #chair mackonstan, Fan Zhang, Dave Wallace, Tibor Frank,  Juraj Linkeš
15:09:22 <collab-meetbot`> Warning: Nick not in channel: Fan
15:09:22 <collab-meetbot`> Warning: Nick not in channel: Zhang
15:09:22 <collab-meetbot`> Warning: Nick not in channel: Dave
15:09:22 <collab-meetbot`> Warning: Nick not in channel: Wallace
15:09:22 <collab-meetbot`> Warning: Nick not in channel: Tibor
15:09:22 <collab-meetbot`> Warning: Nick not in channel: Frank
15:09:22 <collab-meetbot`> Warning: Nick not in channel: Juraj
15:09:22 <collab-meetbot`> Warning: Nick not in channel: Linkeš
15:09:22 <collab-meetbot`> Current chairs: Dave Fan Frank JoelHalpern Juraj Linkeš Tibor Wallace Zhang dwallacelf edwarnicke mackonstan mortderire valderrv vrpolak
15:09:42 <mackonstan> #chair
15:09:42 <collab-meetbot`> Current chairs: Dave Fan Frank JoelHalpern Juraj Linkeš Tibor Wallace Zhang dwallacelf edwarnicke mackonstan mortderire valderrv vrpolak
15:10:39 <mackonstan> #info reply to pim - we will be discussing it later in this call that is currently live, details at the link below
15:10:47 <mackonstan> #link https://wiki.fd.io/view/CSIT/Meeting
15:11:05 <mackonstan> #topic VPP updates
15:11:49 <mackonstan> #info Andrew, rc1 tag to be applied today
15:12:05 <mackonstan> #info Andrew, no showstopper for rc1 identified
15:14:10 <mackonstan> #topic TSC update
15:14:20 <mackonstan> #info TSC chair election is imminent
15:14:26 <mackonstan> #info Dave, Ed will be sending email
15:15:12 <mackonstan> #info Maciek, Dave, in last TSC meeting, all agreed to have at least 4 weeks nomination, followed by max 2 weeks voting
15:15:29 <pim> FWIW - Meeting is only open for authorized attendees (I've been rejected)
15:16:57 <mackonstan> #info mackonstan reply to pim - meeting is open to everyone. But zoom requires attendees to authenticate to avoid abuse/hijacking. Standard free zoom logins work, I am just using one (google login)
15:17:19 <mackonstan> #topic New or (to be) refactored tests
15:18:30 <mackonstan> #info Fan, E810 flow "offload" tests, device: plan to update tests with new dpdk offload flags - discussing it with the team …
15:20:11 <mackonstan> #info mackonstan reply to pim: if you are still struggling attending this meeting, then i'm happy to assist you later to make sure you get it sorted
15:21:51 <mackonstan> #info Maciek: Scale tests, Address perf test jobs with excessive execution time - weekly ndrpdr - 2n-skx, 2n-clx over 24hrs - work with Tibor to reduce the qty / combination of tests to bring it within 24hrs window
15:22:33 <mackonstan> #topic VPP RC1 hot patch(es) items
15:25:17 <mackonstan> #info VPP MTU patches: latest one 34928: vnet: distinguish between max_frame_size and MTU | https://gerrit.fd.io/r/c/vpp/+/34928
15:25:59 <mackonstan> #info above patch is merged, made before rc1 deadline
15:29:07 <mackonstan> #info Maciek, Andrew, need to follow up on how CSIT tests are setting the MTUs, and specifically the error handling by VPP (and CSIT) when wrong/bad MTU value is set
15:30:19 <mackonstan> #info Fan, Maciek, re DPDK v21.11 vhost tests passing, Fan: unclear what got fixed for this bug only … will follow up with code review with Damjan
15:31:04 <mackonstan> #topic Releases CSIT-2202
15:32:45 <mackonstan> #info Fan, late comment, re VPP RC1 patches, some patches didn't verify yet, QAT support for chacha/poly
15:32:57 <mackonstan> #info Andrew, to follow up on the vpp list / calls
15:33:08 <mackonstan> #info Maciek - any hot item work to complete before CSIT RC2
15:34:32 <mackonstan> #info Peter - need to upgrade FVL and CVL DPDK drivers to be compatible with DPDK v21.11, luckily no firmware upgrade
15:35:20 <mackonstan> #topic Physical Infrastructure
15:36:44 <mackonstan> #info Peter - 2nd 1n-skx vpp-device testbed is back in operation
15:37:56 <mackonstan> #info Peter - after driver changes in the past, hitting issue in 2n-dnv and 3n-dnv testbed, seems to be related to mtu and with ethernet autonegotiation
15:38:26 <mackonstan> #info Maciek, new topic - TRex and 100GbE NICs for performance testing, ICE/CVL, MLX
15:49:25 <mackonstan> #info Maciek, Pim, Peter - discussed options - cx5 for clx, cx5ex or cx6 for icx (cx6 if better than cx5ex justified), future consider cx7 for spr
15:51:22 <mackonstan> #info Peter, Perf - Initial 5 Intel ICX servers install and commissioning status - mgmt switch should be coming online next week
15:53:17 <mackonstan> #info Juraj, re Perf - Ampere Altra server(s) delivery ETA, Arm still waiting for hardware, current ETA Feb 2022
15:53:53 <mackonstan> #info Juraj, re Ampere Altra servers delivery ETA , should be shipping from Austin shortly
15:54:01 <mackonstan> #topic Virtual Infrastructure, CI/CD
15:55:18 <mackonstan> #info Dave, re FD.io storage migration to S3, away from Nexus - list is still WIP, but comleting migration tracking for after 22.02 rls
15:57:12 <mackonstan> #topic Trending
15:57:32 <mackonstan> #info quick review of csit-report failures digest email
15:58:25 <mackonstan> #link https://lists.fd.io/g/csit-report/topic/csit_breakages_for_week_03/88482678?p=,,,20,0,0,0::recentpostdate/sticky,,,20,2,0,88482678,previd=1642493791780721342,nextid=1642186267432562827&previd=1642493791780721342&nextid=1642186267432562827
15:58:46 <mackonstan> #topic Fd.io Events
16:03:37 <mackonstan> #info Maciek, had a really good FD.io CSIT talk in LFN dev&testing forum last Thu, "Performance Benchmarking, Anomaly Detection, Results Tracking"
16:04:20 <mackonstan> #info Links to: i) session wiki, ii) slides, iii) zoom mp3 recording, listed below (in that order)
16:04:33 <mackonstan> #link https://wiki.lfnetworking.org/pages/viewpage.action?pageId=65538382
16:04:48 <mackonstan> #link https://wiki.lfnetworking.org/download/attachments/65538382/lfn-ddts21-fdio-csit.pdf?version=1&modificationDate=1642187365000&api=v2
16:05:01 <mackonstan> #link https://wiki.lfnetworking.org/download/attachments/65538382/lfn-ddts21-fdio-csit.mp4?version=1&modificationDate=1642175623000&api=v2
16:05:04 <mackonstan> #endmeeting