14:44:26 <dwallacelf> #startmeeting GoVPP Community Meeting
14:44:26 <collab-meetbot`> Meeting started Thu Jan 11 14:44:26 2024 UTC and is due to finish in 60 minutes.  The chair is dwallacelf. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:44:26 <collab-meetbot`> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:44:26 <collab-meetbot`> The meeting name has been set to 'govpp_community_meeting'
14:44:45 <dwallacelf> #topic Roll Call / Agenda Bashing
14:45:39 <dwallacelf> #info Attendees -- Ondrej, Aman, Arthur, Dave
14:46:55 <dwallacelf> #topic Action Items
14:48:23 <dwallacelf> #info Mohsin Kazmi to maintain libmemif in VPP repo
14:49:40 <dwallacelf> #info Isues related to GoMemif have been addressed in PRs which were merged
14:59:54 <dwallacelf> #action Dave to talk to Mohsin about maintaining GoMemif implementation as well as VPP/libmemif
15:14:09 <dwallacelf> #action Arthur investigate any know consumers of GoVPP/libmemif and/or gomemif
15:16:34 <dwallacelf> #action Dave reach out to CSIT to add interoperability testing for VPP/libmemif, VPP/memif plugin, GoVPP/libmemif, GoVPP/gomemif, and DPDK/memif PMD
15:22:36 <dwallacelf> #info Vlado rebased PR#116 and Nathan added comments
15:22:52 <dwallacelf> #action Ondrej to review/merge PR#116
15:23:24 <dwallacelf> #topic Inputs From Projects
15:24:24 <dwallacelf> #info VPP Release Plan 24.02 is published, RC1 is Jan 24, 2024
15:24:35 <dwallacelf> #link https://wiki.fd.io/view/Projects/vpp/Release_Plans/Release_Plan_24.02
15:27:43 <dwallacelf> #info Calico/VPP is now GA as of Calico Release 3.27
15:28:32 <dwallacelf> #topic Technical Discussion
15:29:36 <dwallacelf> #info Discussion of VPP API cleanup
15:33:36 <dwallacelf> #action Ondrej to review current state of GoVPP CLI linting output
15:42:05 <dwallacelf> #info Ondrej added PR#183 to address lack of synchronization of VPPApiError enum & descriptions.
15:43:52 <dwallacelf> #info Ondrej investigating a mechanism to add an app or extenstion to GoVPP/cli to send api messages directly.  Discussion about possibility of using such an app in VPP make test refactoring plan.
15:43:56 <dwallacelf> #endmeeting