14:30:34 <dwallacelf> #startmeeting GoVPP Community Meeting
14:30:34 <collab-meetbot> Meeting started Thu Jan 25 14:30:34 2024 UTC and is due to finish in 60 minutes.  The chair is dwallacelf. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:34 <collab-meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:30:34 <collab-meetbot> The meeting name has been set to 'govpp_community_meeting'
14:32:32 <dwallacelf> #topic Roll Call / Agenda Bashing
14:39:46 <dwallacelf> #topic Action Items
14:40:12 <dwallacelf> #info Arthur confirmed that Calico/VPP does not use gomemif
14:40:35 <dwallacelf> #action Dave to talk to Mohsin about maintaining GoMemif implementation as well as VPP/libmemif
14:40:54 <dwallacelf> #action Dave reach out to CSIT to add interoperability testing for VPP/libmemif, VPP/memif plugin, GoVPP/libmemif, GoVPP/gomemif, and DPDK/memif PMD
14:41:40 <dwallacelf> #action Ondrej to review/merge PR#116
14:42:01 <dwallacelf> #action Ondrej to review current state of GoVPP CLI linting output
14:42:25 <dwallacelf> #topic Inputs From Projects
14:42:45 <dwallacelf> #info VPP Release 24.02 RC1 happened yesterday
14:51:35 <dwallacelf> #topic Technical Discussion
14:52:29 <dwallacelf> #info Discussion of memory leak bug fixed by PR#184
14:52:34 <dwallacelf> #link https://github.com/FDio/govpp/pull/184
14:56:41 <dwallacelf> #info Vlado is proposing a VPP release to deploy the memory leak fix sooner rather than later
15:00:26 <dwallacelf> #action Ondrej to schedule a point release for downstream consumers to deploy the fix via a release
15:00:46 <dwallacelf> #info Discussion of Memory leak test PR#186
15:00:57 <dwallacelf> #link https://github.com/FDio/govpp/pull/186
15:02:21 <dwallacelf> #action Ondrej to review/merge PR#186 Memory Benchmark test
15:04:05 <dwallacelf> #info Discussion of adding PR#186 to CI
15:05:32 <dwallacelf> #info This test is not applicable to per-patch CI.  It would be best to run before each release.  Does not currently pass when run in CI.
15:09:26 <dwallacelf> #action Vlado to open issue describing proposal to automate execution of PR#186 in the CI
15:17:19 <dwallacelf> #info  Issue#176 closed as completed by Release 0.9.0
15:47:16 <dwallacelf> #endmeeting