14:41:09 <dwallacelf> #startmeeting GoVPP Community Meeting
14:41:09 <collab-meetbot`> Meeting started Thu Jan  9 14:41:09 2025 UTC and is due to finish in 60 minutes.  The chair is dwallacelf. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:41:09 <collab-meetbot`> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:41:09 <collab-meetbot`> The meeting name has been set to 'govpp_community_meeting'
14:42:15 <dwallacelf> #topic Roll Call / Agenda Bashing
14:47:28 <dwallacelf> #action Ondrej to investigate adding memory leak test to CI
14:47:46 <dwallacelf> #action Ondrej to generate a release
14:48:02 <dwallacelf> #action Dave to open a ticket with LF-IT to claim ownership of dockerhub fdio community
14:48:27 <dwallacelf> #action Mohit to relocate ligato/vpp-base to fdio/vpp repo as part of the move of VPP CI to Github Actions
14:50:17 <dwallacelf> #action Dave to notify VPP community of issue with socket client and GoVPP PR#248 (might have been done, will confirm)
14:50:35 <dwallacelf> #topic Inputs From Projects
14:51:15 <dwallacelf> #info VPP Release 25.02 schedule starts with branch pull on Jan 22, follows regular cadence
14:53:09 <dwallacelf> #topic Technical Discussion
14:53:26 <dwallacelf> #info Attendees: Ondrej, Dave, Nathan, Vlado, Mohsin
14:55:18 <dwallacelf> #info Mohsin encountered some performance issues discussed in Issue#254
14:55:36 <dwallacelf> #link https://github.com/FDio/govpp/issues/254
14:58:28 <dwallacelf> #info Discussion of Issue#254
15:06:31 <dwallacelf> #action Ondrej to investigate Issue#254, Mohsin to post C test results and benchmark code
15:06:33 <dwallacelf> #info Vlado pointed out old performance stats on wiki
15:06:34 <dwallacelf> #link https://wiki.fd.io/view/GoVPP/Performance
15:08:47 <dwallacelf> #info Mohsin's vpp benchmark used vat2 which uses shared memory transport, govpp uses socket transport
15:11:09 <dwallacelf> #action Mohsin to update C benchmark test with socket api and report results
15:27:53 <dwallacelf> #info Discussed PR#255, Ondrej to follow up with questions on use case specifics.
15:28:06 <dwallacelf> #endmeeting