14:33:07 <dwallacelf> #startmeeting GoVPP Community Meeting
14:33:07 <collab-meetbot> Meeting started Thu Feb  6 14:33:07 2025 UTC and is due to finish in 60 minutes.  The chair is dwallacelf. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:33:07 <collab-meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:33:07 <collab-meetbot> The meeting name has been set to 'govpp_community_meeting'
14:33:50 <dwallacelf> #chair dwallacelf edwarnicke sknat
14:33:50 <collab-meetbot> Warning: Nick not in channel: dwallacelf
14:33:50 <collab-meetbot> Warning: Nick not in channel: edwarnicke
14:33:50 <collab-meetbot> Warning: Nick not in channel: sknat
14:33:50 <collab-meetbot> Current chairs: dwallacelf edwarnicke sknat
14:49:09 <dwallacelf> #action Nathan to discuss Issue #255 with Mohammed respond with details how to reproduce the issue
14:49:31 <dwallacelf> #topic Inputs From Projects
14:49:58 <dwallacelf> #info VPP Release 25.02 RC1 milestone in progress, no major issues to date
14:50:52 <dwallacelf> #topic Technical Discussion
14:51:43 <dwallacelf> #info No new issues
14:52:29 <dwallacelf> #info Design Improvements discussion
14:53:07 <dwallacelf> #info Optimize writing to socket in the message request (use the request buffer and handle the actual write from the #fdio-meeting
14:53:30 <dwallacelf> #info ^^^ from the API)
14:53:42 <dwallacelf> #info Remove the unnecessary message callback goroutine
14:53:53 <dwallacelf> #inffo Rework the GetMessageID
14:54:05 <dwallacelf> #info Decrease the number of allocated objects (Issue#254 / PR#253)
14:54:25 <dwallacelf> #info Vlado working on the last item in the list
14:55:39 <dwallacelf> #info Ondrej doesn't have the cycles to address the other items in the list currently.
14:56:45 <dwallacelf> #info Ondrej to consult with Mohsin/Vlado to help get the other improvements implemented
14:58:16 <dwallacelf> #info Mohsin has done some benchmarking and has identified some potential API usage patterns to improve the performance
15:12:58 <dwallacelf> #info Discussion of benchmarking methodology
15:13:47 <dwallacelf> #info Mohsin on PTO for the rest of Feb. starting next week.
15:18:22 <dwallacelf> #endmeeting