13:32:21 <dwallacelf> #startmeeting GoVPP Community Meeting
13:32:21 <collab-meetbot> Meeting started Thu Oct 16 13:32:21 2025 UTC and is due to finish in 60 minutes.  The chair is dwallacelf. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:32:21 <collab-meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:32:21 <collab-meetbot> The meeting name has been set to 'govpp_community_meeting'
13:58:52 <dwallacelf> #info Attendees:  Dave, Mohsin, Vlado
13:59:02 <dwallacelf> #topic Action Items
13:59:33 <dwallacelf> #action Ondrej to investigate adding memory leak test to CI
13:59:47 <dwallacelf> #action Ondrej to investigate migrating up GitHub notifications to zulip chat which is replacing slack by LF
13:59:59 <dwallacelf> #action Dave to relocate ligato/vpp-base to fdio/vpp repo after move of VPP CI to Github Actions
14:00:43 <dwallacelf> #action Ondrej to generate next GoVPP release now that Calico 3.30 is complete
14:00:56 <dwallacelf> #action Mohsin to review/fix gomemif Issues #296, #280
14:02:28 <dwallacelf> #info Requests to add FD.io project specific channels to zulip have been denied at the current time by Casey Cain (LFN PM).  Casey is advocating that communities use topics in zulip in place of slack channels.
14:02:51 <dwallacelf> #topic Inputs From Projects
14:12:41 <dwallacelf> #info VPP 25.10 RC2 happened yesterday.  Release to be completed on Wed Oct 29, 2026
14:13:49 <dwallacelf> #topic Technical Discussion
14:14:05 <dwallacelf> #Info Vlado/Ondrej to review new PRs
14:17:37 <dwallacelf> #info Discussion of Design Improvements list
14:17:42 <dwallacelf> #info Mohsin reported that the perf issue of configuring a large fib table (~ 2 million entries) was addressed by using async api calls for fib download, pre-allocating table memory in VPP via startup.conf configuration, and some other refactoring of the control plane app.
14:18:41 <dwallacelf> #info the remaining optimizations in the list should improve things as well, but are not critical at this point.
14:18:53 <dwallacelf> #endmeeting