#fdio-vpp: VPP Weekly

Meeting started by edwarnicke at 16:03:24 UTC (full logs).

Meeting summary

  1. Agenda Bashing (edwarnicke, 16:05:52)
    1. https://wiki.fd.io/view/VPP/Meeting#Agenda (edwarnicke, 16:05:59)

  2. Getting Involved (alagalah, 16:10:19)
    1. edwarnicke Sharing "Getting involved" page (alagalah, 16:10:48)
    2. https://wiki.fd.io/view/Main_Page#Get_Involved Getting Involved (alagalah, 16:11:06)
    3. edwarnicke implores folks to proliferate channels but please document them. (alagalah, 16:11:58)
    4. alagalah preference is keep convention of #fdio- be kept for official projects, and ##fdio- for anything else but... its just a convention (alagalah, 16:12:52)
    5. mailman hasn't been behaving and we have reverted from mailman3 to mailman2 (alagalah, 16:13:16)
    6. https://lists.cloudfoundry.org/archives/ CF mailer lists (alagalah, 16:13:56)
    7. https://lists.cloudfoundry.org/archives/list/cf-dev@lists.cloudfoundry.org/ (alagalah, 16:14:11)
    8. edwarnicke notes that this looks like mailman3 which isn't working for fd.io (alagalah, 16:14:33)
    9. searchability is good. (tfherbert, 16:14:42)
    10. https://wiki.fd.io/view/Project_Proposals Project Proposal (alagalah, 16:15:11)

  3. Consumability (alagalah, 16:16:43)
    1. Upstreaming .. we have afredette tfherbert from RedHat who maybe able to give us insight on upstreaming ... and potentially if folks on from Canonical could make themselves known ... (alagalah, 16:17:25)
    2. tfherbert afredette Committed to making VPP work with CentOS et al but not 100% on the process (alagalah, 16:19:41)
    3. ACTION: afredette (RedHat) to find out process/checklist for upstreaming RPM package. Next week. Email pointers to RTM good enough (alagalah, 16:20:35)
    4. call for volunteers to getting rpms building as part of verify/merge (edwarnicke, 16:25:08)
    5. call for volunteers to get rpms pushed to yum repos are part of merge (edwarnicke, 16:25:22)
    6. call for volunteers to get deb packages working well on Ubuntu 15.10 (upstart -> systemd, uio_igb -> uio-pci-generic (edwarnicke, 16:26:23)
    7. dmarion CLANG works (alagalah, 16:28:05)
    8. DaveBarach describes gcc 5.2 issues (edwarnicke, 16:28:05)
    9. we need docs for "vpp developers" "vpp api users (like control plane)" "vpp deployers (people who just want to install and run it)" (edwarnicke, 16:37:48)
    10. probably both a control plane and a data plane section at hackathon? (tfherbert, 16:38:56)
    11. https://gerrit.fd.io/r/#/c/327/ - tcp/udp checksum disabling patch mentioned (edwarnicke, 16:46:49)
    12. https://github.com/01org/hyperscan (KeithWiles, 16:48:04)
    13. joelhalpern points out we would be doing he world a service by talking about SFC SFF and SF correctly as we look at NSH (edwarnicke, 16:53:34)
    14. joelhalpern and edwarnicke spend some time agreeing emphatically about other subtleties ;) (edwarnicke, 16:53:54)
    15. https://www.openhub.net/p/fdio -> commit velocity documentation (edwarnicke, 16:54:23)
    16. Very interested in the NETLINK project (alagalah, 16:55:25)
    17. : I agree on packaging first+1 (tfherbert, 16:58:16)
    18. https://wiki.fd.io/view/Mature_Release_Process <- link to mature release processes (edwarnicke, 16:59:25)
    19. alagalah asks about how we number versions (edwarnicke, 17:02:49)
    20. alagalah suggests sematic versioning (edwarnicke, 17:03:20)
    21. https://datasift.github.io/gitflow/Versioning.html <- semantic versioning explained (edwarnicke, 17:04:41)
    22. other suggestions involved YY.MM versioning (edwarnicke, 17:04:56)
    23. edwarnicke No, I wasn't advocating it. I twas seeing Relase 1.0.0 on the Mature Relase Process and had questions (alagalah, 17:05:53)


Meeting ended at 17:08:26 UTC (full logs).

Action items

  1. afredette (RedHat) to find out process/checklist for upstreaming RPM package. Next week. Email pointers to RTM good enough


Action items, by person

  1. afredette
    1. afredette (RedHat) to find out process/checklist for upstreaming RPM package. Next week. Email pointers to RTM good enough


People present (lines said)

  1. alagalah (44)
  2. edwarnicke (42)
  3. collabot` (12)
  4. KeithWiles (9)
  5. tfherbert (8)
  6. ashyoung (6)
  7. mdgray (4)
  8. cdl (2)
  9. joelhalpern (1)
  10. afredette (1)
  11. DaveBarach (1)
  12. cj (0)


Generated by MeetBot 0.1.4.