16:00:37 <edwarnicke> #startmeeting vpp Weekly Meeting
16:00:37 <collabot`> Meeting started Tue Feb 23 16:00:37 2016 UTC.  The chair is edwarnicke. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:37 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:00:37 <collabot`> The meeting name has been set to 'vpp_weekly_meeting'
16:02:54 <edwarnicke> #topic Agenda
16:02:59 <edwarnicke> #link https://wiki.fd.io/view/VPP/Meeting#Agenda <- Agenda link
16:03:39 <edwarnicke> #chair afredette DaveBarach KeithWiles
16:03:39 <collabot`> Current chairs: DaveBarach KeithWiles afredette edwarnicke
16:03:52 <edwarnicke> #chair dmarion
16:03:52 <collabot`> Current chairs: DaveBarach KeithWiles afredette dmarion edwarnicke
16:04:07 <edwarnicke> #chair mackonstan1
16:04:07 <collabot`> Current chairs: DaveBarach KeithWiles afredette dmarion edwarnicke mackonstan1
16:04:15 <edwarnicke> #chair ashyoung_
16:04:15 <collabot`> Current chairs: DaveBarach KeithWiles afredette ashyoung_ dmarion edwarnicke mackonstan1
16:06:09 <edwarnicke> #topic Automated Functional / Performance Test update
16:06:18 <edwarnicke> #info mackonstan1 introduces himself
16:08:05 <edwarnicke> #info Functional Regression test overview
16:10:11 <edwarnicke> #info By end of this week, every vpp merge will run a regression
16:10:18 <edwarnicke> #info Will also plug into verify
16:12:37 <edwarnicke> #link https://jenkins.fd.io/view/csit/job/csit-vpp-functional-virl/ <- CSIT tests
16:13:47 <edwarnicke> #link test suites: https://jenkins.fd.io/view/csit/job/csit-vpp-functional-virl/68/robot/
16:14:01 <edwarnicke> #info Performance Test overview
16:16:58 <edwarnicke> #link https://gerrit.fd.io/r/gitweb?p=csit.git;a=summary <- CSIT repo
16:18:20 <edwarnicke> #info question about dpdk integration
16:18:38 <edwarnicke> #info DaveBarach suggested just push a patch pointing to a different DPDK tarball, and the verify job should check it
16:20:56 <edwarnicke> #link  https://lists.fd.io/mailman/listinfo/csit-dev <- csit mailer
16:21:10 <edwarnicke> #topic Open Items for Review
16:21:26 <edwarnicke> #info any progress on process for upstreaming an rpm
16:21:45 <edwarnicke> #info afredette has talked to dfarrel07 from RH and he has expressed interest there
16:22:36 <edwarnicke> Will retain the Open Item for next week
16:22:46 <edwarnicke> #info process for upstreaming Ubuntu debian packaging
16:25:16 <edwarnicke> #info request for volunteers for netlink project
16:26:21 <mackonstan1> #link https://nexus.fd.io/#nexus-search;quick~vpp <- nexus.fd.io with vpp deb pkgs - currently csit functional regression executed against build 1.0.0-185~gca0f3b3
16:26:50 <edwarnicke> #info request for states in jira: INFO, JUNK, CLOSED, etc
16:27:08 <edwarnicke> #action DaveBarach to email list about Jira states
16:28:00 <mackonstan1> #link https://jenkins.fd.io/view/vpp/job/vpp-merge/174/console <- first priority for csit job triggers are vpp-merge jobs, here is the latest
16:28:15 <edwarnicke> #link https://confluence.atlassian.com/adminjiraserver070/defining-status-field-values-749382903.html <- Bug Status can be done
16:28:43 <edwarnicke> #topic Staticly linking vpp executable against network stack
16:28:51 <mackonstan1> #link https://jenkins.fd.io/view/vpp/job/vpp-verify/ <- we are then looking to plug into vpp-verify jobs
16:29:01 <edwarnicke> mackonstan1:  :)
16:30:16 <mackonstan1> #link https://jenkins.fd.io/view/csit/job/csit-vpp-functional-virl/ <- here latest csit functiona tests executed on LF hosted VIRL 3-node topology
16:30:52 <edwarnicke> #info static linking of network stack under consideration, would have to be tested heavily to make that switch
16:31:13 <edwarnicke> DaveBarach: Asks about dpdk .so instead of .a
16:31:18 <mackonstan1> #info execution time of csit-vpp-functional-virl tests - currently < 3.5min
16:31:21 <edwarnicke> keith_wiles: Indicates it can be done
16:31:27 <edwarnicke> mackonstan1: Woot!
16:32:44 <edwarnicke> tfherbert: Mentions DPDK is packaged as an .so upstream
16:33:35 <jmcnamara> In config/common_linuxapp:   CONFIG_RTE_BUILD_SHARED_LIB=n CONFIG_RTE_BUILD_COMBINE_LIBS=n
16:33:47 <jmcnamara> Set those to y
16:33:56 <edwarnicke> jmcnamara: Thanks for the pointer :)
16:37:29 <mackonstan1> edwarnicke: Thanks for Woot! - but it's csit committers work :)
16:39:06 <edwarnicke> #topic Code Base Activity report
16:42:13 <edwarnicke> #info Patch Cisco VIC (enic) PMD TX path
16:42:23 <edwarnicke> #info Add MTU info to binary API (sw_interface_dump)
16:42:32 <edwarnicke> #info Fix vpp handling of DPDK-2.2.0 buffer metadata bits [ip6 pkts ending up in ip4 path]
16:42:44 <edwarnicke> #info Per-interface, per address-family fast packet whitelist / blacklist
16:42:55 <edwarnicke> #info Jumbo frame support for non-dpdk (vhost) interfaces
16:43:05 <edwarnicke> #info Show dpdk EAL arguments in "show version verbose"
16:43:12 <edwarnicke> #topic Consumability
16:43:30 <edwarnicke> #info DPDK tarball download failures
16:43:40 <edwarnicke> #info tfherbert is seeing it too
16:45:13 <edwarnicke> #info suggestion to put dpdk tarball in git repo
16:45:32 <edwarnicke> #action edwarnicke to see about mirroring dpdk tarball to fd.io nexus server
16:46:31 <edwarnicke> #info suggestion made to clone dpdk and set tag to desired release
16:46:47 <edwarnicke> #info DaveBarach suggested possibly retry logic for downloading dpdk tarball
16:47:49 <edwarnicke> #action jmcnamara will look into DPDK download sit
16:47:51 <edwarnicke> site
16:47:55 <edwarnicke> #undo
16:47:55 <collabot`> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x2e0f990>
16:48:02 <edwarnicke> #action jmcnamara will look into DPDK download site
16:48:22 <keith_wiles> what is wrong with clone and set tag method, you can even clone it to a local place too
16:49:39 <edwarnicke> keith_wiles: I *think* it was suggested it would involve downloading a lot more stuff, and thus be slower
16:49:50 <ashyoung_> edwarnicke: why not just use a link to dpdk tarball version?
16:50:11 <keith_wiles> Only the first time right, then just simple update the power of Git
16:50:15 <edwarnicke> ashyoung_: That's what we are doing, just curl-ing down the tarball... and folks are reporting failures
16:50:20 <tfherbert> This dpdk tarball downloading is an issue for upstream I think, not vpp.
16:50:29 <ashyoung_> edwarnicke: oh
16:50:37 <ashyoung_> edwarnicke: try wget ;)
16:50:39 <edwarnicke> keith_wiles: Verify and merge builds are done clean... so it gets hit with every build in the CI ;)
16:50:50 <edwarnicke> ashyoung_: LOL
16:51:09 <ashyoung_> edwarnicke: I can do that sophisticated patch
16:51:20 <keith_wiles> ok
16:52:07 <edwarnicke> ashyoung_: I suspect curl is not the issue... I suspect that its an issue with the DPDK servers
16:52:36 <ashyoung_> edwarnicke: If you do opt to mirror, I have some code I wrote for managing the diffs between origin and mirror
16:52:44 <tfherbert> edwarnicke: include note here as to a summary of what netlink project is.
16:53:38 <edwarnicke> #info idea of netlink agent project is to provide a netlink agent so that existing user space tools via a LDPRELOAD hack can talk to vpp
16:53:59 <ashyoung_> edwarnicke: I did the mirror thing too, onosfw till the cops came over licensing issues. I switched to the wget method as a result
16:54:01 <tfherbert> edwarnicke: Thanks:^)
16:54:21 <edwarnicke> #endmeeting