14:59:52 <edwarnicke> #startmeeting VPP Weekly Call
14:59:52 <collabot`> Meeting started Tue Mar 15 14:59:52 2016 UTC.  The chair is edwarnicke. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:59:52 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:59:52 <collabot`> The meeting name has been set to 'vpp_weekly_call'
15:00:17 <edwarnicke> #link https://wiki.fd.io/view/VPP/Meeting#Agenda <- Agenda
15:03:23 <edwarnicke> #chair DaveBarach keith_wiles cj
15:03:23 <collabot`> Current chairs: DaveBarach cj edwarnicke keith_wiles
15:03:44 <edwarnicke> #chair dmarion skobza
15:03:44 <collabot`> Current chairs: DaveBarach cj dmarion edwarnicke keith_wiles skobza
15:04:59 <edwarnicke> #topic CSIT testing
15:05:33 <edwarnicke> #info skobza reports on CSIT state
15:05:59 <edwarnicke> We have two different labs within FD.io infra
15:06:19 <edwarnicke> First VIRL: installed on a machine, has some configuration, can stand up topologies with interconnections
15:06:29 <edwarnicke> VIRL testbed can execute against this topology
15:06:42 <edwarnicke> described in topology.yaml, passed to python robot framework binary
15:06:58 <edwarnicke> Second type: Performance lab - hardware used for performance tests
15:07:06 <edwarnicke> Functional tests -> VIRL Testbed
15:07:29 <edwarnicke> Performance testing -> Performance Testbed
15:08:21 <edwarnicke> Tests currently not running patch by patch (vpp verify job), but that is the goal.
15:08:29 <edwarnicke> Also want it triggered by merge job
15:08:47 <edwarnicke> DaveBarach: Asks if testing can be run on a particular patch on demand
15:09:20 <edwarnicke> skobza: Indicates that once we have job that is triggered by vpp verify/merge job, you will get that info
15:09:33 <edwarnicke> skobza: Working around issues in infra to get that working
15:10:38 <edwarnicke> DaveBarach: Asks when we might get things hooked up
15:10:41 <edwarnicke> skobza: points to cj
15:11:01 <edwarnicke> cj: mentions tykeal is talking to underlying infrastructure folks
15:11:06 <edwarnicke> cj: Will follow up directly
15:11:32 <edwarnicke> DaveBarach: Mentions that we have patches that desperately need this testing
15:11:57 <edwarnicke> #chair
15:11:57 <collabot`> Current chairs: DaveBarach cj dmarion edwarnicke keith_wiles skobza
15:12:35 <edwarnicke> mackonstan: Mentions these issues have been outstanding for a long time, asks for better visibility of issues as to when triggering will happen and why it isn't happening
15:12:53 <edwarnicke> mackonstan: Mentions we have the code, it just can't be used because of issues in infra
15:12:57 <edwarnicke> #chair alagalah
15:12:57 <collabot`> Current chairs: DaveBarach alagalah cj dmarion edwarnicke keith_wiles skobza
15:13:04 <alagalah> #info I'm present but not going to join audio
15:14:55 <cj> setting up daily updates for zuul trigger problems
15:15:30 <edwarnicke> #link https://wiki.fd.io/view/Project_Proposals/CSIT
15:15:35 <edwarnicke> Project proposal
15:15:44 <edwarnicke> CSIT == Continuous System Integration Testing
15:16:42 <edwarnicke> #link https://wiki.fd.io/view/TSC#2016-03-17 <- Scheduled for TSC Creation Review Thursday Mar 17, 2016
15:18:04 <alagalah> edwarnicke: :) I was about to ask ... any objections if I modify the proposal template to include a proposal date and a link to tsc email ?
15:18:30 <edwarnicke> alagalah: Absolutely none :)
15:18:51 <keith_wiles> None from me
15:19:03 <edwarnicke> alagalah: I appreciate you asking
15:19:16 <skobza> #info [csit] Test suites currently present for functional tests:  bridge domain, l2 xconnect, V4, V6, VXLAN with BD, VXLAN with L2 xconnect. All tests only Eth, no dot1.q
15:19:54 <skobza> #info [csit] Test suites currently present for performance tests: short_bridge_domain, short_ipv4, short_xconnect and proposed long_bridge_domain (https://gerrit.fd.io/r/#/c/515/)
15:24:33 <keith_wiles> yes it does
15:27:32 <edwarnicke> #action cj to file Debian ITP (Intent to Package) as first step to getting into Debian
15:27:44 <cj> todo: file ITP with debian
15:28:11 <edwarnicke> #link https://wiki.fd.io/view/TSC#Future_Agenda_Items <- Future Agenda Items of the TSC
15:32:29 <edwarnicke> #topic dpdk changes
15:32:47 <edwarnicke> #info dpdk in release candidate stage, so only things that went in after that are going in
15:33:11 <edwarnicke> #info headroom changes will not make it into 16.04, might make it into the next release
15:34:38 <edwarnicke> #topic things being worked on
15:34:48 <edwarnicke> #info sharing adjacencies in fib
15:36:27 <keith_wiles> #info For DPDK changes the normal method is to submit a patch for that change and allow the group to discuss, then ACK or NAK the patch.
15:38:41 <edwarnicke> #topic consumability
15:38:52 <keith_wiles> #info changing the HEADROOM size is most likely a ABI change, which takes two releases to get into the code base. The first release is a ABI change notice then it can be added to the next release. If you get the notice in 16.04 then 16.07 could be the next release with the change. Not sure if we have missed the deadline for ABI changes in 16.04.
15:46:48 <cj> todo: depend on install-deps target for build targets
15:47:24 <cj> todo: implement cross-platform install-deps target
15:48:21 <keith_wiles> Do we want to support FreeBSD as DPDK does already?
15:51:18 <edwarnicke> #link http://sched.co/6RFF <- fd.io meetup at ONS
15:54:45 <edwarnicke> #endmeeting