14:59:12 <edwarnicke> #startmeeting VPP weekly meeting
14:59:12 <collabot`> Meeting started Tue Mar 29 14:59:12 2016 UTC.  The chair is edwarnicke. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:59:12 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:59:12 <collabot`> The meeting name has been set to 'vpp_weekly_meeting'
14:59:36 <edwarnicke> #chair skobza mspanik cj dmarion
14:59:36 <collabot`> Current chairs: cj dmarion edwarnicke mspanik skobza
15:02:42 <edwarnicke> #topic Agenda Bashing
15:02:46 <edwarnicke> #link https://wiki.fd.io/view/VPP/Meeting#Agenda <- Agenda
15:03:07 <edwarnicke> #topic Cancel call next week due to training/hackfest
15:03:29 <edwarnicke> #info DaveBarach suggests cancelling next weeks vpp meeting
15:03:37 <edwarnicke> #agreed next weeks vpp meeting is cancelled
15:03:56 <edwarnicke> #topic Reports from other projects
15:04:24 <cj> #info present
15:04:48 <edwarnicke> #topic CSIT
15:05:42 <edwarnicke> #chair mackonstan
15:05:42 <collabot`> Current chairs: cj dmarion edwarnicke mackonstan mspanik skobza
15:08:32 <edwarnicke> #link https://lists.fd.io/pipermail/csit-dev/2016-March/000070.html <- PTL elections from CSIT
15:08:43 <edwarnicke> Congratulations mackonstan on being elected PTL of CSIT
15:08:56 <edwarnicke> #link https://wiki.fd.io/view/CSIT <- CSIT page
15:09:12 <edwarnicke> #info if a vpp change has comment 'manualrun' on it it will run the CSIT tests agains the patch
15:10:25 <edwarnicke> #info dmarion reports having run successfully, but reporting of success was broken.  skobza reports having provided a fix patch for that
15:11:09 <edwarnicke> #link https://gerrit.fd.io/r/#/c/633/ <- fix patch
15:12:07 <edwarnicke> #info plan of record is to have CSIT testing as part of the verify path for next Tuesday
15:12:44 <edwarnicke> #info manualrun is to make sure that testing is working correctly before we turn it on for verify job
15:18:27 <edwarnicke> #topic Release Planning 16.06
15:18:43 <edwarnicke> #link https://wiki.fd.io/view/Projects/vpp/Release_Plans/Release_Plan_16.06 <- Proposed vpp release plan
15:19:51 <edwarnicke> #info CSIT asks about priorities for testing for 16.06 vpp release
15:20:10 <edwarnicke> #link https://lists.fd.io/mailman/listinfo/csit-dev <- CSIT mailer
15:20:34 <edwarnicke> #action DaveBarach to send feedback to CSIT team
15:21:05 <edwarnicke> #topic Packaging
15:21:38 <edwarnicke> #action cj to report week after next on state of packaging
15:22:04 <edwarnicke> #action cj to file ITP (Intent to Package) with Debian to get debian packages upstream
15:22:46 <edwarnicke> #info We have a local apt repo updated with new packages on every merge
15:22:52 <edwarnicke> #action edwarnicke to document local apt repo
15:29:30 <alagalah> #link https://www.ciscolive.com/online/connect/sessionDetail.ww?SESSION_ID=83652&tclass=popup Great talk on IOAM6 Dave mentioned as a patch
15:49:38 <edwarnicke> #link https://wiki.fd.io/view/VPP/Installing_VPP_binaries_from_packages <- installing vpp from binary packages
15:50:47 <florinc> thanks edwarnicke!
15:50:58 <edwarnicke> florinc: thanks for finally making me document it :)
15:51:30 <florinc> my pleasure! :D
15:52:29 <Chrisy> next we'll be encouraging you sign your Release file :)
15:53:13 <edwarnicke> LOL
15:53:26 <edwarnicke> Chrisy: baby steps
19:10:58 <cj> http://events.linuxfoundation.org/events/collaboration-summit/program/live-video-stream
14:49:12 <gsagie_> Hello all, watched edwarnicke presentation about VPP in ONOS and i am wondering about the performance results, i currently see that Intel FM10840 has 600GB from ports and has PCIe channels to the CPU socket max at 200GB
14:49:36 <gsagie_> so if i have one socket of 18 cores basically this means i can only process 200GB max right?
14:49:49 <edwarnicke> gsagie_: Meet mackonstan who is our resident benchmark expert ;)
14:50:03 <gsagie_> mackonstan: hi :) just in time..
14:50:06 <gsagie_> my question:
14:50:09 <edwarnicke> mackonstan: Meet gsagie_ who has some questions about fd.io benchmarks :)
14:50:10 <gsagie_> Hello all, watched edwarnicke presentation about VPP in ONOS and i am wondering about the performance results, i currently see that Intel FM10840 has 600GB from ports and has PCIe channels to the CPU socket max at 200GB
14:51:44 <gsagie_> so if i have one socket of 18 cores basically this means i can only process 200GB max right? but still offload to the switch 400GB that get switched
14:52:13 <gsagie_> wondering what was the exact setup that you showed ~400-500GB processing
14:53:26 <gsagie_> btw, great presentation edwarnicke :)
14:53:57 <edwarnicke> gsagie_: I don't believe there was any offload for the numbers I quoted in my talk
14:54:48 <gsagie_> edwarnicke: yeah understood, just trying to figure out if my assumption is correct and what is the exact details, for example can i connect 300GB processing to the CPU and leave only 300GB ports
14:56:06 <gsagie_> edwarnicke: any link to the slides by any chance?
14:56:30 <edwarnicke> gsagie_: Slides are open sourced here: https://wiki.fd.io/view/Presentations
14:56:31 <gsagie_> nvm found :)
14:56:38 <gsagie_> thanks
14:59:06 <edwarnicke> gsagie_: I'm glad you found it easy to find ;)
14:59:33 <gsagie_> just wondering if when you write "24 cores were used" i guess it means you used 12 at each socket  and used 2 sockets or maybe 6 at each socket and used 4 sockets
15:00:05 <gsagie_> as reaching ~500GB seems to need at least 3 sockets and 3 Intel NICs
15:02:28 <mackonstan> gsagie_: The benchmark tests reported in these slides were done with NIC rss (receive side scaling) set to 2. Meaning that packets received in each NIC port were load-balanced into two VPP threads.
15:03:04 <mackonstan> gasgie): so for 12x 40GE ports, that's 24 VPP worker threads.
15:03:21 <gsagie_> mackonstan: so two threads per core
15:03:40 <mackonstan> gsagie_: two VPP worker threads per NIC port.
15:04:19 <mackonstan> gsagie_: and tests were done without using hyperthreading, so each VPP worker thread had a physical core to itself.
15:04:38 <mackonstan> gsagie_: and in the numbers you quoted, you should s/500GB/500Gbps/ :)
15:04:54 <gsagie_> mackonstan:  but the 12x 40GE ports are how many Intel NICs?
15:05:25 <gsagie_> and the 24 cores, how much sockets they span
15:06:32 <gsagie_> basically you could use 18 cores from one socket but what i am trying to say that the results don't make sense for that as you won't be able to process more then 200Gbps
15:06:53 <gsagie_> so i assume you used 3-4 sockets and span the cores between them
15:07:10 <gsagie_> is that right?
15:08:05 <mackonstan> gsagie_: tests done with Fortville NICs, 2p40GE
15:08:30 <gsagie_> ok, so 6 NICs
15:08:33 <mackonstan> gsagie_: yes, all four sockets were used
15:11:20 <gsagie_> mackonstan: ok thanks that make sense, do you know iif my understanding that FM10840 (if you happen to know this NIC) can connect
15:11:23 <gsagie_> ohhh
15:11:25 <gsagie_> he left :(
15:13:36 <gsagie_> dmarion: here?
16:24:01 <gsagie_> Anyone can tell me the maximum number of PCI lanes i can connect to E7-8890 v3 ? from what it seems i can only connect 200Gs to it (4x50GBs 8 lane PCIe)
16:24:04 <gsagie_> is this correct?
16:25:27 <gsagie_> but FM10840 seems to have maximum of 600GBs incoming traffic so i am wondering whats the use case if i can only connect it to 200GBs of CPU processing, are the other 400GB to be offloaded to the switch/TCAM?
10:43:08 <kll> I'm reading this page https://wiki.fd.io/view/VPP/Introduction_To_N-tuple_Classifiers and I don't get this sentence "Searching 357 tables on a regular basis will neatly solve the halting problem", can someone explain?
10:43:34 <kll> is this a formatting error from being copied from something else? what is 357? 3-5-7 ?
21:00:06 <Chrisy> As promised: Hello!
21:00:19 <edwarnicke> Chrisy: Good to hear from you, who else is on?
14:47:19 <edwarnicke> VPP meeting at the top of the hour: https://wiki.fd.io/view/VPP/Meeting#Meeting_Details
14:55:45 <cj> here or in -meeting?
14:56:47 <edwarnicke> cj: Both :)
14:58:38 <edwarnicke> Due to techincal difficulties, please refer to the new webex at: https://wiki.fd.io/view/VPP/Meeting#Meeting_Details
14:59:47 <collabot> edwarnicke: Error: Can't start another meeting, one is in progress.  Use #endmeeting first.
14:59:55 <edwarnicke> #endmeeting