15:03:31 <alagalah> #startmeeting VPP 4/26
15:03:31 <collabot`> Meeting started Tue Apr 26 15:03:31 2016 UTC.  The chair is alagalah. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:03:31 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:03:31 <collabot`> The meeting name has been set to 'vpp_4_26'
15:03:38 <alagalah> #topic Sign in :D
15:03:40 <Chrisy> #info Chris Luke
15:03:41 <keith_wiles> #info Keith Wiles
15:03:48 <MarkusMagnusson> #info Markus Magnusson
15:03:50 <DaveBarach> #info Dave Barach
15:03:55 <alagalah> #info alagalah (Keith Burns)
15:04:32 <alagalah> #link https://wiki.fd.io/view/VPP/Meeting#Agenda Agenda
15:04:52 <alagalah> #chair florinc
15:04:52 <collabot`> Current chairs: alagalah florinc
15:04:57 <alagalah> #chair dbarach
15:04:57 <collabot`> Warning: Nick not in channel: dbarach
15:04:57 <collabot`> Current chairs: alagalah dbarach florinc
15:05:07 <alagalah> #chair ppfister
15:05:07 <collabot`> Current chairs: alagalah dbarach florinc ppfister
15:05:33 <tmonjalo> What about the next hands-on meeting?
15:05:47 <alagalah> #topic CSIT - dpdk-16.04 success story (
15:06:13 <alagalah> #info DaveBarach made change for migrating from DPDK 2.02 to 16.04
15:06:17 <alagalah> #chair DaveBarach
15:06:17 <collabot`> Current chairs: DaveBarach alagalah dbarach florinc ppfister
15:07:02 <alagalah> #info mackonstan1 Discusses publishing CSIT code release ( ???)
15:07:41 <alagalah> #info mackonstan1 Clarifies above, discussion within project to create a CSIT Release Plan
15:07:57 <alagalah> #info mackonstan1 will discuss at CSIT Project meeting tomorrow
15:08:58 <alagalah> #link https://jira.fd.io/secure/RapidBoard.jspa?rapidView=1 CSIT KanBan in JIRA
15:10:00 <mackonstan1> #link https://wiki.fd.io/view/CSIT/FuncTestPlan CSIT VPP functional test cases
15:10:03 <alagalah> #info Honeycomb readout from marek_
15:10:28 <alagalah> #info gerrit patches in there JNI
15:11:02 <alagalah> #action alagalah and Dwallace will review hc related vpp patches this morning
15:12:43 <alagalah> #info NSH_SFC readout. Pulling NSH specific things out of VPP and into NSH_SFC this week. Simplistic design below
15:12:53 <alagalah> #link https://wiki.fd.io/view/NSH_SFC/Docs/Designs NSH into NSH_SFC
15:14:02 <alagalah> #topic TWS meeting next week
15:14:09 <alagalah> #link https://lists.fd.io/pipermail/discuss/2016-April/000061.html Documentation is next week
15:15:13 <alagalah> #info email coming from alagalah to discuss/tsc to get some ideas going pre-TWS next week
15:16:06 <alagalah> #topic Using JIRA
15:16:15 <alagalah> #info how do we track what folks are working on.
15:18:38 <florinc> #info Dave and Chris discuss how to tackle CLI patches
15:19:13 <florinc> #topic VPP release 16.06 planning
15:19:31 <Chrisy> rats, i was about to clarify the gerrit topic merge feature
15:19:55 <florinc> #info CJ and Ed working on building repo for Ubuntu
15:20:26 <florinc> #info repository should be available sometime later this week
15:21:23 <florinc> cj: could you action yourself? :)
15:23:15 <tmonjalo> when/where will be the next hands-on, please?
15:24:10 <florinc> #info Damjan thinks RIB updates are too risky before the release
15:24:38 <florinc> #info switched to DPDK 16.04 as of this morning
15:25:19 <florinc> #info CLI improvements will probably get in before freeze
15:25:35 <alagalah> I'm back
15:25:53 <alagalah> #topic upcoming changes
15:26:17 <alagalah> #info florinc discusses pushing his LISP ONE changes by end of week (pursuant with F0)
15:26:50 <alagalah> #info dave barach comments that folks are getting patchsets in
15:26:51 <Chrisy> #info Chris would like everyone to exercise the CLI once merged. There is plenty of opportuinty for off-by-one issues.
15:27:10 <alagalah> Chrisy: Thanks mate :) more hands more good
15:27:43 <alagalah> #info alagalah and DaveWallace to review Honeycomb
15:28:14 <alagalah> #info John Lo has reviewed Gerrit 873 by Chrisy
15:29:06 <alagalah> #link https://gerrit.fd.io/r/#/c/873/ John reviewing after meeting for his +1
15:33:38 <alagalah> #info alagalah has a generalised zero memcpy packet replicator as part of his ip6 SR multicast spray case
15:37:08 <alagalah> #action alagalah to make a table of committers on vpp wiki with their self-identified areas of review-expertise. Committers please update
15:41:30 <alagalah> #link https://jira.fd.io/browse/HONEYCOMB-25 JIRA VPP ticket for Java7 has a HC JIRA related:
15:41:58 <alagalah> #info Java7 is a blocker for the HC project so they are motivated to address this
15:51:09 <alagalah> #topic code base activity
15:51:45 <alagalah> #info as per agenda https://wiki.fd.io/view/VPP/Meeting#Agenda no major issues with these.
15:51:59 <alagalah> #info JLo talked about a code-fix for BVI not on the list that was kind of nice
15:52:29 <alagalah> #link https://gerrit.fd.io/r/#/c/851/ Cool BVI change merged
15:58:49 <alagalah> #endmeeting