#fdio-vpp: fdio vpp

Meeting started by DaveBarach at 14:55:55 UTC (full logs).

Meeting summary

    1. maciek giving CSIT status (DaveBarach, 15:03:22)
    2. 82599 patch fixed gross perf hit (no packet classification) (DaveBarach, 15:03:49)
    3. 2.5% slower w/ dpdk-16.07 vs dpdk-16.04, csit guys investigating (DaveBarach, 15:04:09)
    4. Florin looking into lisp fail on cdp coding standards cleanup (DaveBarach, 15:05:55)
    5. maciek away for 2.5 weeks (PTO), Dave Wallace and Miro Miklus will act as CSIT PTL (DaveBarach, 15:07:02)
    6. dwallacelf on PTO 8/23 - 8/30 (dwallacelf, 15:07:34)
    7. Marek reporting on Honeycomb (DaveBarach, 15:07:44)
    8. Honeycomb to intro support for ACL, L2, L3 (DaveBarach, 15:08:14)
    9. Keith reports on NSH / SFC. (DaveBarach, 15:09:13)
    10. Intel folks needing some Honeycomb changes to be pushed (DaveBarach, 15:10:40)
    11. Honeycomb commit in progress to use NSH jar-file (DaveBarach, 15:11:51)
    12. ACTION: Marek to write description how to test (DaveBarach, 15:12:18)
    13. Florin reporing on one/LISP (DaveBarach, 15:12:44)
    14. working through Jira list - multihoming patch expected soon (DaveBarach, 15:13:03)
    15. control-plane impl for source/dest (DaveBarach, 15:13:14)
    16. code hardening (DaveBarach, 15:13:17)
    17. Pierre reporting on sandbox (DaveBarach, 15:13:45)
    18. new committers (DaveBarach, 15:13:50)
    19. Keith pushed demo framework to sandbox (DaveBarach, 15:14:00)
    20. new project(s) on tap interfaces expected soon (DaveBarach, 15:14:22)
    21. TDLK and DPDK packaging ed catching up after PTO (DaveBarach, 15:14:51)
    22. Time for the Keith Burns show... (:-)... (DaveBarach, 15:15:25)
    23. TWS cancelled for today (DaveBarach, 15:16:20)
    24. hoping to hear from small-form-factor dpdk conference demo guys e.g. next time (DaveBarach, 15:16:41)
    25. calico integration underway. Matt Johnson working on multi-host ipv6 support (DaveBarach, 15:17:11)
    26. calico/vpp demo at Linux Conference in Toronto in two weeks (DaveBarach, 15:17:28)
    27. Contiv integration complete; Nikos B. had surgery to deal with appendicitis (DaveBarach, 15:18:14)
    28. vpp 16.09 release planning (DaveBarach, 15:20:05)
    29. Ed documented release process "paint by numbers" (DaveBarach, 15:20:27)
    30. which bits can we test beforehand? (DaveBarach, 15:20:38)
    31. dry-runing release repo creation is problematic (DaveBarach, 15:22:06)
    32. create / delete / recreate on nexus repos is almost certain to cause issues (DaveBarach, 15:22:32)
    33. "so don't do that..." (DaveBarach, 15:22:37)
    34. 18 to-do items on the Kanban board, 16 in progress (DaveBarach, 15:24:00)
    35. doxygen and coding style cleanups in progress, as agreed (DaveBarach, 15:24:33)
    36. please jump in and help! (DaveBarach, 15:25:15)
    37. https://gerrit.fd.io/r/#/c/2235/ <- script that will enable checkstyle on verify (edwarnicke, 15:47:57)
    38. coding style process review w/ Keith (DaveBarach, 15:49:43)
    39. ACTION: Keith to send links to "how to fix coding style" wiki page to Ed (DaveBarach, 15:54:02)
    40. keith asks if we can avoid re-running verify when patches move from draft to public (DaveBarach, 15:55:49)
    41. Ed replies that he doesn't know (DaveBarach, 15:55:58)
    42. keith mentions that we should schedule a design session for early in the 16.12 release cycle (DaveBarach, 16:00:26)
    43. discuss tools to support design sessions, breakouts (DaveBarach, 16:01:13)


Meeting ended at 16:02:56 UTC (full logs).

Action items

  1. Marek to write description how to test
  2. Keith to send links to "how to fix coding style" wiki page to Ed


People present (lines said)

  1. DaveBarach (43)
  2. collabot (3)
  3. edwarnicke (2)
  4. cpaelzer (1)
  5. dwallacelf (1)


Generated by MeetBot 0.1.4.