14:28:38 <DaveBarach> #startmeeting fdio vpp
14:28:38 <collabot`> Meeting started Tue Sep 13 14:28:38 2016 UTC.  The chair is DaveBarach. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:28:38 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:28:38 <collabot`> The meeting name has been set to 'fdio_vpp'
14:36:02 <DaveBarach> #info very light turnout due to annoying meeting reschedule...
14:36:23 <DaveBarach> #topic Marek Gradzki on Honeycomb
14:36:24 <tfherbert> #info I thought meeting was at 11:00?
14:36:31 <DaveBarach> #info HC RC1 released last week
14:36:44 <DaveBarach> #info RC2 to be released next week, after vpp 16.09
14:37:04 <DaveBarach> #info feature requests to the HC team for 16.12 solicited
14:37:39 <alagalah> tfherbert: Mate
14:37:54 <alagalah> tfherbert: There was email and the wiki changed to 730am pac
14:38:12 <DaveBarach> #topic NSH / SFC Keith Burns reporting
14:38:17 <tfherbert> alagalah: OK, I am getting on now. email got buried.
14:38:31 <DaveBarach> #info Hongjun declared victory on lists
14:38:45 <DaveBarach> #info jvpp refactor complete
14:38:58 <DaveBarach> #info "everything is working"
14:39:29 <DaveBarach> #info committer vote to release w/out CSIT, doxygen complete.
14:40:23 <DaveBarach> #info ed reports doxygen infra ready for nsh/sfc project
14:40:49 <alagalah> #link https://gerrit.fd.io/r/#/c/2853/ Thanks Ed for pointing out Doxy NSH patch
14:41:13 <DaveBarach> #topic Florin reports on ONE-LISP
14:41:20 <DaveBarach> #info docs added for dataplane code
14:41:32 <DaveBarach> #info refactoring code on master for HC integration
14:42:15 <DaveBarach> #topic TLDK Ed reporting
14:42:27 <DaveBarach> #info reminder meetings at 8am PDT Wednesdays
14:43:36 <DaveBarach> #topic Ed reporting on mini-summit
14:43:45 <edwarnicke> #link https://fd.io/news/events/2016-09-26/fdio-mini-summit-open-daylight-summit <- minisummit agenda
14:44:20 <edwarnicke> #link http://events.linuxfoundation.org/events/opendaylight-summit/extend-the-experience/colocatedevents <- event page
14:44:50 <DaveBarach> #info representation across a bunch of projects
14:45:07 <DaveBarach> #topic 16.09 release
14:45:29 <DaveBarach> #info release pull tomorrow, activitites start at 2:00pm PDT.
14:46:02 <DaveBarach> #info draft patch for release notes on the way
14:46:47 <DaveBarach> #info cli guide -> doxygen docs
14:55:07 <DaveBarach> #topic Damjan on 16.12 release planning
14:55:17 <DaveBarach> #info meeting next week, info in the interim by email
15:00:33 <DaveBarach> #topic Maciek reporting on CSIT
15:00:50 <DaveBarach> #info on time / on target to release 16.09 perf reports
15:01:16 <DaveBarach> #info thank you to Pierre for working on non-repeatable vhost_user csit results
15:01:58 <DaveBarach> #info will call for help if repeatable results are not obtained in the CSIT environment
15:02:21 <DaveBarach> #info latency tests evaluating trex behavior, seems ok
15:03:07 <DaveBarach> #info hardware failures in perf testbeds
15:04:44 <DaveBarach> #info parallelizing some virl test to improve performance
15:05:55 <DaveBarach> #info "make test" report: offload anything that can be moved to this framework
15:06:06 <DaveBarach> #info need to review code, evaluate what we can move there
15:06:49 <DaveBarach> #info csit 16.09 draft report for review tomorrow / day after tomorrow
15:08:51 <DaveBarach> #topic Keith Wiles reporting on TLDK
15:09:06 <DaveBarach> #info meeting tomorrow
15:09:21 <tfherbert> #info Question about dpdk convergence? I don't know yet how much effort but can we get in the plan DPDK convergence for 16.12 or 17.3? It would be nice to get it (from the RPM perspective) down to a package dependency with a manageably small amount of patches..
15:09:26 <DaveBarach> #info difficulties using Google docs w/ work email accounts
15:10:25 <cj> FYI, vanessa and I cannot connect to webex.
15:10:45 <DaveBarach> #info Ray K answering on dpdk integration
15:11:08 <Chrisy> morning everyone
15:11:13 <tfherbert> #info Ray K, do you need any help in terms of pushing patches up and etc...?
15:11:29 <DaveBarach> #action ray to follow up specific dpdk driver upstreaming issues
15:11:47 <tmonjalo> I'm OK to assist on the issues
15:12:22 <DaveBarach> #info remider: dpdk user event in Dublin, in October; please attend / register
15:12:29 <tfherbert> #info I will be at DPDK Dublin userspace. Will be happy to have side informal discussion at least with VPP folks.
15:12:30 <tmonjalo> (sorry, I'm not in the call)
15:13:40 <tmonjalo> We can organize a mini-meeting at Dublin about VPP patches
15:14:02 <tfherbert> 10/20 and 20/21
15:14:04 <DaveBarach> #info Dublin event October 20-21 2016
15:15:34 <tmonjalo> #info Thomas Monjalon would like to have discussions at Dublin about VPP patches integration in DPDK
15:16:18 <DaveBarach> #topic Consumability
15:16:36 <cpaelzer> I'd like to at least lurk around in that vpp<->dpdk discussions to fresee what will come up for packagers in regard to this
15:16:44 <DaveBarach> #info disaster plan review
15:16:51 <cpaelzer> so if possible make that a session on the agenda and not a secret meeting
15:17:03 <tfherbert> #info Thomas yes. We need to move toward package dependency for vpp release on upstream DPDK package.
15:17:26 <alagalah> tfherbert: This is being discussed in another thread if you like I can loop you in
15:17:40 <alagalah> I believe Jerome is talking with Franck about this
15:17:58 <tfherbert> alagalah: Yes, I would...
15:18:06 <edwarnicke> tfherbert: Where are the rpm packages for inclusion in Fedora/Centos dpdk being maintained?
15:18:11 <alagalah> tfherbert: Be good to have you and dmarion looped in on that
15:18:32 <edwarnicke> (I know where they are maintained for Ubuntu: https://wiki.fd.io/view/Deb_dpdk ;) )
15:18:32 <tfherbert> edwarnicke: On our plan top priority.
15:18:42 <cpaelzer> missind a d
15:19:01 <edwarnicke> tfherbert: ?
15:19:42 <DaveBarach> #info official 16.09 release PR offset by one week, to coincide w/ Honeycomb + NSH/SFC releases
15:21:52 <DaveBarach> #info Ed points out that from the POV of mechanics, it's easier to slip 16.12 to 17.01
15:22:13 <DaveBarach> #info than it is to back up from 17.01 to 16.12
15:22:42 <tfherbert> #info Which date is better to converge with DPDK release, would 17.01 be better?
15:24:05 <DaveBarach> #action damjan to close 16.12 vs. 17.01 by the end of next week
15:24:23 <tfherbert> #info what does tmonjalo think?
15:24:47 <tfherbert> tmonjalo: ?
15:26:09 <tmonjalo> sorry, what is the question?
15:26:15 <DaveBarach> #endmeeting